none
devenv.exe vs2015 random hangs

    Question

  • Hi,

    We are currently experiencing random hangs just after devenv.exe the process started.  It happen about once every 20 builds. We are using nant.exe to call devenv.exe on command line for the build system. We have multiple team switching from vs2012 to vs2015. I don't see any error in the output windows. Nothing in the event viewer. Since it's random, like I could abort the one running and relaunch the same build and it would work.

    The build machine is configure with vs2008, vs2010, vs2012, vs2013, vs2015.

    Do you know how I could debug the problem ? or any link that would help ? I searched online but nothing that look like my problem.

    Thanks

    Wednesday, November 11, 2015 3:08 PM

All replies

  • Hi,

    Thank you for posting in MSDN forum.

    >> We are using nant.exe to call devenv.exe on command line for the build system.

    To make sure whether it is related to the nant.exe. Please launch your visual studio manually to see if it hangs.

    If it doesn't hang, I doubt that it is related to the nant.exe.

    If it also hangs, I doubt that it is related to the visual studio IDE, please take the following steps to troubleshoot this issue:

    Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files or Program Files (x86)\Microsoft Visual Studio <version number>\Common7\IDE), and run the following commands:

    a.devenv.exe /SafeMode, This can eliminate the possibility that third party Add-ins or packages are causing problems. Thus ensuring stable execution..
    b.devenv.exe /resetuserdata, it will take a couple of minutes to run as Visual Studio cleans up and sets itself back to its original state. You may open Task Manager at this point to check whether the devenv.exe process is still running. After it has completed running, you can restart Visual Studio.

    If none of the above helps, I need more detail information to troubleshoot this issue, please take the following steps to collect the log files to us:
    1. Devenv.exe /log, to start Visual Studio and log all activity to the log file. By default, the log file is: %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml
    2. Please upload the ActivityLog.xml to https://skydrive.live.com/ and share the link here.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, November 12, 2015 7:02 AM
    Moderator
  • Thanks for the tips.

    I just try just adding the /Log,I get "syntax error". If I specify the path and log filename I get a error below : 

    External Program Failed: C:\Program Files (x86)\Microsoft Visual Stu
    dio 14.0\Common7\IDE\devenv.com (return code was -1073741819)

    more output:

                Using 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\I
    DE\devenv.com' as the build system.
                Starting 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common
    7\IDE\devenv.com (/Log "D:\ws\prism\BA250_win64_01\team\gear_studio/buildfolder/
    Reports/devenv.log" "gear_studio.sln" /Build "Release|x64" )' in 'D:\ws\prism\BA
    250_win64_01\team\gear_studio\'
    
                Microsoft Visual Studio 2015 Version 14.0.23107.0.
                Copyright (C) Microsoft Corp. All rights reserved.
    
                Package 'Async Query Service Package' failed to load.
    
                Package 'Async Query Service Package' failed to load.
                D:\ws\prism\BA250_win64_01\team\gear_studio\private\tools\Beast\priv
    ate\builder\VisualStudioBuilder.build(130,12):
                External Program Failed: C:\Program Files (x86)\Microsoft Visual Stu
    dio 14.0\Common7\IDE\devenv.com (return code was -1073741819)

    I did not try /safemode yet because we need plugins during compilation. Any ideas ? 

    Sunday, November 15, 2015 4:30 PM
  • Hi,

    We need to drag the devenv.exe to the command prompt, not the devenv.com.

    Could you double click devenv.exe to open the visual studio?

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, November 18, 2015 4:41 AM
    Moderator
  • Did you find a solution for this? I am having a similar issue with our VS2015 builds using devenv.com. We build many solutions one after the other, and are regularly getting stalled builds during our nightly runs.

    When I added logging with /log and a file path, I got the "'Async Query Service Package' failed to load" message in my build output and a popup saying Visual Studio had stopped.

    Without the /log parameter, I just got random hanging builds where there were only devenv.com and devenv.exe processes running, but no MSBuild.exe or VSHub.exe.

    If I stop the stalled devenv processes, it goes to the next solution and most of the time will succeed.

    Monday, March 28, 2016 5:42 PM
  • Also have similar issues to this, anyone find a solution?
    Monday, May 23, 2016 6:02 AM