none
Create Release Annotation Azure Devops task doesn't work anymore RRS feed

  • Question

  • The Azure Devops task to create a release annotation doesn't appear to work anymore.

    Logs here:

    2020-01-24T12:01:11.9812586Z ##[section]Starting: Add release annotation to Azure Application Insights resource...
    2020-01-24T12:01:11.9968585Z ==============================================================================
    2020-01-24T12:01:11.9968585Z Task         : Release Annotation
    2020-01-24T12:01:11.9968585Z Description  : Mark releases on Application Insights timelines.
    2020-01-24T12:01:11.9968585Z Version      : 1.0.15
    2020-01-24T12:01:11.9968585Z Author       : Microsoft Corporation
    2020-01-24T12:01:11.9968585Z Help         : [Learn more about release annotations](http://go.microsoft.com/fwlink/?LinkId=717105)
    2020-01-24T12:01:11.9968585Z ==============================================================================
    2020-01-24T12:01:13.1704514Z Invoke a web request to create a new release annotation. Attempting 1
    2020-01-24T12:01:14.6570423Z Invoke a web request to create a new release annotation. Attempting 2
    2020-01-24T12:01:15.7172361Z Invoke a web request to create a new release annotation. Attempting 3
    2020-01-24T12:01:16.8004294Z Invoke a web request to create a new release annotation. Attempting 4
    2020-01-24T12:01:17.8630243Z Invoke a web request to create a new release annotation. Attempting 5
    2020-01-24T12:01:20.3960098Z ##[error]Failed to create an annotation with Id: xxx. Error Unknown, Description: Unknown.
    2020-01-24T12:01:20.4584094Z ##[section]Finishing: Add release annotation to Azure Application Insights resource...

    Friday, January 24, 2020 10:42 PM

All replies

  • Hello gregpakes,

    Thanks for reaching out!

    From what I see in the logs, it seems like the web request timed out and should be a one-off issue in that case. I was able to create a release annotation successfully using the same task with the generated Application ID and API Key as per the instructions mentioned in this doc: Release annotations with Azure Pipelines build.

    Please ensure that you have the correct Application ID and API Key configured in the pipeline as detailed in the doc and give it another try. Let me know if the issue recurs.

    Thanks again!

    Monday, January 27, 2020 5:41 AM
    Moderator
  • It’s not a one-off. It stopped working 2 months ago and hasn’t worked since.
    Monday, January 27, 2020 7:51 AM
  • Can you please confirm if the Application ID and API Key are configured properly in the Azure Pipeline?

    Also, please try enabling debug/verbose logs on the Release pipeline by setting the system.debug variable to true. You should then be able to see detailed logs in the pipeline run.

    If that's not the problem, could you please generate and configure a new API Key and re-run?

    Let me know how that goes!

    Monday, January 27, 2020 8:12 AM
    Moderator
  • Hi,

    These values are correct.  They are stored in the release pipeline and haven't changed for years.  I have even re-applied them to make sure, but it still doesn't work.

    I will enable verbose logging.

    thanks,

    Greg

    Monday, January 27, 2020 9:11 PM
  • Sure, you may even consider testing the key with CreateReleaseAnnotation PowerShell script from GitHub to test creating annotations manually.
    Tuesday, January 28, 2020 9:16 AM
    Moderator
  • Hello gregpakes, Any luck with the logs?

    Wednesday, January 29, 2020 12:20 PM
    Moderator
  • Hello gregpakes,

    Hope you've had a chance to check if any of the above options help. Let us know if there is anything else related to this thread that we can assist you with, else please feel free to mark and close this out if any of the above responses have been of help! Thanks again for reaching out!

    Saturday, February 1, 2020 4:30 AM
    Moderator