none
Word 2010 & Templates/Add-Ins RRS feed

  • Question

  • I have added a template I created via Options/Add-Ins/Templates. In that dialog (Templates and Add-ins) I also checked the check box. This check box presumably enables the template, and in fact the macro I have in that template runs as expected.

    Problem is, when I re-open Word, that checkbox is again un-checked, and therefore my macro no longer runs (Macro cannot be found or has been disabled...).

    Nothing I've tried thus far has worked. Here is what I have tried.

    1. Added the template's location to 'Trusted Locations', in this case C:\Templates
    2. Enabled all macros via Trust Center/Macro Settings
    3. Enabled "Trust access to the VBA project object model"
    4. Confirmed the template add-in is not listed as a 'Disabled Item'. 
    5. Verified I am an administrator of the computer (It's my home computer). 

    What I need to get done (work) actually has nothing to do with any of this. But I can't because Word keeps getting in my way, and is buttoned down tighter than Fort Knox.

    Anyone have an idea of what flag, check box, registry setting or hack I'm missing?

    Thank you 


    Facebook: Zamdrist
    Roleplaying: Elliquiy


    Thursday, June 16, 2011 12:58 AM

Answers

  • You can do either of two things:

    1. Move the template into the Startup folder in your profile, %appdata%\Microsoft\Word\Startup.
    2. Go to Options > Advanced > File Locations (this button is almost at the bottom of the dialog) and change the Startup location to the folder (C:\Templates) that you want to use for add-ins.

    Method 1 is obviously simpler.

    The checkbox in the Add-ins page is always retained only for the current session (which seems fairly useless to me, but I didn't design it).


    Jay Freedman
    MS Word MVP  FAQ: http://word.mvps.org
    • Marked as answer by ITMn0403 Thursday, June 16, 2011 2:20 AM
    Thursday, June 16, 2011 2:03 AM

All replies

  • You can do either of two things:

    1. Move the template into the Startup folder in your profile, %appdata%\Microsoft\Word\Startup.
    2. Go to Options > Advanced > File Locations (this button is almost at the bottom of the dialog) and change the Startup location to the folder (C:\Templates) that you want to use for add-ins.

    Method 1 is obviously simpler.

    The checkbox in the Add-ins page is always retained only for the current session (which seems fairly useless to me, but I didn't design it).


    Jay Freedman
    MS Word MVP  FAQ: http://word.mvps.org
    • Marked as answer by ITMn0403 Thursday, June 16, 2011 2:20 AM
    Thursday, June 16, 2011 2:03 AM
  • Thank you Jay, that worked (Method #1).

    Seems to me the check box only remains checked for those templates/add-ins that reside in a folder defined in 'Folder Locations', and not just any file/location, regardless if you've 'added' it.

    Again, thank you. Now I can actually do something. 
    Facebook: Zamdrist
    Roleplaying: Elliquiy
    Thursday, June 16, 2011 2:20 AM