none
BizTalk 2010 - EDIFACT D96A "Unknown" Schema even though deployed and validated RRS feed

  • Question

  • BizTalk 2010 - EDIFACT D96A "Unknown" Schema even though deployed and validated.  

    I can see the incoming DELFOR document in suspended messages and the UNB2_1, UNB2_2, UNB3_1, and UNB3_2 are matching what I have set for the party.

    In visual studio, an EDI text file of the DELFOR (received by email) validates...... But I continue to get unknown schema and suspended messages in BizTalk.

    Friday, October 13, 2017 6:31 PM

All replies

  • Hi P.Wh, 

    Could you provide any other information about this issue? we can hardly troubleshoot according to current information above. 

    Regards,

    Angie  


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, October 18, 2017 11:53 AM
  • I have a custom EDIFACT Schema.  I can validate and I got it to work once.... but the schema resolution is failing sometimes.  70: Finding the document specification by message type "http://schemas.microsoft.com/BizTalk/EDI/EDIFACT/2006#EFACT_D96A_DELFOR" failed. Verify the schema deployed properly. 

    Error: 2 (Miscellaneous error)
    71: Transaction Set or Group Control Number Mismatch

    Error: 3 (Miscellaneous error)
    29: Invalid count specified at interchange, group or message level

    .
     The sequence number of the suspended message is 2. 

    Wednesday, October 25, 2017 1:28 PM
  • I think I figured this out.  My party uses the qualifier of 1 for the X12 portion of the setup but 01 for the EDIFACT.  I used the updated qualifiers and now my transactions are working.
    Wednesday, October 25, 2017 4:38 PM