none
Failing to Install .NET 3.5 SP1, plz help?? RRS feed

  • Question

  • I am running Windows XP Media Center Edition 2002 SP 3 on a Celeron 3.2 Ghz CPU with 448 MB of RAM. My Add/Remove Programs list in the Control Panel says I currently have Microsoft .NET Framework 1.1, and Microsoft .NET Framework 1.1 hotfix (KB928366). I am trying to install .NET 3.5 SP 1 from here and I keep getting a failed install with this as my error log:

    [06/20/09,15:31:12] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [06/20/09,15:31:12] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [06/20/09,15:31:12] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [06/20/09,15:31:12] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [06/20/09,15:31:13] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [06/20/09,15:31:13] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [06/20/09,15:31:13] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [06/20/09,15:31:13] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [06/20/09,15:31:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
    [06/20/09,15:31:13] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
    [06/20/09,15:31:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.
    [06/20/09,15:31:14] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [06/20/09,16:00:48] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [06/20/09,15:31:12] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [06/20/09,15:31:12] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [06/20/09,15:31:12] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [06/20/09,15:31:12] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [06/20/09,15:31:13] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [06/20/09,15:31:13] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [06/20/09,15:31:13] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [06/20/09,15:31:13] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [06/20/09,15:31:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
    [06/20/09,15:31:13] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
    [06/20/09,15:31:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.
    [06/20/09,15:31:14] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [06/20/09,16:00:48] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [08/28/09,09:16:33] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
    [08/28/09,09:16:33] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
    [08/28/09,09:16:58] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
    [08/29/09,10:16:42] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    I am not a very tech savy person, and I have searched for information on fixing this problem, but most thngs I see have slightly different information, or involve doing things I am worried about trying. Basically if anyone is familiar with this issue, and knows what my problem is, I would appreciate some help here please.

    Thank you for your time.
    Saturday, August 29, 2009 3:47 PM

Answers

  • Just to update anyone interested.

    Turns out my problem was several corrupted setup files in the base 1.0 Framework. I had uninstalled all my .NET versions, but was still unable to install 3.5, or even 1.0 after that. Several months ago, I had a virus hit me, I took care of it, but apparently it had duplicated, moved, and corrupted some setup files, so even after I uninstalled everything, some corrupted files still existed that I didn't know about.

    However, I found a great tool to remove ALL .NET Framework files from your computer. It can be downloaded here . NOTE: This program is from an independent third party, and may cause unexpected problems to core windows programs. I am in NO WAY VOUCHING for the reliability, or safety of this program. Use it at your own risk. I however had excellent results. Immediately after running the program, I was able to install .NET 3.5 SP 1 without problems.

    So, if you have the same (or similar) problems as I had, I hope this helps you out.

    GL

    ** Individual results may vary, and I do not pretend to be a technical support specialist. I am simply sharing what worked for me. Any and all information obtained from myself, or my posts, or links in them is to be taken lightly, and implemented at your own risk. In using any information obtained from me, you are accepting total responsibility for any actions you choose to take.**

    Thank You
    • Marked as answer by xBigPoppaDx Sunday, August 30, 2009 8:39 PM
    Sunday, August 30, 2009 8:39 PM