none
Visual Studio options not sticking

    Question

  • In visual studio, I have checked the "Pretty Listing" option in the Visual Studio options.  But if I close visual studio and relaunch it, it will no longer be checked.  I'm not importing new settings or anything. Why is this value not being maintained?
    Tuesday, March 15, 2016 2:53 PM

Answers

  • Hi daustin_dev,

    Could you share me the detailed VS version information under the HELP menu->About VS?

    Do you install the update 1?

    Actually I could get that option under the "Advanced" like the following screen shot.

    But it was enabled in default.

    And it works well in my side even if I close and restart the VS.

    (1) Please reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again.

    (2) Not very sure that whether it is related to the "Synchronized Settings", but if possible, you could disable it under TOOLS->Options->Environment->Synchronized Settings. Or you could sign out the Microsoft account under the top right corner.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, March 17, 2016 7:17 AM
    Moderator

All replies

  • Hi daustin_dev,

    Which VS version did you use?

    Where can I get the "Pretty Listing" option? I test it in my VS2015 Enterprise with update 1, but I couldn't find the "VB specific" option under TOOLS->Options->Text Editor->Basic.

    But I found that it really has this option in VS2012, it was enabled in the default VS.

    And it worked well in my side no matter I disable/enable it, re-open it still has the same settings as the previous update.

    So if yours doesn't work, maybe you could check that whether it is related to the add-ins or extension tools in your side. Please also run your VS as the admin, or in safe mode, check it again.

    https://msdn.microsoft.com/en-us/library/ms241278.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 16, 2016 11:21 AM
    Moderator
  • I will try running it in safe mode.  My company does not allow us to have admin privileges.  We're using Visual Studio 2015 Enterprise Edition.  Here is the location in Visual Studio 2015

    Wednesday, March 16, 2016 11:28 AM
  • Hi daustin_dev,

    Could you share me the detailed VS version information under the HELP menu->About VS?

    Do you install the update 1?

    Actually I could get that option under the "Advanced" like the following screen shot.

    But it was enabled in default.

    And it works well in my side even if I close and restart the VS.

    (1) Please reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again.

    (2) Not very sure that whether it is related to the "Synchronized Settings", but if possible, you could disable it under TOOLS->Options->Environment->Synchronized Settings. Or you could sign out the Microsoft account under the top right corner.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, March 17, 2016 7:17 AM
    Moderator
  • we're installing update 1 soon.  Hoping that will fix it.  Synchronized settings is not checked.  I will try resetting my settings.
    Monday, March 21, 2016 1:58 PM
  • Hi daustin_dev,

    If you get any latest information, please feel free to let me know.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, March 22, 2016 2:32 AM
    Moderator