none
Could not find an existing platform WinMD location !

    Question

  • Since i updated to update 2 , i keep getting this error message

    "Error Could not find an existing platform WinMD location APPNAME C:\Program Files (x86)\MSBuild\Microsoft\.NetNative\Microsoft.NetNative.targets 416 "

    it happens only when i try to build release x64 x68 and ARM , 

    any idea why ?

    thanks

    Friday, April 22, 2016 4:23 PM

Answers

  • Hi jjosef,

    The error message you're observing is indicating that the union metadata file, which is usually at "C:\Program Files (x86)\Windows Kits\10\UnionMetadata\Windows.winmd", is not found. The union metadata file is created during installing Windows SDK or a specific platform SDK. You might be experiencing a problem about the installation of the SDK, preventing it from successfully being completed, which in turn prevents the union metadata to be successfully created. This could be a transient issue. Repairing the Windows SDK installation often addresses this issue. To repair the Windows SDK, go to Add Remove Programs, select the "Windows Software Development Kit" (pick the latest one - the one with the largest version number), click on Change, choose Repair in the upcoming wizard and follow the steps.

    Best Regards

    Tuesday, May 31, 2016 6:05 PM

All replies

  • I face the same problem and the answer above doesn't help really. The file exists and I have no idea why it should have the wrong content. I tried about everything except reinstalling windows 10. There seems to be absolutely no way to build unsiversal app store packages anymore since update 2. And there is nothing wrong with the Install of VS2015 Update 2 (I installed, deinstalled, repaired, installed again, set up new projects, everything. Meanwhile I am pretty angry about it, because I can't support my own apps anymore since that update...).

    Any other ideas?

    Monday, May 16, 2016 11:19 AM
  • Got the same problem. Debug configuration works fine, but when I want to build in release mode, it just says "Could not find an existing platform WinMD location".

    The file "C:\Program Files (x86)\MSBuild\Microsoft\.NetNative\Microsoft.NetNative.targets" exists. I even reinstalled Visual Studio, tried repairing and reinstalling specific components, but this error still occurs.

    My system also experienced this bug until it got fixed by Windows Update:

    https://connect.microsoft.com/VisualStudio/feedback/details/2558411/uwp-projects-couldnt-be-run-after-changing-storage-folder-in-settings

    Maybe there are still some side effects?

    Anyway, I'm not able to release new versions of my apps at the moment.

    Friday, May 20, 2016 8:50 PM
  • Hi jjosef,

    The error message you're observing is indicating that the union metadata file, which is usually at "C:\Program Files (x86)\Windows Kits\10\UnionMetadata\Windows.winmd", is not found. The union metadata file is created during installing Windows SDK or a specific platform SDK. You might be experiencing a problem about the installation of the SDK, preventing it from successfully being completed, which in turn prevents the union metadata to be successfully created. This could be a transient issue. Repairing the Windows SDK installation often addresses this issue. To repair the Windows SDK, go to Add Remove Programs, select the "Windows Software Development Kit" (pick the latest one - the one with the largest version number), click on Change, choose Repair in the upcoming wizard and follow the steps.

    Best Regards

    Tuesday, May 31, 2016 6:05 PM
  • I turned off the "Compile with .NET Native tool chain" and it solved the problem...bummer though.  I'm sure that's slower.
    Thursday, July 14, 2016 10:58 PM
  • I am having exactly the same issue.

    Repairing it did not work for me, the file Windows.winmd was not added to directory

    C:\Program Files (x86)\Windows Kits\10\UnionMetadata

    and I wasn't able to run app.

    So, I checked other machine and took that file from the machine that was able to build and run my app and copied the file into the directory.  That fixed the issue.


    -- d.

    Friday, October 27, 2017 8:35 PM