locked
MSBUILD : error MSB4017: Could not run the "GenerateResource" task because MSBuild could not create or connect to a task host with runtime "CLR2" and architecture "x86". RRS feed

Answers

  • Hi Thoward.tx, 

    Thanks for your post.

    Click Start>>right-click Computer>>Properties>>Advanced system settings>>click Environment Variables button to open the dialog, then under the System variables section, click New… button, type the Variable name = DISABLEOUTOFPROCTASKHOST, and type the Variable value = 1, then click Ok.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 25, 2013 8:31 AM
    Moderator

All replies

  • Hi Thoward.tx, 

    Thanks for your post.

    Click Start>>right-click Computer>>Properties>>Advanced system settings>>click Environment Variables button to open the dialog, then under the System variables section, click New… button, type the Variable name = DISABLEOUTOFPROCTASKHOST, and type the Variable value = 1, then click Ok.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 25, 2013 8:31 AM
    Moderator
  • Hi Thoward.tx, 

    If misunderstood anything, please describe your question in more detail and we will be able to provide the better responses.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, March 27, 2013 10:33 AM
    Moderator
  • It Works for me, but I had to restart the Build Service in order to get this working.
    Tuesday, April 9, 2013 9:55 AM
  • Thank you so much! Problem solved here! 
    Tuesday, October 25, 2016 7:47 PM