locked
Error using cdc RRS feed

  • Question

  • I am running with SQL Server 2016 RC3 and when executing the following I get this error:

    EXEC sys.sp_cdc_enable_table
       @source_schema = N'dbo',
       @source_name   = N'T9',
       @captured_column_list = N'T9C0,T9C1,T9C2,T9C3,T9C4,T9C5,T9C6,T9C7,T9C8,T9C9,T9C10,T9C11,T9C12,T9C13,T9C14,T9C15,T9C16,T9C17,T9C18,T9C19,T9C20', 
       @capture_instance = 'RP_T9_39_MR',
       @role_name = 'rp_user'

    Msg 2812, Level 16, State 62, Procedure sp_cdc_enable_table_internal, Line 283 [Batch Start Line 0]
    Could not find stored procedure 'sys.sp_cdc_parse_captured_column_list'.
    Msg 22942, Level 16, State 1, Procedure sp_cdc_enable_table_internal, Line 290 [Batch Start Line 0]
    Columns specified in the captured column list could not be mapped to columns in source table 'dbo.T9'. Verify that the columns specified in the parameter @captured_column_list are delimited properly and match columns in the source table.

    This works just fine with SQL Server 2014. Any ideas?


    Monday, April 25, 2016 8:47 PM

All replies

  • Hi D-Richburg,

    According to Kevin’s reply in this thread, it is a bug in SQL Server RC1 and RC2, which should be fixed in RC3.

    However, several persons still get the same error in RC3, I would recommend you submit a feedback to the Microsoft Connect at this link https://connect.microsoft.com/SQLServer/Feedback. Your feedback enables Microsoft to offer the best software and deliver superior services.


    Thanks,
    Lydia Zhang


    Lydia Zhang
    TechNet Community Support


    Wednesday, May 4, 2016 6:37 AM
    Moderator