none
System locking my debug generated .exe

    Question

  • hi, why is process "System" locking the executable I just compiled with visual studio 2015?

    if i execute my code from visual studio, it crashes...

    i can compile, but i can't execute any program!

    help please..

    thanks!


    • Edited by LorisDema Saturday, February 13, 2016 10:03 AM
    Saturday, February 13, 2016 10:02 AM

Answers

  • >hi, why is process "System" locking the executable I just compiled with visual studio 2015?

    An anti-virus product perhaps?

    Dave

    • Proposed as answer by lake XiaoModerator Tuesday, February 16, 2016 1:11 AM
    • Marked as answer by LorisDema Tuesday, February 16, 2016 8:37 AM
    Saturday, February 13, 2016 1:10 PM
  • Hi LorisDema,

    Please try the following ways:

    1.Please try running Visual Studio in Safe mode to Check whether some add-ins and extensions affect it(devenv /safemode).

    2. Follow Dave's suggestion to turn off the anti-virus software and firewall then try it again.

    If above suggestions still no help. I suppose there was something wrong with your VS2015. Try to create a new project then test it again.

    If same error occurred. I suggest you could try to repair your Visual Studio or install the VS2015 Update1.

    Best Regards,

    Lake Xiao

    • Proposed as answer by lake XiaoModerator Tuesday, February 16, 2016 1:12 AM
    • Marked as answer by LorisDema Tuesday, February 16, 2016 8:37 AM
    Monday, February 15, 2016 5:51 AM
    Moderator

All replies

  • >hi, why is process "System" locking the executable I just compiled with visual studio 2015?

    An anti-virus product perhaps?

    Dave

    • Proposed as answer by lake XiaoModerator Tuesday, February 16, 2016 1:11 AM
    • Marked as answer by LorisDema Tuesday, February 16, 2016 8:37 AM
    Saturday, February 13, 2016 1:10 PM
  • Hi LorisDema,

    Please try the following ways:

    1.Please try running Visual Studio in Safe mode to Check whether some add-ins and extensions affect it(devenv /safemode).

    2. Follow Dave's suggestion to turn off the anti-virus software and firewall then try it again.

    If above suggestions still no help. I suppose there was something wrong with your VS2015. Try to create a new project then test it again.

    If same error occurred. I suggest you could try to repair your Visual Studio or install the VS2015 Update1.

    Best Regards,

    Lake Xiao

    • Proposed as answer by lake XiaoModerator Tuesday, February 16, 2016 1:12 AM
    • Marked as answer by LorisDema Tuesday, February 16, 2016 8:37 AM
    Monday, February 15, 2016 5:51 AM
    Moderator
  • it seems that the culprit was the antivirus.

    i added visual studio's folder to the exceptions list.

    thank you everybody!

    Monday, February 15, 2016 10:55 AM
  • >it seems that the culprit was the antivirus.

    They often are :)

    Glad it helped.

    Dave

    Monday, February 15, 2016 11:56 AM
  • Hi LorisDema,

    Glad to hear you have found the cause of your issue.

    If possible,  please mark the reply as the answer which is helpful, so it would be helpful for other members who get the same issue as yours to research and find the answer directly, and I could close this case.

    Have a nice day.

    Best Regards,

    Lake Xiao

    Tuesday, February 16, 2016 1:12 AM
    Moderator