none
.NET 3.5 SP1 Installation fails on Windows 7 RRS feed

  • Question

  • I need to install .NET Framework 3.5 SP1 on Windows 7 64 bit. Therefore I downloaded the installer "dotnetfx35setup.exe" (size 2,82 MB) which I found here: http://www.microsoft.com/en-us/download/details.aspx?id=2

    The problem is that when I run "dotnetfx35setup.exe"  nothing happens.

    For additional information, in the Windows program list there is no .NET already installed  and in Windows Features I can see .NET Framework 3.5.1 marked as enabled.

    What could it be the problem's cause?


    • Edited by alesxx88 Tuesday, November 25, 2014 8:53 AM
    Tuesday, November 25, 2014 8:53 AM

Answers

  • Your attempt to install .NET 3.5 SP1 failed because it was installed as part of your Windows 7 OS.

    What leads you to think it's not there?

    You state: "in Windows Features I can see .NET Framework 3.5.1 marked as enabled."

    That is normal and correct.

    To verify the integrity of your .NET 3.5 SP1, use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please run the tool with .NET 3.5 selected, then post the first 12 lines AND the last 12 lines of the tool log here.

    The log will show if there is any issue with your .NET 3.5.

    • Marked as answer by Anna Cc Wednesday, November 26, 2014 6:48 AM
    Tuesday, November 25, 2014 3:25 PM

All replies

  • Your attempt to install .NET 3.5 SP1 failed because it was installed as part of your Windows 7 OS.

    What leads you to think it's not there?

    You state: "in Windows Features I can see .NET Framework 3.5.1 marked as enabled."

    That is normal and correct.

    To verify the integrity of your .NET 3.5 SP1, use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please run the tool with .NET 3.5 selected, then post the first 12 lines AND the last 12 lines of the tool log here.

    The log will show if there is any issue with your .NET 3.5.

    • Marked as answer by Anna Cc Wednesday, November 26, 2014 6:48 AM
    Tuesday, November 25, 2014 3:25 PM
  • I didn't know that .NET 3.5.1 includes .NET 3.5 SP1.

    After having run the tool you suggested, I verified that I actually have .NET 3.5 SP1.

    Tuesday, November 25, 2014 3:55 PM
  • Thank you for letting us know your issue is resolved :-)

    If you have any additional questions, please don't hesitate to ask.

    Tuesday, November 25, 2014 11:53 PM
  • Hello,

    I want to setup ms sql 2012, and it asks for .net framework 3.5 sp1, but ı cant fix the problem. ı checked the control panel, but ıt does nothing. please help, thanks.


    • Edited by h044574 Sunday, April 26, 2015 9:59 AM
    Sunday, April 26, 2015 9:58 AM
  • In future, please start a new thread for you issue. Because this thread is already closed, many will not even see your post.

    To start, more information is needed.

    What is your Windows version?

    To verify the integrity of your .NET 3.5 SP1, use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please run the tool with .NET 3.5 selected, then post the first 12 lines AND the last 12 lines of the tool log here.

    The log will show if there is any issue with your .NET 3.5.


    • Edited by pvdg42 Sunday, April 26, 2015 4:27 PM
    Sunday, April 26, 2015 4:25 PM