locked
Error when running csupload Set-Connection RRS feed

  • Question

  • I am a member of the VM Role Beta.  I am trying to upload a VM to Windows Azure. When I run the csupload Set-Connection command, I get the following error:

    "The certificate (with thumbprint XXX) is missing a required private key."

    I followed the instructions on how to generate the certificate using makecert.exe.  Then I uploaded it to my personal certificate store.

    What does this error mean and what can I do to resolve it?

     

    Monday, March 21, 2011 11:09 AM

Answers

  • Hi HarrisTX,

    It's possible that the command console doesn't have permission to access the certificate private key. You may try running command console with Administrator account and run csupload again.

    If you still get same error message by above method, I think that your certificate store indeed doesn't contain your required certificate's private key. You may try following this blog to regenerate and reupload the management certificate.

    http://www.davidaiken.com/2009/12/21/how-to-create-a-x509-certificate-for-the-windows-azure-management-api/

    Thanks,

     


    Mog Liang
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Proposed as answer by Mog Liang Monday, March 28, 2011 9:29 AM
    • Marked as answer by Mog Liang Friday, April 1, 2011 8:55 AM
    Tuesday, March 22, 2011 2:21 AM
  • Install the certificate using pfx file and not cer file. It will fix the problem. I hope you have the .pfx file for the concerned certificate? Else generate a new one, upload it to portal as management certificate and also install on your machine
    If this post answers your question, please mark it as an answer. If this post is helpful to you, then vote it as helpful.
    TechyFreak | Mobile Development Resources
    • Marked as answer by Mog Liang Friday, April 1, 2011 8:55 AM
    Tuesday, March 29, 2011 11:50 AM

All replies

  • When you use makecert to generate a certificate, it creates a .cer file *and* also installs the certificate in a certificate store that you specify using the -ss parameter. You don't need to import the .cer file yourself. Could it be that importing it again may be overwriting the certificate that makecert generated and since a .cer file does not have a private key, be the reason that csupload fails to find one?

    Another possibility is that you exported the certificate from your store after creating it and checked the option to "Delete the private key if the export is successful".

     

    Monday, March 21, 2011 1:01 PM
  • Hi HarrisTX,

    It's possible that the command console doesn't have permission to access the certificate private key. You may try running command console with Administrator account and run csupload again.

    If you still get same error message by above method, I think that your certificate store indeed doesn't contain your required certificate's private key. You may try following this blog to regenerate and reupload the management certificate.

    http://www.davidaiken.com/2009/12/21/how-to-create-a-x509-certificate-for-the-windows-azure-management-api/

    Thanks,

     


    Mog Liang
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Proposed as answer by Mog Liang Monday, March 28, 2011 9:29 AM
    • Marked as answer by Mog Liang Friday, April 1, 2011 8:55 AM
    Tuesday, March 22, 2011 2:21 AM
  • Install the certificate using pfx file and not cer file. It will fix the problem. I hope you have the .pfx file for the concerned certificate? Else generate a new one, upload it to portal as management certificate and also install on your machine
    If this post answers your question, please mark it as an answer. If this post is helpful to you, then vote it as helpful.
    TechyFreak | Mobile Development Resources
    • Marked as answer by Mog Liang Friday, April 1, 2011 8:55 AM
    Tuesday, March 29, 2011 11:50 AM