locked
Add Service Reference for OData service gives "Could not load file or assembly 'Microsoft.Data.Services.Design' RRS feed

  • Question

  • I was following this tutorial for OData using WCF data services.  On the last step of the tutorial trying to "Add Service Reference" to the OData service that I already created that is working (verified using Fiddler), the error below pops up in Visual Studio UI.

    Could not load file or assembly 'Microsoft.Data.Services.Design, Version 5.3.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependancies. The system cannot find the file specified.

    I've tried getting the latest WCF updates and OData (which should not be needed for the client) using NUGet and also installing WCF 5.3, 5.5 and 5.6 in VS2012 and VS2013 RC and got the same result.

    I also could not find any files on disk that reference this ell. This appears to be an internal DLL used by VS to generate code based on MSDN and is not even supposed to be utilized by developers.


    Bob King

    Saturday, October 5, 2013 7:55 PM

Answers

  • Hello,

    For this, my suggestion is that we can do the test at anther PC with same environment to see if it will throw the same exception.

    Or we can reinstall the VS and then follow  this tutorial for OData using WCF data services.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, October 15, 2013 7:58 AM
    Moderator

All replies

  • To get the Visual Studio ASR experience working, you need to install OData tools in your box from here. You just need one version installed - just install 5.6 tools and that should get it going.

    Thanks

    Pratik


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 9, 2013 5:13 PM
    Moderator
  • I had already done that using the pre-RTM 5.6.0 version.  I just uninstalled and re-installed again using WCF 5.6.0 RTM and got the same tool error.

    Bob King

    Wednesday, October 9, 2013 8:41 PM
  • Hello,

    For this, my suggestion is that we can do the test at anther PC with same environment to see if it will throw the same exception.

    Or we can reinstall the VS and then follow  this tutorial for OData using WCF data services.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, October 15, 2013 7:58 AM
    Moderator