locked
Second Preview of Office Dev Tools for Visual Studio 2015 RRS feed

  • Question

  • Does anyone know if there is anything new in this in regards to Cloud Business Apps?

    https://visualstudiomagazine.com/articles/2016/04/28/office-dev-tools-vs-2015-preview-2.aspx

    https://blogs.msdn.microsoft.com/visualstudio/2016/04/26/the-latest-of-microsoft-office-developer-tools-office-add-in-commands-and-sharepoint-2016-support/


    A Fleet

    Friday, April 29, 2016 8:47 AM

Answers

  • OK, If you have installed the correct version try disabling extensions on startup of a new project. It could well be that one of those extensions is not compatible with the new update and is throwing the error that you are seeing.

    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)


    visualisation of the words :)
    • Edited by Otis Ranger Thursday, May 5, 2016 4:03 PM added pretty picture
    • Proposed as answer by Angie Xu Monday, May 9, 2016 2:44 AM
    • Marked as answer by Angie Xu Monday, May 9, 2016 2:44 AM
    Thursday, May 5, 2016 3:59 PM

All replies

  • I do not know but I am hoping a stable version of LightSwitch for VS 2015 with this update 2 I cannot get update 1 to run.
    Monday, May 2, 2016 12:47 AM
  • I got the following errors even loading a LS VS 2015 project I just built this afternoon.

    Monday, May 2, 2016 12:52 AM
  • Tried a new project and now get the same warning and a final message box that says it is not compatible with my version of windows or visual studio or both. I am running the latest build of windows 10 and is says to upgrade. A Link for compatibility sends me to MSDN's default page. https://msdn.microsoft.com/en-us/default.aspx

    Monday, May 2, 2016 12:58 AM
  • It is totally unstable now I cannot even create a Lightswitch project. I can select one I can name one but once it starts to load the solution after I press ok for creating it failure utter failure. I've done a full shutdown and restart of my machine nothing now I get this little error.

    Monday, May 2, 2016 1:11 AM
  • Hi Reigh7

    I think the issue you are having is that you have installed the Preview 2 for "15" (the un released update to VS 2015) onto your VS Community 2015 install.


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    • Proposed as answer by Otis Ranger Tuesday, May 3, 2016 1:18 PM
    • Unproposed as answer by Otis Ranger Thursday, May 5, 2016 3:59 PM
    Tuesday, May 3, 2016 1:18 PM
  • Otis at this site I read this quote with the following link to install it on VS 2015.

    "As a Visual Studio user, you can get started right away and take advantage of all the new Office extensibility goodness inside the IDE.

    Wednesday, May 4, 2016 1:53 AM
  • OK, If you have installed the correct version try disabling extensions on startup of a new project. It could well be that one of those extensions is not compatible with the new update and is throwing the error that you are seeing.

    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)


    visualisation of the words :)
    • Edited by Otis Ranger Thursday, May 5, 2016 4:03 PM added pretty picture
    • Proposed as answer by Angie Xu Monday, May 9, 2016 2:44 AM
    • Marked as answer by Angie Xu Monday, May 9, 2016 2:44 AM
    Thursday, May 5, 2016 3:59 PM
  • I don't know I did not uninstall or disable any extensions but I did re install everything again out of frustration trying to revert to version 1. I found out though that I only had access to version two. I had tried reinstalls with version 1 too and nothing was ever stabile but now with this fresh install of VS and LS templates things seems to be working the only thing I find annoying now is I have to hit run and then manually go to the "browser link dashboard" and click view in browser for it to show anything (see picture below). I will know more once I build a basic project with some data and screen to see how it works with 2015. I have been avoiding upgrading my most involved projects since 2012 because of lack of extension support.

    Friday, May 6, 2016 10:51 AM