none
July 17, 2015: New Dev Center (July migration): Windows Phone 7.1 XAP update crashes on all Windows Phones RRS feed

  • Question

  • Hi Everyone,

    The issue appeared a couple of days ago (July 15, 2015) when my Dev account has been migrated to the new Dev Center dashboard

    I decided to update my app:

    I have 2 separate packages: one (XAP) for all Windows Phone devices and the second one (.appxupload) is for Windows 8.1 devices.

    I prepared the game update, tested it, submitted to the store.

    It has PASSED the certification so I published it.Then users started to receive the update on WP7 and WP8.

    - On WP7 the app tries to be updated but fails (on install stage)

    - On WP8 devices the app is updated but crashes on start.

    0) The XAP from the update works fine if I deploy it directly to my device so I don't think that there is any problem with it
    1) I can't use the old dev center to update the game again to fix the problem myself.
    2) There is no option to rollback the latest update

    3) I've contacted Dev Center support but this process seems to be extremely slow: I submitted a ticket more than 24 hrs ago and I was just asked to provide screenshots of the Dev Center since then.
    4) How the app could pass the certifcation if it doesn't work?

    Does anyone else experience the same problem? How can I speed up the processing of my support ticket?


    • Edited by KozTv Friday, July 17, 2015 3:06 PM fixed typos
    Friday, July 17, 2015 2:57 PM

All replies

  • Hi,

    I have an update. Probably it will be useful for someone.

    It looks like the root cause of the issue is in some changes in the app manifest format for the apps submitted via the new Dev Center.

    I was able to fix the app crash on at least Windows Phone 8 devices simply by stopping retrieving ProductID from the manifest inside my app (it is used for sharing the link to the app).

    WP7 devices still can't install the application (I think because of the unknown manifest format) - I can't fix it by myself.


    • Edited by KozTv Monday, July 20, 2015 8:40 AM minor corrections
    Sunday, July 19, 2015 11:40 AM
  • Hello KozTv,

    We had similar situation to yours - we've tried to get some data from our manifest and after last update of Microsoft market, they changed something in the publishing process. It is not possible to get any data from application manifest. I can see two options: manifest is renamed or packed into other container. Either way, they shouldn't remove access to a file of that importance without noticing community about that kind of change.
    Your info helped us to investigate this problem, thank you.

    Cheers,
    Marek
    Wednesday, July 29, 2015 7:13 AM
  • Hi KozTv and Marek,

    could you please provide the APP ID for which you are having issues? we will take a look.


    thanks, palash biswas [MSFT]

    This posting is provided "AS IS" with no warranties and confers no rights.


    Wednesday, July 29, 2015 7:23 AM
  • 2 weeks since I reported the issue...

    The problem is still there.
    I receive one response from the support per 1-2 business days.

    I also see that users and other developers are posting about the same issue:
    Developers: http://stackoverflow.com/questions/31615054/windows-phone-7-gets-error-c101b000-after-downloading-50-from-marketplace/31693875#31693875
    Users: http://answers.microsoft.com/en-us/mobiledevices/forum/mdlumia-mdapps/lumia510-code-c101b000/ce8b4233-a867-4f8b-bf75-8699aeacc24e?rtAction=1438153477994
    Users also post in social networks and in their negative reviews to the affected apps.

    Looks like many people are affected. Some people get c101b000 error. Some just see 50% downloading and then "Attention require"

    I was also told that when a user contact Microsoft consumer support about the issue they say that the issue is most probably caused by the affected application's developer (it means by me)

    Wednesday, July 29, 2015 8:26 AM
  • We have the same problem with our apps on WP7 after last update of Microsoft dashboard.

    App-ID: 31e71f44-6156-440d-b815-16e701b54d44

    The same xap uploaded before the last dashboard update works fine with wp7-phones.


    Wednesday, July 29, 2015 9:38 AM

  • I was also told that when a user contact Microsoft consumer support about the issue they say that the issue is most probably caused by the affected application's developer (it means by me)

    How would an install issue from the store to a phone be an application developer's fault?

    In our case, we released an update to our application that was written for Windows Phone 7 and works on Windows Phone 8 with backward compatibility.  We have not created a Windows Phone 8 version of the application.  This update installs without problems on Windows Phone 8 devices, but fails to update or install on Windows Phone 7 devices since we updated the application after the dashboard change.  The two Windows Phone 7 devices we have to test are an HTC Trophy and an HTC HD7, both running OS version 7.10.8862.144.  Both devices get the same c101b000 error when updating.  I removed the application from one and tried a fresh install and the error remains the same.

    Has anyone tried to create a simple "Hello World" application and publish that as a beta version?  Could it hang from one of the access capabilities being used in the application?

    Wednesday, July 29, 2015 9:48 AM
  • We have identified a potential issue, on our end with WP7 XAPs, which is preventing installation of XAPs on WP7.1 devices. We are working on to resolve it ASAP. I will update this thread once we will have the fix ready and deployed. Sorry again for the inconvenience.

    thanks, palash biswas [MSFT]

    This posting is provided "AS IS" with no warranties and confers no rights.

    Thursday, July 30, 2015 2:25 AM
  • UPDATE - Fix has been deployed. Unfortunately you need to re-upload and re-submit your WP7/WP7.1 XAPs to get it resolved.

    thanks, palash biswas [MSFT]

    This posting is provided "AS IS" with no warranties and confers no rights.

    Saturday, August 1, 2015 3:40 AM
  • The fix doesn't seem to be working correctly.

    Having re-submitted today I'm getting "This app is not available for your phone"

    This is a problem I was having before on legacy WP7 beta submissions, but yesterday on this appid I had a consistent c101b000 error. I get the same error now trying to download on WP8. So now I can't do a beta release to either device...

    Hoping this was the end, I re-submitted today and I'm back to "This app is not available for your phone".

    With the download slot still active, I have been able to select it in the list and attempt to download it. I am still getting c101b000 errors.


    • Edited by vasarik Saturday, August 1, 2015 12:11 PM
    Saturday, August 1, 2015 11:56 AM
  • Tonight I've just tried to publish something marked just as "Hide this app in the Store. Customers with a direct link to the app’s listing can still download it"

    This doesn't download in WP7 or WP8 for the same reason: appid=e9b4ed17-0fbd-48ad-8eab-ae2b8f3be159

    So I'm guessing we can't release anywhere to any platform now.


    • Edited by vasarik Saturday, August 1, 2015 10:44 PM
    Saturday, August 1, 2015 10:43 PM
  • Hi Vasarik,

    The issue (that was fixed later on), was impacting WP7 only. However since you are receiving the error on WP8 as well - it may be a different issue. We will definitely take a look. Are you getting this error for all of your apps?


    thanks, palash biswas [MSFT]

    This posting is provided "AS IS" with no warranties and confers no rights.

    Tuesday, August 4, 2015 2:50 AM
  • Hi Palash,

    "Are you getting this error for all of your apps?"

    Oh, no. The ones that were published before the migration appear fine.

    There is this beta release which it is being seen on appid=ee603cbe-4085-4015-b492-68fc8736ac5f when it redirects, sometimes it takes me to the marketplace page and doesn't redirect to the mobile download. The fact it's a beta and shouldn't be available from a browser doesn't seem to bother it.

    Then I appid=dd2d56a9-494d-4388-93af-a02dd2903e78 giving me c101b000 and is also visible in the browser (and as a beta I'm not sure it's meant to be)

    I also have appid=8d32963a-fb83-4caf-acff-e68f9df458b0 which is giving me "CAN'T DOWNLOAD
    Sorry, you don't have permission to download this app." (Another visible beta app)

    I have also appid=0627f52c-eee2-4c96-9626-6f591b7d8e88 which is particularly interesting.

    Another Beta release, I updated it both on Saturday and Sunday with a basic "Hello World" app, and while DevCenter seems quite happy it has replaced it, the size it is reporting is still the size of the app 2 submissions ago.

    So far, since the migration I've only managed to release 1 app to 1 device family, and a second submission for the same app then rendered the "This app is not available for your phone", which was basically just the resubmission based on the idea that this was now fixed for WP7. So I'm guessing there is a problem with subsequent submissions, but it's impossible to say from here. I've already created 4 new apps, with countless submissions to try and understand this issue over the last 19 days, and it's making a mess of my devcenter.

    Tuesday, August 4, 2015 9:47 AM
  • There were some issues with Beta Apps which have been resolved.

    https://social.msdn.microsoft.com/Forums/windowsapps/en-US/62799749-06cb-477c-848a-daa77f65d992/resolved-issues-installing-beta-apps?forum=wpsubmit


    thanks, palash biswas [MSFT]

    This posting is provided "AS IS" with no warranties and confers no rights.

    Wednesday, August 5, 2015 2:24 AM
  • I haven't tried all of failing apps yet, but those two fixes seem to have solved all my problems, thanks!

    Thursday, August 6, 2015 12:23 AM
  • I've re-uploaded my app after the fix (August 01, 2015) deployment. I don't observe the installation problem on WP7 for clean installs. However the app was failing to install as an update with the same symptoms on my test WP7 device. I had to remove the app before updating it to succeed.


    • Edited by KozloTv Monday, August 10, 2015 7:37 AM
    Monday, August 10, 2015 7:36 AM