none
SharePoint: Error - Error occurred in deployment step 'Activate Features': Cannot complete this action. (VS 2010) RRS feed

  • Question

  • Hi all, I'm New to Sharepoint and I just Created a simple list definition in Visual Studio.

    I Deployed and it worked fine..

    I added another list definition to my solution but later deleted it.

    Now it wont deploy and it will not give me a reason..

    It just states: SharePoint: Error - Error occurred in deployment step 'Activate Features': Cannot complete this action.  line 0 , column 0.

    Thursday, July 7, 2011 4:17 PM

Answers

  • Thanks Alot Chris!

    I found that there was a naming conflict in one of the schemas, and I was able to resolve the issue. 

    • Marked as answer by JG525 Friday, July 8, 2011 3:41 PM
    Friday, July 8, 2011 3:41 PM

All replies

  • Hi JG525,

     

    Make sure that the old definition/feature is no longer being referenced in the Package. You can do this by double clicking on the Package.package file through the Visual Studio Solution Explorer. That will consequently open up the Package designer which provids the "Items in the Package" list. If you find a reference to the old definition and/or feature then remove it.

     

    HTH,

     

    Chris

    Thursday, July 7, 2011 6:34 PM
  • Thanks Alot Chris!

    I found that there was a naming conflict in one of the schemas, and I was able to resolve the issue. 

    • Marked as answer by JG525 Friday, July 8, 2011 3:41 PM
    Friday, July 8, 2011 3:41 PM