none
.NET Framework 4.8 not showing in control panel RRS feed

  • Question

  • Went to Control Panel to check if it is enabled but found that framework 4.8 itself is missing.

    

    But I can see that .Net Framework 4.8 is installed in my machine.

    Any help would be deeply appreciated.

    Thursday, October 3, 2019 9:51 AM

All replies

  • Hi harish,

    Welcome to the MSDN forum.

    What’s your OS version? Please have a look at this doc: .NET Framework 4.8 is available on Windows Update, WSUS and MU Catalog

    We can go to Control Panel-Uninstall a program-View installed updates to check the .NET Framework 4.8 and it should display like KBxxxxxxx per your OS edition.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, October 4, 2019 1:37 AM
    Moderator
  • Hi harish,

    Do you have any updates? If you still cannot found the .NET Framework 4.8 on your computer, please feel free to let us know.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, October 7, 2019 8:58 AM
    Moderator
  • Hi Sara,

    I am facing same problem and I can't find KBBXXX in control panel. Is it a common problem that 4.8 gets added in registry key but is not in list of installed packages? I am not able to find 4.8 even in Visual Studio installed components. I need to install a lower version for my app to work. Can you help?

    Tuesday, August 25, 2020 5:11 AM
  • .NET Framwork 4.8 was included in Windows 10 since version 1903:
    .NET Framework versions and dependencies
    You can not downgrade without downgrading the OS, too.

    what is stopping you from making your app compatible with the current version of the framework?

    Tuesday, August 25, 2020 3:04 PM
  • Thank you Eckis for reply. It will take time and lot of effort for a big size project to upgrade to later version of .Net.

    Is there anyway lower .Net version can be installed even if higher version is installed? Is there any command line option or something which can bypass checking of installed higher version?

    Tuesday, August 25, 2020 4:41 PM
  • 4.8 is backwards compatible to all 4.x versions.
    against what version was your app compiled, what error do you get when you try to run it?
    Tuesday, August 25, 2020 6:08 PM