locked
Dependencies to NuGet packages RRS feed

  • Question

  • User36375 posted

    This is a general question about dependencies to NuGet packages but I'll give you my specific case.

    I'm using Acr.XamForms.Userdialogs (https://github.com/aritchie/userdialogs) which needs Acr.Userdialogs which has a dependency on

    In general I want to keep my Xamarin.Forms and Xamarin.Android.Support etc updated to the latest stable release but due to the above constraint I cannot. I get the following:

    Unable to resolve dependencies. 'Xamarin.Android.Support.Design 23.4.0' is not compatible with 'Acr.UserDialogs 5.2.2 constraint: Xamarin.Android.Support.Design (>= 23.0.1.3 && < 24.0.0)', 'Xamarin.Forms 2.0.1.6498 constraint: Xamarin.Android.Support.Design (= 23.0.1.3)'. ========== Finished ==========

    If I want to keep using the published NuGet packages am I stuck on my current version of Android.Support until such a time that Acr.Userdialogs gets updated?

    Thanks, Fergus

    Friday, June 24, 2016 8:38 AM

Answers

  • User187527 posted

    The constraint you're hitting isn't Acr.UserDialogs. The constraint you are hitting is with Xamarin Forms 2.0.1 being hard set to 23.0.1.3. Acr.UserDialogs allows any support library from that version but less than 24.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, June 24, 2016 3:17 PM

All replies

  • User187527 posted

    The constraint you're hitting isn't Acr.UserDialogs. The constraint you are hitting is with Xamarin Forms 2.0.1 being hard set to 23.0.1.3. Acr.UserDialogs allows any support library from that version but less than 24.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, June 24, 2016 3:17 PM
  • User36375 posted

    @AllanRitchie said: The constraint you're hitting isn't Acr.UserDialogs. The constraint you are hitting is with Xamarin Forms 2.0.1 being hard set to 23.0.1.3. Acr.UserDialogs allows any support library from that version but less than 24.

    Thanks Allen (both for the answer and the UserDialogs). I had seen that it should support any version < 24. I'm still a bit confused. The only version of Xamarin Forms I have in my solution is 2.3.0.49 - any idea where this 2.0.1 reference comes from? Forgive the question but I'm new to both Xamarin and NuGet packages.

    Fergus

    Friday, June 24, 2016 3:48 PM
  • User187527 posted

    No idea. I suggest taking a look at the "Consolidate" tab when looking at nuget installation packages across the solution

    Friday, June 24, 2016 3:52 PM
  • User36375 posted

    Ok, so it seems Xamarin Forms 2.3.0.49 itself has a dependency to Xamarin.Android.Support.Design 23.3.0. I had assumed that the latest Xamarin Forms would be compatible with the latest Xamarin.Android.Support which doesn't seem to be the case. Interesting!

    Thanks again!

    Friday, June 24, 2016 4:07 PM