locked
"http://schemas.microsoft.com/.NetConfiguration/v2.0" RRS feed

  • Question

  • User-220424742 posted

    I am trying to deploy my web site. I copied all of the files over to the server and installed .Net 2.0. When I try and run the project through Visual Web Developer Express I get the following error...."Could not find schema information for the element "http://schemas.microsoft.com/.NetConfiguration/v2.0" I realize this is the configuration xmlns from the web.config file. but all the documentation I can find says this is what is supposed to be there. Can anyone help me please. I don't know what to do at all.

     

    Thanks so much!!

    Tuesday, April 11, 2006 10:23 AM

All replies

  • User-1634877164 posted

    Hi Spartacus,

    You can remove the XMLNS element from the root <configuration> element.  This was a bug in VS that caused it to get added.  You can safetly remove it and everything will work fine.

    Hope this helps,

    Scott

    Wednesday, April 12, 2006 12:31 AM
  • User-884404548 posted
    This is not good advice.  The problem is that IIS defaults to .NET 1.1 (even if .NET 2 is installed after IIS) - this error is generated from the 1.1 framework.  Removing the xmlns tag gives you:

    Parser Error: Unrecognised configuration section 'connectionStrings'

    This error message may change depending on what .NET 2.0 features are in the web.config file.  The footer of the error page specifically mentions 1.1.4322

    The answer needed is: How can you programmatically change the default .NET version for a website (or, even, why does the VS-generated installer not fix this for me?)

    Ewan (dreaming of .htaccess simplicity...)
    Thursday, April 20, 2006 10:14 AM
  • User-1634877164 posted

    There are two separate issues in the thread:

    1) The first issue from above is related to the VS intellisense engine having issues with the xmlns: attribute.  This is a design-time issue, and is fixed by removing the namespace.

    2) The issue that you have above ewan is at runtime, and is caused because you are deploying a V2.0 application in an application directory configured to use V1.1 instead.  That is why it isn't recognizing any of the new schema tags in V2.0.

    To fix #2, go into the IIS admin tool (inetmgr) and pull up the properties for the application you are deploying the app into.  You can then click on the "ASP.NET" tab in the properties window and map the application to use V2.0 instead of V1.1.  This error will then go away.

    Hope this helps,

    Scott

    P.S. By default we don't upgrade V1.1 apps to use V2.0 to avoid breaking existing applications.  So if you already had V1.1 installed, the default site (and by default apps created under it) will be V1.1 unless you map them to use V2.0.

    Thursday, April 20, 2006 1:18 PM
  • User-884404548 posted

    2) The issue that you have above ewan is at runtime, and is caused because you are deploying a V2.0 application in an application directory configured to use V1.1 instead.  That is why it isn't recognizing any of the new schema tags in V2.0.

    To fix #2, go into the IIS admin tool (inetmgr) and pull up the properties for the application you are deploying the app into.  You can then click on the "ASP.NET" tab in the properties window and map the application to use V2.0 instead of V1.1.  This error will then go away.



    And how can I get my MSI file to do this?  There is no API call anywhere that I can find that lets me set this.  I'm trying to deploy a medical ASP.NET 2.0 web-application, so cannot really expect the users to be able to open IIS manager.

    Ewan
    Friday, April 21, 2006 7:15 AM
  • User-1634877164 posted

    Hi Ewan,

    What you'd want to-do within your MSI is author a custom action to change the version of the application/virtual directory that was installed. 

    If you can launch a command-line app from within your MSI, then one option would be to use this command-line utility that is installed with every copy of ASP.NET 2.0:

    c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe

    You can pass arguments to the utility to cause it to map a specified application or vroot to use a specific version.

    Hope this helps,

    Scott

    Friday, April 21, 2006 7:13 PM
  • User-884404548 posted
    Scott,

    Thanks very much.  That's solved the deployment problems.

    Ewan
    Monday, April 24, 2006 5:32 AM
  • User86908308 posted

    Hi all,

    I think i have the same bug...

    In fact, it's when i want to use the Web site Administration tool that the problem appears...

    My <configuration> tag is replace by this one :

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    I have reading this : http://groups.google.de/group/microsoft.public.dotnet.framework.aspnet/browse_thread/thread/12152d90b4f6398c/076c50ae9d71f18f?lnk=st&q=web.config+author%3AJooss&rnum=1&hl=de

    but i still don't have any soluce for fixing this bug..Could someone help me please ?!! :'(

     

    Wednesday, August 2, 2006 7:22 AM
  • User-1634877164 posted

    This blog post here should help: http://weblogs.asp.net/scottgu/archive/2005/12/02/432077.aspx

    Thanks,

    Scott

    Thursday, August 3, 2006 1:46 AM
  • User86908308 posted

    Yosch !!!!!!!!!

    Thanks Scott and Thanks to Massimo too :')

    i have definitively resolve my problem.

    Thursday, August 3, 2006 5:35 AM
  • User284795505 posted

    I had this problem also.  This answer is the one I needed.  Thanks!!

    Wednesday, January 7, 2009 6:25 PM
  • User-1196875972 posted

     hi scott,

    i am practicing first WCF application of professional-WCF by wrox publication.

    i m using VS2008.

    sorry, if Query is very simple for u.

    i got the error

     A name was started with an invalid character. Error processing resource 'http://localhost/WCFServiceDemo/Service.svc'. Lin...

     <% @ServiceHost Language=C# Debug="true" Service="MyWCFService"
    -^

     i think this is because of web.config using

    <

    configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    can u please help me out. 

    Wednesday, August 26, 2009 3:19 AM
  • User-1196875972 posted

    hi scott,

    the problem is resolved.

    the asp.net was not registered with the iis .

    I ended up entering the following lines into the Visual Studio command
    prompt:

    aspnet_regiis -i

     

    Thanks.

    Wednesday, August 26, 2009 4:47 AM