none
HELP! MDS is broken after update to SQL 2012 SP4 RRS feed

  • Question

  • Hi,

    I recently updated our SQL server to SQL 2012 SP4 (from SP1) and ever since, MDS has not been working. I went to Configuration Manager and it said the database required an upgrade (from 11.2.0.0) but when I click on the Upgrade button I get the below error which I can't decipher nor find anywhere on Google:

    Microsoft.MasterDataServices.Configuration.ConfigurationException: Unable to locate the embedded resource. ---> System.IO.FileNotFoundException: Unable to locate the embedded resource.
       at Microsoft.MasterDataServices.Configuration.DatabaseUtilities.UpgradeMasterDataServicesDatabase(SqlConnection connection, String databaseName, Collection`1& businessRuleExclusionWarnings)
       at Microsoft.MasterDataServices.Configuration.Commands.UpdateMasterDataServicesDatabase.InternalProcessRecord()
       at Microsoft.MasterDataServices.Configuration.Commands.ConfigurationCmdlet.ProcessRecord()
       at System.Management.Automation.CommandProcessor.ProcessRecord()
       --- End of inner exception stack trace ---
       at Microsoft.MasterDataServices.Configuration.InstanceManager.Execute(Command command)
       at Microsoft.MasterDataServices.Configuration.InstanceManager.UpgradeMasterDataServicesDatabase(DatabaseServerInformation serverInformation, DatabaseInformation databaseInformation)
       at Microsoft.MasterDataServices.Configuration.UI.ServerManagement.ConfigurationAdministration.UpgradeDatabase(DatabaseInformation databaseInformation)
       at Microsoft.MasterDataServices.Configuration.UI.MdsDatabase.UpgradeDatabase()

    Any help would be greatly appreciated - the business need MDS back and it's becoming a major problem!

    Thanks,

    Tuesday, October 24, 2017 9:38 AM

All replies

  • Did you find the cause of the error? I have the same error after installing SP4
    Tuesday, October 31, 2017 7:08 AM
  • Any news from Microsoft? I have the exact same issue after installing 2012 SP4.
    Monday, November 20, 2017 12:43 PM
  • I have the same issue!

    Monday, November 20, 2017 4:05 PM
  • I had the same issue. I used this workaround:

    *Back up your MDS database.

    *Use MDS Config Manager to install a new empty MDS database.

    *Use a schema compare tool (eg. database project in Visual Studio)  to update the changes from the newly created MDS database to your proper one. There's a handful of Stored Procedures that have been changed.

    *In your proper MDS database, update the record column [SchemaVersion] in the table [mdm].[tblSystem] to the new version number: 11.4.0.0.

    *Restart MDS Config Manager and make sure no upgrade warnings appear for your proper MDS database.

    Ugly, but it worked.

    Tuesday, November 21, 2017 1:23 PM
  • Hi All ,

    yes it came to our notice and we had a case on it , we are investigating the root cause for it .

    for now please follow the workaround of upgrading from 2012 Sp3 to Sp4 ( only this works ) any version less than SP3 is having issue while directly upgrading to Sp4 . we will release a fix at the earliest once we solve this problem . Please do not change the table schema version directly , ideally there is no change in SP3 to SP4 interms of Database schema meaning no SP's or views or tables are changed , its just a DB version bump from 11.3.0.0 to 11.4.0.0 .

    also as an FYI,  remember 2012 mainline support ended on Jul 11 2017, so we wont be releasing new SP's any more and I was also checking with our team whether we have any CU's or not , unfortunately we will also not have CU releases any more . so only thing , I can see is to have an OD release from this branch SQL 2012 SP4.

    as thanksgiving holidays is going on usa, I already informed right folks and I will post the updates here as soon as I get it . thanks for the cooperation .

    Thursday, November 23, 2017 7:36 AM
    Moderator
  • Hi

    Last week I updated MDS feature on front-end server (db engine is on different server) from SQL Server 2012 SP1 CU8 directly to SP4. The next step was to upgrade database using MDS Config Manager. Of course upgrade failed with the same error as above. Fortunately I took a backup of MDS database before upgrade. I understand that I should rollback SP4 installation and restore database from backup. Next step is to patch to SP3 first and then to SP4.

    The problem is I tried to uninstall SP4 on front-end. MDS was discovered under shared features. Uninstallation finished successfully but MDS wasn't shown as uninstalled and it is still SP4 11.0.7001.0 (11.4.7001.1). Now I don't have SP4 on the list of installed updates (can't uninstall SP4 from MDS) but MDS is still SP4.

    I understand it is a kind of bug and there is a workaround but how to move back and use that workaround?

    Is there a way to uninstall SP4 from MDS manually? If not what will happen if I uninstall MDS and install again with the old version (SP1). Can I just use existing Website and Web application in MDS Config Manager or maybe Web application will be also uninstalled and I will have to create a new one? 

       

    Sunday, December 17, 2017 8:18 AM
  • Same issue.  We were running SP3 but apparently never updated MDS database from 11.2 to 11.3.

    Also couldn't roll back MDS SP4, it stuck at 11.0.7001.0 after uninstalling SP4.

    Did this:

    1. Remove SP4

    2. Backed up all MDS customizations (e.g. web.config, etc., do not mess with your IIS application or the MDS database itself)

    3. Uninstall MDS shared feature from SQL

    4. Reinstall MDS from a SQL Server 2012 w/ SP3 .ISO

    5. Use MDS Configuration Manager to update database from 11.2 to 11.3

    6. Reinstall SP4

    7. Restore all MDS customizations

    8. Use MDS Configuration Manager to update database from 11.3 to 11.4

    Don't forget to restart after each run of the Installer.  Good luck.



    Monday, February 5, 2018 10:53 PM
  • Hi..

    Is there a solution available for this issue? I am facing this same issue and not able to resolve?

    Thanks

    Wednesday, August 22, 2018 6:53 AM
  • Hi,

    Has anyone find a solution for this issue? I have the same issue.

    Thursday, June 13, 2019 10:08 AM