locked
Unable to connect to my Azure VM RRS feed

  • Question

  • I logged into my Azure VM using RDP. Then Changed the RDP in bound rule to accept specific IP address. I am sure that i included my IP address. But from then, It is not allowing to login into my VM using RDP. Please help me to sort this issue ASAP.
    Monday, June 16, 2014 4:44 PM

Answers

  • Hi Nithya,

    You can turn off the windows firewall on the VM by using Remote PowerShell.

    Please follow the below article to connect to Vm using PowerShell

    blogs.msdn.com/b/sriharsha/archive/2013/10/26/remote-powershell-in-azure-iaas-virtual-machines

    Once connected you can run the following command to turn off the windows firewall profile

    netsh advfirewall set allprofiles state off

    Once firewall is off, you can RDP into the VM and reset the firewall settings that you modified.

    • Proposed as answer by Sunny_MSFT Tuesday, June 17, 2014 1:18 AM
    • Marked as answer by Susie Long Wednesday, July 9, 2014 2:51 AM
    Tuesday, June 17, 2014 1:18 AM

All replies

  • I logged into my Azure VM using RDP. Then Changed the RDP in bound rule to accept specific IP address under Windows Firewall. I am sure that i included my IP address. But from then, It is not allowing to login into my VM using RDP. Please help me to sort this issue ASAP.

    I there any way to remove the IP address filter in Windows firewall so that I can login into my machine
    Monday, June 16, 2014 4:50 PM
  • Hi Nithya,

    You can turn off the windows firewall on the VM by using Remote PowerShell.

    Please follow the below article to connect to Vm using PowerShell

    blogs.msdn.com/b/sriharsha/archive/2013/10/26/remote-powershell-in-azure-iaas-virtual-machines

    Once connected you can run the following command to turn off the windows firewall profile

    netsh advfirewall set allprofiles state off

    Once firewall is off, you can RDP into the VM and reset the firewall settings that you modified.

    • Proposed as answer by Sunny_MSFT Tuesday, June 17, 2014 1:18 AM
    • Marked as answer by Susie Long Wednesday, July 9, 2014 2:51 AM
    Tuesday, June 17, 2014 1:18 AM
  • Hi

    I agree with the above suggestion.

    You can also refer to the similar thread below:

    http://social.msdn.microsoft.com/Forums/en-US/13ce1f11-2cf5-4cc8-ac6f-7b483d610087/reenable-remote-desktop-windows-firewall-rule-on-windows-azure?forum=WAVirtualMachinesforWindows

    Please use the “netsh advfirewall set allprofiles state off” instead.

    Best regards,

    Susie

    Tuesday, June 17, 2014 7:13 AM
  • Enter-PSSession : Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troublesho
    oting Help topic.

    I am getting the above error when I use Enter-PSSession command. Please help

    Tuesday, June 17, 2014 8:08 PM
  • Hi,

    This is because Remote PS uses HTTPS and the certificate used for your Virtual Machine is a self signed certificate.

    To solve this open your browser and navigate to your VM and the public endpoint for Remote PS. Install the certificate in Trusted Root Certification Authorities.

    More information:

    Remote PowerShell in Azure IAAS Virtual Machines

    best regards,

    Susie

    Thursday, July 3, 2014 2:45 AM