locked
Lumia 1020 - Developer Preview, Update 2 - screen goes blank, doesn't respond, battery drains - charged back up first time, second time dead RRS feed

  • Question

  • Hello,

    I'm a developer and I installed the Developer Preview of 8.1 on my factory unlocked Lumia 1020 (unlocked by Nokia).  I also installed the second update, which fixed the battery and performance issues.

    Just the other day my screen went blank when I had about 45% battery left and didn't respond to the power button or any of the keys.  I left it on the wireless charging plate overnight but when I woke up it was not charged at all - the battery was fully drained.  When I plugged it in (USB) it immediately began charging and the Windows key began blinking.  It happened a second time shortly after I tried using Skype (I had used Skype on the day when the screen went blank the first time, as well, but I don't know if it had anything to do with it).

    The only other thing I can think of that happened was that I dropped it from about 10-12 inches, but that was days after the first incident.  I immediately tested the screen and camera and everything was fine.  Days after that the screen went blank again, this time with much more battery and shortly after trying to use Skype.  It hasn't charged since.

    Also, I do have a warranty with Negri Electronics, the company that sells the unlocked phones, but I'd rather not wait around for a replacement phone if I don't have to, plus having to reinstall Dev Preview, etc, etc:

    1) Any ideas?

    2) Is there a place where I can take my Lumia 1020 to get looked at that is sanctioned by Nokia?  It's factory unlocked so I wouldn't be breaking any warranties there (maybe with Negri, but I'll have to look into it)

    Thanks in advance.

    Thursday, May 22, 2014 6:26 PM

Answers

  • Everyone,

    I ended up finding a place here in NY that works on Nokia phones.  It is called Jack's Place and is an authorized Nokia repair shop.  I took the phone there and it ended up being a dead motherboard.  I sent the phone back for replacement.

    Thanks

    • Marked as answer by amk1 Thursday, July 3, 2014 1:48 AM
    Thursday, July 3, 2014 1:48 AM