none
Please need help with SSRS / SSSAS and Excel Reports RRS feed

  • Question

  • Hi All,

    i'm using SP 2013 Azure. I created a folder "Data Source" under Reports and it points to SSAS Cube and tested successfully , by checking the stored credentials and then checking "Use as Windows Crdentials". I deployed SSRS Reports and uploaded an Excel Report (which also points to the same cube). None of these work.

    When i click on the SSRS Report i'm getting the following error 

    An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Cannot impersonate user for data source 'NIPAC'. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ClaimsToWindowsTokenException: Cannot convert claims identity to windows token. ---> System.InvalidOperationException: Could not retrieve a valid Windows identity. ---> System.ServiceModel.FaultException`1[[System.ServiceModel.ExceptionDetail, System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]: WTS0003: The caller is not authorized to access the service. 

    When i click on the excel report i'm getting the following error

    We're sorry. We ran into a problem completing your request.

    Please try that again in a few minutes.

     I have been searching online and couldn't find why these errors. Really SP is not user friendly to host reports using SSAS. 

    Can someone please point me in the right direction?

    Thanks


    • Edited by joseelvis Tuesday, January 10, 2017 3:08 PM
    Tuesday, January 10, 2017 2:28 PM

All replies

  • Hi,

    What do you mean about "i'm using SP 2013 Azure"? Your SharePoint environment is SharePoint Online?

    If your environment is SharePoint on premise, please try to do as follows:

    1.  Disable ASP.Net Impersonation authentication for SharePoint Services Web Site.

    •Launch IIS Manager (Start Administrative Tools -> Internet Information Services (IIS) Manager)
    •Expand Servers and Expand Sites
    •Select SharePoint Web Services from list of available of sites.
    •Select Authentication from right panel and available authentications are displayed.
    •Disable ASP.NET Impersonation if enabled.

    2. Check whether you have enable the Excel Services Application in Central Administration.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, January 13, 2017 8:50 AM
    Moderator