none
The adapter failed to transmit message going to send port AS2 protocol via HTTP ? RRS feed

  • Question

  • Hi all,

    Whenever I am trying to send message to my trading partner as well AS2 protocol via HTTP adapter I got below error message.

    The adapter failed to transmit message going to send port "ABB.OB.PAYMENT" with URL "http://elink-as26.ABB.COM:500/as2/AS2H_ECS_INBNDD.IN". It will be retransmitted after the retry interval specified for this Send Port. Details:” Unable to connect to the remote server".

    Do you guys know the solution of the error?

    Thanks and Regards,

    Ram.

    Monday, January 24, 2011 9:07 AM

Answers

  • Hi Ram,

    Have you completed the IIS settings as per the documentation. You can find the link here

     

    Let me know if it works. 403 is kind of good as you are sure that traffic is actually getting to the BizTalk Server/ Receive Location. Make sure you have Certificates in place. Also I have run into issues with AS2 at almost every place I go and they are all different issues all the time. Follow this thread also. It will be helpful as there are several people trying to help me with suggestions.

     

    -amit


    amit kumar * Please Indicate "Mark as Answer" if this Post has Answered the Question
    • Marked as answer by Sankar B2Bi Friday, January 28, 2011 9:46 AM
    Thursday, January 27, 2011 1:20 PM

All replies

  • Yes. One thing to remember when testing the Biztalk is to make sure that it works without the protocol. IN other words, are you able to connect without biztalk? It sounds like the destionation is down or perhaps your password is wrong. However, I did run into a situation where the settings file on biztalk got currupted. What I mean by that is if you are able to connect to the destination without biztalk and you are sure the password is correct, try connecting from a differnet biztalk server if you have one. Let me know what you find.


    Please Indicate "Mark as Answer" if this Post has Answered the Question
    Monday, January 24, 2011 1:02 PM
  • Ram,

    In addition to what Carlos suggested, can you also make sure that the firewall on the Partner side is configured with your firewall Team to allow traffic from your server. I ran into this issue when the ports were not allowed by my partner from one of my BizTalk Server. In my case the BizTalk server was behind a firewall which means my Network Security Team had to get specific IP address from my Partner's Security Team along with the Port numbers and both parties enabled those IP addresses and Port numbers.

    Let us know what you find out.

     

    -amit


    amit kumar * Please Indicate "Mark as Answer" if this Post has Answered the Question
    Monday, January 24, 2011 4:26 PM
  • Hi Amit and carlos,

    Thanks for u r responce,

    After firewall configurations i got below errors within event logs.

    pls give me proper guidencs and i need any sttings in IIS Server ?

    A message received by adapter "HTTP" on receive location "ABB_ReceiveMsg_SAP" with URI "E:\Biztalk Project\AS2 \ReceivePay_SAP\*" is suspended.

    Error details: The remote server returned an error: (403) Forbidden.

    MessageId: {8F460E10-86AF-43AC-8B17-3F44B771C698}

    InstanceID: {97C0F8C0-F288-4019-ABD5-D5977088CB63}

    Best Regards,

    Ram.

    Thursday, January 27, 2011 5:21 AM
  • Hi Ram,

    Have you completed the IIS settings as per the documentation. You can find the link here

     

    Let me know if it works. 403 is kind of good as you are sure that traffic is actually getting to the BizTalk Server/ Receive Location. Make sure you have Certificates in place. Also I have run into issues with AS2 at almost every place I go and they are all different issues all the time. Follow this thread also. It will be helpful as there are several people trying to help me with suggestions.

     

    -amit


    amit kumar * Please Indicate "Mark as Answer" if this Post has Answered the Question
    • Marked as answer by Sankar B2Bi Friday, January 28, 2011 9:46 AM
    Thursday, January 27, 2011 1:20 PM
  • Hi Amit,

    this is my kind request pls give me u r contact No: this is very urget i have some issuse in AS2 configurations.

    Best and Regards,

    Ram.

    Friday, January 28, 2011 9:48 AM
  • this error message is most likely from the MDN the partner is sending you back for the CSV file you sent and they received via AS2. Please do the following:

    1. Confirm with partner that they got the file.

    2. Verify the Certificates are installed as below. While installing them please use the BizTalk servie account to login to the Server.

    Message or MDN

    Direction

    Certificate Type

    Certificate Owner

    Public or Private

    Certificate Location

    Where to configure

    Message

    Outbound

    Signing

    Home Org

    Private

    Personal certificate store of in-proc host user

    BizTalk Group / Properties / Certificate

    Message

    Outbound

    Encryption

    Partner

    Public

    Other People certificate store of local computer

    Send port / Certificate

    Message

    Inbound

    Signing

    Partner

    Public

    Other People certificate store of local computer

    Party / Certificate

    Message

    Inbound

    Encryption

    Home Org

    Private

    Personal certificate store of in-proc host user

    Isolated Host / Certificates

    MDN

    Outbound

    Signing

    Home Org

    Private

    Synch MDN: Personal certificate store of isolated host user

    Asynch MDN: Personal certificate store of in-proc host user

    BizTalk Group / Properties / Certificate

    MDN

    Inbound

    Signing

    Partner

    Public

    Other People certificate store of local computer

    Party / Certificate


    amit kumar * Please Indicate "Mark as Answer" if this Post has Answered the Question
    Wednesday, February 2, 2011 3:41 AM