locked
GoDaddy RRS feed

  • Question

  • User2041165822 posted
    I used VS2005 to modify the "Club Website Starter Kit" changing only the text and ascetics.  It works and looks great on my own computer but when I upload it the GoDaddy, It won't run.  I get this:

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>


    I am new and my research into this problem has provided no solution, and GoDaddys tech support is of no help... anyone know what I need to do?  Any help would be appreciated.

    Thanks
    Friday, October 28, 2005 12:20 PM

All replies

  • User541108374 posted
    Hi,

    change the web.config on the server like stated in the error message (set the mode="Off" in the <customErrors> element). This gives you the real error message of what's going on.and gives you more insight of what the exact problem is.

    Grz, Kris.
    Saturday, October 29, 2005 1:52 PM
  • User2041165822 posted

    It is off, but still says the same thing.  here is my web.config:

    <?xml version="1.0"?>

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <location path="events_edit.aspx" >

    <system.web>

    <authorization >

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="locations_edit.aspx" >

    <system.web>

    <authorization >

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="news_edit.aspx" >

    <system.web>

    <authorization >

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="photoalbum_new.aspx" >

    <system.web>

    <authorization >

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="member_list.aspx" >

    <system.web>

    <authorization >

    <deny users="?" />

    </authorization>

    </system.web>

    </location>

    <location path="member_details.aspx" >

    <system.web>

    <authorization >

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <connectionStrings>

    <add name="ClubSiteDB" connectionString="Data Source=.\SQLExpress;Integrated Security=true;AttachDBFileName=|DataDirectory|clubsite.mdf;User Instance=True" providerName="System.Data.SqlClient"/>

    <remove name="LocalSqlServer" />

    <add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />

    </connectionStrings>

    <appSettings>

    <!--

    The <appSettings> section is used to configure application-specific configuration

    settings. These can be fetched from within apps by calling the

    "ConfigurationSettings.AppSettings(key)" property:

    <add key="connectionstring" value="server=localhost;trusted_connection=true;database=pubs"/>

    -->

    </appSettings>

    <system.web>

    <!--

    DYNAMIC DEBUG COMPILATION

    Set compilation debug="true" to insert debugging symbols (.pdb information)

    into the compiled page. Because this creates a larger file that executes

    more slowly, you should set this value to true only when debugging and to

    false at all other times. For more information, refer to the documentation about

    debugging ASP.NET files.

    -->

    <roleManager enabled="true"/>

    <authentication mode="Forms"/>

    <compilation debug="false" strict="true">

    <assemblies>

    <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    </assemblies>

    </compilation>

    <membership defaultProvider="AspNetSqlMembershipProvider" />

    <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">

    <providers>

    <remove name="AspNetXmlSiteMapProvider" />

    <add name="AspNetXmlSiteMapProvider"

    description="SiteMap provider which reads in .sitemap XML files."

    type="System.Web.XmlSiteMapProvider"

    securityTrimmingEnabled="true"

    siteMapFile="Web.sitemap" />

    </providers>

    </siteMap>

    <!--

    The <sessionState> section is used to configure session state for the application.

    It supports four modes: "Off", "InProc", "StateServer", and "SqlServer". The

    later two modes enable session state to be stored off the web server machine -

    allowing failure redundancy and web farm session state scenarios.

    <sessionState mode="InProc"

    stateConnectionString="tcpip=127.0.0.1:42424"

    sqlConnectionString="data source=127.0.0.1;trusted_connection=true"

    cookieless="false"

    timeout="20" />

    -->

    <!--

    The <customErrors> section enables configuration of what to do if/when an

    unhandled error occurs during the execution of a request. Specifically, it

    enables developers to configure html error pages to be displayed in place of

    a error stack trace:

    -->

    <customErrors mode="Off" />

    <!--

    The <authentication> section enables configuration of the security authentication

    mode used by ASP.NET to identify an incoming user. It supports a "mode"

    attribute with four valid values: "Windows", "Forms", "Passport" and "None".

    The <forms> section is a sub-section of the <authentication> section,

    and supports configuring the authentication values used when Forms

    authentication is enabled above:

    <authentication mode="Windows">

    <forms name=".ASPXAUTH"

    loginUrl="login.aspx"

    protection="Validation"

    timeout="999999" />

    </authentication>

    -->

    <!--

    The <authorization> section enables developers/administrators to configure

    whether a user or role has access to a particular page or resource. This is

    accomplished by adding "<allow>" and "<deny>" sub-tags beneath the <authorization>

    section - specifically detailing the users/roles allowed or denied access.

    Note: The "?" character indicates "anonymous" users (ie: non authenticated users).

    The "*" character indicates "all" users.

    <authorization>

    <allow users="joeuser" />

    <allow roles="Admins" />

    <deny users="*" />

    </authorization>

    -->

    <!-- GLOBALIZATION

    This section sets the globalization settings of the application.

    -->

    <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>

    </system.web>

    </configuration>

    Sunday, October 30, 2005 9:19 PM
  • User-1414430916 posted
    I have exactly the same problem,I did also set the customerror mode to"off" But still the same error !!
    I by chance you solved the problem pleas email me the solution at okone@mdc.edu
    or post it here so I could see it .Thank you. I think it has to be a better step by step guide to installing the Start kit !! This is too frustrating !
    Thank you !
    Tuesday, November 1, 2005 7:46 AM
  • User-1286131087 posted
    go daddy does not have framework v2.0 on their system
    Tuesday, November 1, 2005 11:06 AM
  • User-509622928 posted
    I ran into the same problem and just posted a question looking for answers too.  If you make the change to the web.config file like the error message suggests, you'll see (or at least in my case) a detailed error message indicating that there is a problem with SQL connecting.  Look for my post.  Hofully someone will respond to it and we'll both have working web sites.  This is the way I modified my web.config file:

    <!--customErrors mode="RemoteOnly" defaultRedirect="ErrorPage.htm" /-->

    <customErrors mode="Off" />

    Tuesday, November 8, 2005 1:18 AM
  • User541108374 posted
    Look for my post.  Hofully someone will respond to it and we'll both have working web sites.

    It would be nice if you included the url to that particular post.

    Grz, Kris.
    Tuesday, November 8, 2005 6:47 AM
  • User-509622928 posted
    They recently added it.
    Tuesday, November 8, 2005 7:50 AM
  • User-509622928 posted
    At the time I replied to this one it had not been  accepted by the moderator.  But, it now has so here is the link: 

    http://forums.asp.net/1105411/ShowPost.aspx

    Tuesday, November 8, 2005 7:52 AM
  • User-275333937 posted

    Godaddy do not allow remote access, i have the same problem with the Classified Starter Kit,

    I am on try-and-error mode with differents Web.Config.

    Godday message for any problem with Sql Server connection =  

    ""Thank you for contacting customer support. The error relates to the fact that we do not provide the ability to use remote connections to our database servers. Sorry for any confusion.""

     

    For more information on Medium trust level, see the MSDN article How To: Use Medium Trust in ASP.NET 2.0.

    Tuesday, June 6, 2006 4:49 PM
  • User-1760427068 posted

    I went to the part in the aspx page that has

    ConnectionString="<%$ ConnectionStrings:ConnectionString %>"

    and changed it to

    ConnectionString="Server=whsql-v05.prod.mesa1.secureserver.net;uid=myusername;pwd=******;database=DB_123456"

    I'm not suggesting that this is the 'final answer'.  I'm still working to try and make it work with the ConnectionString (instead of the surgical bypass written above), but I've had no luck so far, even though GoDaddy supplies code to write in that I would have thought should have worked easily.

    I'm looking for other GoDaddy newbies (ASP.NET / VWD 2005 EE / SQL Server) to collaborate with as we work on these sort of things.

    -Larry

     

    Saturday, January 6, 2007 7:15 PM
  • User-940382857 posted

    posting experience here with godaddy.

    Trying to get the the small business starter kit running. On godaddy with ASP.NET 1.1 i get the need to turn the customError="Off" message but my web.config says it is "Off" (capital Oh). With ASP.NET 2.0 i get Server unavailable. Got a response from godaddy.com and they said that the site is crashing the ASP.NEt application pool as it is exceeding the allocated resources per site. This is ridiculous as the site itself to include images is 700 kilobytes!!.. Less than a damn floppy and they can allocate resources for that?..... sorry I am shopping for another vendor at this point as I got numerous servers to include an ARCHAIC PII400 with 512 MB of ram and it works fast on that!!

     

    <-- not happy with godaddy at this point.

    Friday, March 16, 2007 11:55 AM
  • User65710823 posted

    Without knowing what you've done so far it's kind of hard to pinpoint the problem, but I will try to help.

    1-Did you make sure site would build on your local server before copying any files?  2- Did you create all the DB tables and Procedures?  3-Did you upload the data?  (I'm assuming you're using VisualStudio/VisualWebDeveloper)

    I was going nuts trying to get my ClubSite going and ZOwen was great and clued me in to a wonderful tool for creating the scripts needed to create the tables, procedures and write the data.  All the problems I was having stemed from DB issues.  If you don't already have it - go get it- SQL Server Hosting Toolkit http://www.codeplex.com/Wiki/View.aspx?ProjectName=sqlhost

    Once you've made sure you're site is working on your local host, create a brand new (MS SQL) DB. Ensure that you select the 2.0ASP shema.

    Then use the script to run against YOUR working .mdf file.  Create 2 separate scripts - 1 for the tables&procedures and 1 for the data (try not to script the data in the DB for photos - will bring everything to a standstill).  Then you have to go thru the entire tables/procedures script and move any GOTO statements up to the row before (this is very important).  The copy and paste that entire edited script up to the hosted database using the tool provided.  You should not receive any errors when that tool runs.  Then copy and paste script for the data into the tool.  Then copy all your asp files up to the host.  Make sure you have already added yourself as an administrator before the upload - so that you don't have to go thru any additional steps to add yourself or your roles on the hosted db.

    Good luck.

    http://MarValus-Domains-Hosting.com

    ClubSite:  http://DisciplesOnDirt.com

    I'll be working on the small business starter kit myself in a couple weeks - so if you're still stuck I will try to help you more.

     

    Friday, March 16, 2007 7:51 PM
  • User-109503533 posted

    Good point on #1. I too was getting mighty disappointed trying to get the connection string working with Godaddy.

    They finally gave me this little script that proved my connection string was correct:

    mysqltest.aspx

     <%@ Import Namespace="System.Data.SqlClient" %>
    <%
    Dim oSQLConn As SqlConnection = New SqlConnection()
    oSQLConn.ConnectionString ="Server=whsql-v09.prod.mesa1.secureserver.net;uid=dbasolutions;pwd=*****;database=DB_87972;"
    try
        oSQLConn.Open()
    catch dag as exception
        response.write(dag.message)
    End try
    Response.write("Connection Open!")
    %>

    When this worked, I finally realized the program was not being recompiled on Godaddy. After recompiling locally, I was able to get it to work. Is there a setting in the config file to allow recompile on the server?

    (btw: I am moving away from Godaddy since they are not asp.net friendly.)

     

    Bill 

     

    Thursday, March 22, 2007 7:00 PM
  • User-420550402 posted

    Hi MarValUS,

    I really appreciate the effort you have gone to so far, but I have not had success yet with your instructions. Here is what I have done to date:

    Using Visual Studio 2005, SQL Express 2005 locally 

    1: Built site locally and tested all aspects working fine. Added myself as administrator at this point. I did not modify the content of the site in any way.

    2: I am not sure what you mean by "Did you create all the DB tables and Procedures?"

    3: Downloaded and ran the SQL Server Database Publishing Wizard and ran this through VS 2005 against my local copy of "Club.mdf"

    Settings here were:

    Drop existing objects in script = True

    Schema qualify = True

    Script for target database = SQL Server 2000 (the SQL Database on GoDaddy says it is version 2000)

    Types of data to publish = first run through I chose Schema only, and the second time (separate target file) Data only

    I can provide the output of these files if it helps. One thing I noted is that there are no GOTO statements in either of these scripts. Plenty of GO statements though.

    4: Created a new SQL DB on my GoDaddy account. ASP 2.0 enabled. 

    5: Copied and pasted the contents of the schema script file into the GoDaddy SQL Server Web Admin tool. I got no errors with either script.

    6: Edited the ConnectionStrings section of the web.config file to read:

    <connectionStrings>
    <add name="ClubSiteDB" connectionString="
    Server=p3swhsql-v02.shr.phx3.secureserver.net;
    Database=DB_1005155;
    User ID=****;
    Password=****;
    Trusted_Connection=False"
    providerName="System.Data.SqlClient" />
    <remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="
    Server=p3swhsql-v02.shr.phx3.secureserver.net;
    Database=DB_1005155;
    User ID=****;
    Password=****;
    Trusted_Connection=False"
    providerName="System.Data.SqlClient" />
    </connectionStrings>

    7: Uploaded all files to GoDaddy. Every page gives me "an application error has occurred".

    So far I have got 2 support replies from GoDaddy. #1: "Rename Default.aspx to default.aspx" and #2: "Unfortunately, we will be unable to assist you as this is a scripting error" which is nice since GoDaddy suggests this Clubsite, and Microsoft lists GoDaddy as the #1 host to use for this Clubsite.

    If anyone has had success with this Clubsite on GoDaddy, I would love to hear from you.
     


     

    Monday, March 26, 2007 11:08 AM
  • User-420550402 posted

    I am going to answer myself here [;)]

    What I had forgotten to do was to Rebuild the website locally, with the web.config file modified to suit the GoDaddy database information ie:

    Server=p3swhsql-v02.shr.phx3.secureserver.net; ....etc

    and then upload the files to GoDaddy.

    At this point in time - I am quite amazed to say - everything I have checked so far is working except that I cannot login using the administrator role which I created locally earlier.
     

    Monday, March 26, 2007 11:36 AM
  • User109204228 posted

    After the rebuild do you have to do anything other than ftp the files to Godaddy?

     Thank,

    CK
     

    Friday, May 4, 2007 10:00 AM
  • User706866991 posted

    Here is my working web.cong.  Here are the steps I followed on Go Daddy

    1. First, get a copy of the Go Daddy Walkthrough post on this site
    2.  Create your DB on Go Daddy using their SQL tool.  Note the user name and password you use to create teh DB
    3.  Using the create scripts in the CSK, create your table, sp's, etc. changing the dbo ownership in the scripts to the ID you used to create your DB on Go Daddy.
    4.  Use the Go Daddy Walk Through to add your Admin ID
    5.  Modify your web.config to use the proper Go Daddy server, etc.
    6.  Post your site.  I used VWD and just FTP'd it up.

    Here is my working web.config.
    <?xml version="1.0"?>

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <location path="events_edit.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="locations_edit.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="news_edit.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="photoalbum_new.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="member_list.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <location path="member_details.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <!--<location path="Files.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>
    -->

    <location path="forum_manage.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="forum_editpost.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="forum_addpost.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <location path="Admin.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="Poll_Manage.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="Poll_Answers.aspx">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="Poll_AddReaction.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <connectionStrings>

    <add name="ClubSiteDB" connectionString="Data Source=XXXXX-XXX.XXXX.XXXXX.XXXXXXXXXXXX.XXX;Initial Catalog=XX_XXXXXX;User ID=XXXXX;Password='XXXXXX';Trusted_Connection=False" providerName="System.Data.SqlClient"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=XXXX-vXXX.XXXX.XXXXX.XXXXXXXXXXXX.XXX;Initial Catalog=XX_XXXXX;User ID=XXXXX;Password='XXXXXXX';Trusted_Connection=False" providerName="System.Data.SqlClient"/>

    </connectionStrings>

    <system.web>

    <roleManager enabled="true"/>

    <authentication mode="Forms"/>

    <compilation debug="true" strict="true">

    <assemblies>

    <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    </assemblies>

    </compilation>

    <membership defaultProvider="AspNetSqlMembershipProvider"/>

    <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">

    <providers>

    <remove name="AspNetXmlSiteMapProvider"/>

    <add name="AspNetXmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>

    </providers>

    </siteMap>

    <customErrors mode="Off" defaultRedirect="ErrorPage.htm"/>

    <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>

    </system.web>

    <system.net>

    <defaultProxy>

    <proxy usesystemdefault="False" proxyaddress="http://wc-v01.inet.mesa1.gdg:3128" bypassonlocal="False" />

    </defaultProxy>

    </system.net>

    <system.net>

    <mailSettings>

    <smtp deliveryMethod="network" from=XXXXXXXXX@XXXXXXXXXX.XXX>

    <network

    host="relay-hosting.secureserver.net"

    port="25"

    defaultCredentials="true"

    />

    </
    smtp>

    </mailSettings>

    </system.net>

    <appSettings>

    <add key="BccLimit" value="10" />

    </appSettings>

    </configuration>

     

     

    Friday, June 15, 2007 11:47 PM
  • User522395092 posted

    I"m having trouble launching my site locally as well as accesing the asp.net applications. here's a copy of my web.config. Does godaddy.com allow remote access or not?

    thanks,

    jay0555

    <connectionStrings>

    <add name="ClubSiteDB" providerName="System.Data.SqlClient"

    connectionString="server=whsql-v21.prod.mesa1.secureserver.net;

    database=DB_146614;

    uid=xxxxxx;

    pwd=xxxxxx
    "/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" providerName="System.Data.SqlClient"

    connectionString="server=whsql-v21.prod.mesa1.secureserver.net;

    database=DB_146614;

    uid=xxxxx;

    pwd=xxxxx
    "/>

     

    </connectionStrings>

    Sunday, June 24, 2007 8:55 PM
  • User65710823 posted

    No GoDaddy doesn't allow remote access.  To run your site locally you have to change your connection string to connect to your local DB.  To look at/ connect to your live DB you have to use their DB manager tool.  I wish they would chage to allow remote access, it would be a lot easier but also more chance of the DB getting hacked.

    Monday, June 25, 2007 3:49 PM
  • User522395092 posted

    ok, how do i connect to my remote database. i'm getting this error:

     

    Line 4: 
    Line 5:  void Application_Start(object sender, EventArgs e) {
    Line 6:  if (!Roles.RoleExists("Administrators")) Roles.CreateRole("Administrators");
    Line 7:  }
    Line 8:  

     

    here's my local connection code:

     

    <remove name="LocalSqlServer"/>

     

    <
    add name="LocalSqlServer" connectionString="Data Source=.\SQLExpress;Integrated Security=true;AttachDBFileName=|DataDirectory|Club.mdf;User Instance=True" providerName="System.Data.SqlClient"/>

    Any suggestions would be greatly appreciated.

     

    thanks,

    Jay0555

    Monday, July 16, 2007 10:24 PM
  • User522395092 posted

    i meant to say, how do i connnect to my local database.

     

     

    Line 4: 
    Line 5:  void Application_Start(object sender, EventArgs e) {
    Line 6:  if (!Roles.RoleExists("Administrators")) Roles.CreateRole("Administrators");
    Line 7:  }
    Line 8:  

     

    here's my local connection code:

     

    <remove name="LocalSqlServer"/>

     

    <
    add name="LocalSqlServer" connectionString="Data Source=.\SQLExpress;Integrated Security=true;AttachDBFileName=|DataDirectory|Club.mdf;User Instance=True" providerName="System.Data.SqlClient"/>

    Any suggestions would be greatly appreciated.

     

    thanks,

    Jay0555

    Tuesday, July 17, 2007 7:20 PM
  • User65710823 posted

    Jay,

    The connections sometimes are enough to drive you nuts, hope the below info helps. 

    The local connection should be:

    <add name="ClubSiteDB" connectionString="Data Source=.\SQLExpress;Integrated Security=true;AttachDBFileName=|DataDirectory|ClubDB.mdf;User Instance=True" providerName="System.Data.SqlClient"/>

    Your remote connection string should look something like this:

    <add name="LocalSqlServer" connectionString="Data Source=whsql-vXX.prod.mesa1.secureserver.net; Initial Catalog=YOUR-DB-ID; User ID=YOUR-USER-ID; Password=YOUR-PASSWORD;" providerName="System.Data.SqlClient"/>

    I'm looking back at your previous posts and noticed you posted the actual DB# for your remote connection-you should never post that information for security reasons.  I would strongly suggest (since it looks like you're not live yet) deleting that remote DB and adding a new one so that you have a diff DB id.

    Good Luck.

    Tuesday, July 17, 2007 9:02 PM
  • User140933388 posted

    Hi guys

    I have a GoDaddy hosting as well. I have set up my ASPNETDB database but my connection string is not working as far as I can tell.

    From reading this thread I see that I should NOT use database name but an ID instead? And how important it is to have Trusted_Connection=False or Integrated Security=True in connection string?

    I just can't understand why can't this database deployment be simpler?  

    Thanks 

    *Edit: I went to my database manager and I see that my database doesn't have an ID but only name.

    I have no idea why isn't this working !!!!! @#$@#$$$%%^@@#$ !!!!! 

    Tuesday, July 24, 2007 7:27 AM
  • User-1516338612 posted

    Having Trusted_Connection=False is optional but it won't hurt. But DO NOT have "Integrated Security=True" - that will ensure your connection won't work.

    Post your error message so that we can trouble-shoot with you. 


     

    Tuesday, July 24, 2007 8:08 PM
  • User65710823 posted

    Go to the Hosting Control Center, click on the drop down "Databases - SQL Server", to the far right of the screen under the column "Action" click the Pencil (Edit/View Details) next to your database, click the "Configuration" button and the different connection strings to your database will be listed.

    Copy the connection string to the SQL database [SqlConnection (.NET)], which looks like:  Data Source=whsql-XXX.XXXX.XXXXX.secureserver.net; Initial Catalog=XXXXXXXXX; User ID=XXXXXXX; Password=XXXXXX;

    In the web.config file you replace everything between the quotes with your connection string information you just copied.

    So instead of  <add name="ClubSiteDB" connectionString="Data Source=.\SQLExpress;Integrated Security=true;AttachDBFileName=|DataDirectory|ClubDB.mdf;User Instance=True" providerName="System.Data.SqlClient"/>

    You will have <add name="ClubSiteDB" connectionString="="Data Source=whsql-XXX.XXXX.XXXXX.secureserver.net; Initial Catalog=XXXXXXXXX; User ID=XXXXXXX; Password=XXXXXX;" providerName="System.Data.SqlClient"/>

    Tuesday, July 24, 2007 10:24 PM
  • User140933388 posted

    @MarValUS
    I know about this. I found it and my connection string is what GoDaddy gave me.

    @SalmonTraining
    But! I think, I can't check right now, I have Integrated Security=True.

    Can this be it? Can this be the problem? SalmonTraining, can you please explain what this setting does. Cause I got an example of connection string from a man working in Microsoft with this Integrated Security=True in it.

    Thx
     

    Wednesday, July 25, 2007 3:03 AM
  • User75903138 posted

    Are you guys talking about Club Version 2.0 or Club Version 3 BETA 1? I have no problem getting version 2.0 to run on Godaddy, it's version 3.1 I'm having issues with.

    Wednesday, August 8, 2007 2:23 PM
  • User522395092 posted

    ok, thanks for all your help so far.

     

    I have another issue, I have accidently unistalled the asp schema, so i am rebuilding my tables. Where does the administrator account get created? When i reinstalled the schema, it was not there? I have recreated it as well as an application id, but now when i try to create a new member on my site, i get the following error. Please any advice would be appreciated! of course, I am in a hurry to get this up as well.

    Server Error in '/' Application.

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    thanks

    Jay

    Sunday, August 12, 2007 9:10 PM
  • User522395092 posted

    ok, please help. here's my web.config connection string.

    <connectionStrings>

    <add name="ClubSiteDB" providerName="System.Data.SqlClient"

    connectionString="server=whsql-v21.prod.mesa1.secureserver.net;&#xD;&#xA;&#xD;&#xA; database=DB_12345;&#xD;&#xA;&#xD;&#xA; uid=USERID;&#xD;&#xA;&#xD;&#xA; pwd=PSWRD"

     

    />

    <
    remove name="ClubSiteDB"/><add name="ClubSiteDB" connectionString="Data Source=.\SQLExpress;Integrated Security=true;AttachDBFileName=|DataDirectory|Club.mdf;User Instance=True" providerName="System.Data.SqlClient"/>

     

     

     

     

    </connectionStrings>

     

    I don't understand why all of a sudden i can't connect to the database. I have check the database name, user id and password a thousand times. Any help would be appreciated.

     

    thansk,

    Jay0555

    Monday, August 13, 2007 9:17 PM
  • User-1516338612 posted

    Jay,

    Where are you having your connection problems - on the live site (SQL Server) or the development site (SQL Express)? If it's the development site, then check that the SQL Server(SQLExpress) engine is actually running as a service. If it's the live site - if that's really your web.config connection settings then you are over-riding your live connection with the development connection. 

    Monday, August 13, 2007 10:39 PM
  • User522395092 posted

    ok, thanks for the quick response. I changed my connection to:

    <connectionStrings>

    <add name="ClubSiteDB" providerName="System.Data.SqlClient"

    connectionString="server=whsql-v21.prod.mesa1.secureserver.net;&#xD;&#xA;&#xD;&#xA; database=DB_12345;&#xD;&#xA;&#xD;&#xA; uid=USERID;&#xD;&#xA;&#xD;&#xA; pwd=PSWRD"

    />

    </connectionStrings>

     

    and I'm still getting the same response. It appears that my site is reading from the database just fine becuase the calendar is showing the proper data, but as soon as i try to login to the site, I get the connection error. any other suggestions???

     

    Thanks for all your help.

     

    Jay

     

    Monday, August 13, 2007 10:47 PM
  • User-1516338612 posted

    Okay. Try this - it fixes the same problem for the Personal Starter Kit on Go Daddy but I won't guarantee it's the same problem. It's leaving your connection string unchanged, but also adding connection details for the LocalSQLServer entry - as exactly the same as your ClubSiteDB entry (you need the first line to remove the entry before setting it).

    <connectionStrings> 
    <remove name="LocalSqlServer"/>
    <add name=LocalSqlServer"
    connectionString="server=whsql-v21.prod.mesa1.secureserver.net; database=DB_12345; uid=USERID; pwd=PSWRD" 
    />
    <add name="ClubSiteDB" providerName="System.Data.SqlClient"
    connectionString="server=whsql-v21.prod.mesa1.secureserver.net; database=DB_12345; uid=USERID; pwd=PSWRD" 
    />
    </connectionStrings>
    
     
    Tuesday, August 14, 2007 7:33 AM
  • User522395092 posted

    WOW!!!

    thank you so much!!! That worked. Now I may have to do some finagling to connect to my local, but a least the public site is up!!!

     

    Thanks again,

     

    Jay0555

    Tuesday, August 14, 2007 10:56 PM
  • User522395092 posted

    Well, it sort of works. The site doesn't crash, but i can't login as a user??? I can create a new one, see security questions. I can also see the calendar, news, etc. I cannot login thogh. it's almost like it' not even trying, it just comes back with an unsuccesful login. Any suggestions would be appreciated.

     

    thanks,

    jay

     

    Wednesday, August 15, 2007 11:11 PM
  • User-1516338612 posted

    Is it really creating the user? Can you see the user in the aspnet_users table in the database (you can use the Go Daddy control panel to view all data in a table - there's an icon on the table window).

    This thread is getting very long - I suggest you post your problem as a new thread with a more explanatory subject e.g. can't log in on live site. I doubt this is a GoDaddy specific issue, if you are actually connecting properly to the database - but mention the host in the message just in case.

    Thursday, August 16, 2007 8:19 AM
  • User522395092 posted

    i will repost, but yes it is creating the user. thanks again for all your help!

     

    jay0555

    Thursday, August 16, 2007 9:56 AM
  • User65710823 posted

    I am so sorry, I somehow missed your last post.  Did you finally get the site up and running? What is your URL? Let us know if you are still having problems.

    I've got an older version of the club (I think like v1) up and running at DisciplesOnDirt.com and the new v3Beta1 merged with the classifieds kit up and running at Zebu-Cattle-for-Sale.info.   They are both hosted by Marvalus-Domains-Hosting.com.  Publishing the database was easy due to right click integration using the Publishing tool with Visual Studio.
     

    Saturday, December 1, 2007 3:07 AM
  • User205197355 posted

    Hi

    I visited your Zebu-Cattle-for-Sale.info site which I think uses Version 3.1 Beta. Did you ever run into the Security Exception error that many who use GoDaddy have encountered? I think it has to do with medium trust on shared hosting. Do you have any suggestions on how to resolve?

    Thanks

    Tuesday, February 12, 2008 3:57 PM
  • User65710823 posted

    Yes I started with V3Beta1 (and fixed a ton of stuff). 

    The issue you are encountering is not a GoDaddy specific issue, it is an issue for any website running in a medium trust environment.

    It's caused by an "issue" in the Subsonic dll.  I corrected the "offending" code file and rebuilt the dll before going live.

    If you need the rebuilt dll let me know and I'll zip it and upload to my website and post a link to it.

    Tuesday, February 12, 2008 8:03 PM
  • User-1293775167 posted

    Did you get the answer to your post yet? 

    If not:

    This is the same problem that many of us have been having.  I have a club site up and running on one of my domain names which are hosted by GoDaddy.  Here's what I see.

    The database connection is most likely this issue. In your web.config I see that the connection string is set for running on the local computer during the build phase.  When you set up the hosting plan, make sure that you have the Deluxe Plan because it provides 2 SQL Server DBs.  Set them up on the site and name them.  Remember the password for each.  I copied all of the information to Word and printed it out so that I could remember it for later steps.  When you are finished, you will see the databses click on the edit button, (on the right near the delete button.)  Chose configuration and look for the :SQL Connection .NET.  This is the connection string you need to put into the web.config.  There is one for each of the databases you set up.  (I copied them to the word file with the passwords so that I didn't confuse them.

    Next, I followed Scott Guthrie's Blog on the Database Publishing Wizard step by step.  I saved the resultant .SQL files in /My Documents.

    Next, I logged in at GoDaddy, and accessed the first database.  I went to Query Manager found the .sql file "Club.mdf.sql"  I uploaded it and then ran the query.  I logged out of that database, and into the second one then found, uploaded and ran the ASPNET.MDF.sql file.  then I modified the web.config file with the proper connection string.

    <connectionStrings>

    <add name="ClubSiteDB" connectionString="Data Source=Your connection string from the first database [don't forget to put in the password];"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=Your connection string from the second database [don't forget to put in the password];"/>

    </connectionStrings>

    Fire it up and it should work

    Here is the temporary link to the one I just got working. http://www.the-elias-family.com/ 

    Saturday, February 16, 2008 11:40 AM
  • User65710823 posted

    You do not need to spend the extra money for deluxe hosting as you can merge both databases into one. Basically the one DB is the ASP.Net DB and the other is the classifieds or club (whichever).  If you're using the SQL files instead of connecting directly you just need to run that against the ASP.NET DB that should have installed when you selected ASP.NET 2.0 in your hosting account.  The club SQL is setup for one DB anyway not 2.  It's the classifieds that you had to merge the 2 DB into 1.

    All my sites run on 1 DB not 2 and you can even run multiple sites out of the same DB if you don't have a lot of activity.

    I'll be posting the .dll later today and will post the link.

    Saturday, February 16, 2008 1:46 PM
  • User205197355 posted

    Hi I would appreciate you posting your rebuilt dll soon, I am in bind. Thanks.

    Sunday, February 17, 2008 8:28 PM
  • User65710823 posted

    Sorry, it's been a crazy weekend.

    Here's the link the the recompiled dll along with instructions on what to do with it.

     http://www.marvalus-domains-hosting.com/Club-Site-Starter-Kit/Downloads/Club-Site-Medium-Trust.aspx

    Good luck and let us know.

     

    Sunday, February 17, 2008 9:48 PM
  • User205197355 posted

    Hi MarValUS

    Something's wrong in your zipped file, it says Nothing to Extract when I try. Please upload again. Thanks

     

    Sunday, February 17, 2008 10:03 PM
  • User65710823 posted

    It's good now - sorry for not having anything in the zip file.

    Sunday, February 17, 2008 10:13 PM
  • User2077848281 posted

    MarValUs,

     Thanks for posting the updated DLL. It fixed my issues with getting CSK 3.0b1 up and running on Network Solutions.

     

    Tuesday, May 13, 2008 3:43 PM
  • User65710823 posted

     

    You're welcome!  Glad it helped you out!  If I can help you with anything else, just let me know.
    Wednesday, May 14, 2008 12:01 AM
  • User75903138 posted

    Try this from scratch:

    1. Create your site locally.  Include AT LEAST 1 local admin account.
    2. Run site using CTRL-F5.
    3. Log into your GoDaddy hosting account and open the control panel.
    4. Click on ASP.Net runtime and select 2.0
    5. Click Databases > SQL Server > Create New Database.
    1. Select
    2. Check DSN (optional?)
    3. Enter UserName (this will become the database name NOT your hosting login)
    4. Enter Password (again, database password NOT hosting password)
    5. Check "Install Schema Features"
    6. Click Continue > Create Database (it WILL take some time for the database to create itself, you can refresh by clicking the SQL button in the left menu)
    7. Once setup finishes, Click Pencil icon under actions > print this page.
    8. Click Computer icon under actions > record the SQL Connection (.NET) strings
    9. Click Open Manager
    10. Click Connection > Enter the Username and Password from 6 above.
    11. Once connected, expand Tools menu > Click Query Analyzer
    12. Cut & Paste all text from club-add.sql into the Query Analyzer window
    13. Click Submit (you should see many "command(s) completed successfully" below)
    14. Go back to VWD and edit default.aspx
    15. Go to Edit > Find & Replace > Quick Replace
    16. Find dbo. (NOT Dbo. big difference)
    17. Replace with <blank> (nothing, nada, zip, zero)
    18. Look in: Current Document
    19. Click Replace All (should be 12 or more) > Save default.aspx
    20. Repeat steps 16 & 17 for:
    21. Events_Edit.aspx
    22. Events_View.aspx
    23. Open web.config
    24. Replace original text
      1. <add name="ClubSiteDB" connectionString="Data Source=.\SQLExpress;

              Integrated Security=true;

              AttachDBFileName=|DataDirectory|Club.mdf;

              User Instance=True" providerName="System.Data.SqlClient"/>

    25. With new text

      1. <add name="ClubSiteDB" providerName="System.Data.SqlClient"

              connectionString="server=whsql-v04.prod.mesa1.secureserver.net;

              database=DB_12345;

              uid=myusername;

              pwd=mypassword"/>

        <remove name="LocalSqlServer"/>

        <add name="LocalSqlServer" providerName="System.Data.SqlClient"

              connectionString="server=whsql-v04.prod.mesa1.secureserver.net;

              database=DB_12345;

              uid=myusername;

              pwd=mypassword"/>

    26. Change <customErrors mode="Off" /> (optional)

    27. Save!!!

    28. Run CTRL-F5 again.  (it will bring up a window with a server error, what you want is to look in the lower left corner of the VWD window for "Build Successful")

    29. Click Website > Copy Web Site > Connect

    30. Input your hosting username and password (NOT you database uid and pwd)

    31. Highlight all files from the left side and click right arrow to transfer.

    32. Go to your public website and create an account for each admin you created on your local database.  (make sure the usernames and passwords are the same!!!)

    33. Log back into Query Analyzer

    34. Input

      1. SELECT RoleId FROM aspnet_Roles WHERE RoleName="Administrators"

    35. Copy bracketed response into a text document and include the brackets

    1. Reset QA and Input
    2. SELECT UserId FROM aspnet_Users WHERE UserName="username"

    3. Copy each bracketed response to your text document.

    4. Reset QA again and Input

      1. INSERT INTO aspnet_UsersInRoles (RoleId, UserID) VALUES ('copied text from 29', 'copied text from 31')

    5. Repeat 28-32 for each admin account.

Monday, May 26, 2008 8:29 PM