locked
Deploying my first ASP.NET website RRS feed

  • Question

  • User494690411 posted

    Hi,

    I just finished my first ASP.NET Website project, and need to host it on internet.

    I really don't know where to start. but I found this free hosting site http://www.smarterasp.net/ 

    And that is how my try looks like: I chose Copy Web Site.. from Website menu and connected to the server and selected all files and folders and copied them to the server

    but when I open the website it shows an error of missing contentPlaceHolder, I found that the master page didn't move to the server properly, after some random try the page opened but without styling and the contact form doesn't work!

    I'm really feeling lost. Please could you tell me where to start learning about these things. if there is a straightforward tutorial I'd be so grateful, or If someone here could help me.

    Thanks in advance

    Tuesday, January 26, 2016 11:06 PM

Answers

  • User465171450 posted

    Make sure that the directory you are publishing into is actually setup as an application. I can't say how to do this with your host as it's different for each one. If your pages reference a masterpage and use "~/MasterPage.master", then the ~/ translates into the application root. If there is a different master in the root directory, it could have a different content placeholder arrangement and that can throw things off.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, January 26, 2016 11:21 PM

All replies

  • User465171450 posted

    Make sure that the directory you are publishing into is actually setup as an application. I can't say how to do this with your host as it's different for each one. If your pages reference a masterpage and use "~/MasterPage.master", then the ~/ translates into the application root. If there is a different master in the root directory, it could have a different content placeholder arrangement and that can throw things off.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, January 26, 2016 11:21 PM
  • User-986267747 posted

    Hi madongeer,

    And that is how my try looks like: I chose Copy Web Site.. from Website menu and connected to the server and selected all files and folders and copied them to the server

    but when I open the website it shows an error of missing contentPlaceHolder, I found that the master page didn't move to the server properly, after some random try the page opened but without styling and the contact form doesn't work!

    According to your description, you need to mark sure that your project works fine in your vs. And you couldn't upload all of files to server,  i'm not sure why you couldn't do it. I suspect that the method you upload your website is not right, you could refer to the following link to learn how to upload your website to smartersap.net.

    http://www.smarterasp.net/support/kb/a381/quick-start-guide.aspx

    Best Regards,

    Klein zhang

    Wednesday, January 27, 2016 2:43 AM