none
VSTO application issue with Win 10 10074 upgrade RRS feed

  • Question

  • Hi All

    With multiple Users we are experiencing the below runtime exceptions while launching VSTO application with newer version of OS WIN 10 Build 10074. The VSTO application is working fine with build 10041 and the exception arise when the multiple Users upgraded their machines from build 10041 to 10074.

    When the application is launched (Via VSTO Excel app) following exception messages were shown: "Cannot insert object" and for some User's "MS Excel waiting for another application to complete an OLE action". Internally we are not creating any controls but consuming the office in-build control like panels etc

    To be safer side we have tried debugging the VSTO application at our end with fresh installation of Win 10 10074. We experimented with User's machine by cleaning file cache, registry, uninstall (Office & VSTO), reinstall (Office & VSTO), restarting the machine etc but no luck. Tested across diff. version of Office as well.

    Like to understand if there is any similar kind of exceptions raised in your area or vicinity and tried some work around to resolve the issue ? Reach out in case of more information required.

    Regards
    Srinivasan B

    Srinivasan Baskaran, Technology Architect, Infosys Technology Limited, India

    Thursday, June 11, 2015 6:56 AM

Answers

  • Hi Srinivasan,

    >>Any pointers to implement this in WIX / C# ?? <<

    If the application we have developed that depend on the sepcific version of .Net Framework, we need to config the dependent components as prerequisites correctly.

    I suggest that you get support from Offical support from WIX if you want to achieve the goal using WIX.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by L.HlModerator Friday, July 10, 2015 9:00 AM
    Tuesday, June 23, 2015 5:20 AM
    Moderator

All replies

  • Hi Srinivasan B,

    >>Cannot insert object" and for some User's "MS Excel waiting for another application to complete an OLE action<<

    According to the description, you were making OLE automation other application in Office.

    To narrow down this issue, I suggest that you try the same operation manually to see whether this issue is relative to product. If the issue also could be reproduced manually, I suggest that you reopen a thread in the Community Office forum.

    If not, would you mind sharing the code you were developing with?

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, June 12, 2015 5:53 AM
    Moderator
  • Fei

    The issue was occurring only to specific User's who have upgraded their OS from Win 10 10041 to 10074 build.

    The application / product is working fine in rest of the User's. Like to understand is there any change happened between these 2 builds or any workaround for the error description.

    Regards

    Srinivasan Baskaran


    Srinivasan Baskaran, Technology Architect, Infosys Technology Limited, India

    Monday, June 15, 2015 7:29 AM
  • Hi Srinivansan,

    >>The application / product is working fine in rest of the User's. Like to understand is there any change happened between these 2 builds or any workaround for the error description.<<

    Would you mind sharing the code of snippet caused this issue?

    In addtion, is the version of Office on the computers same? If not, I suggest that to change the version same as which version the code works.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, June 15, 2015 9:24 AM
    Moderator
  • The application works fine with same s/w configuration with other Users and certain Users are facing the issue.

    Meanwhile we found one of the workaround to enable the .NET Framework 3.5 under the turn on or off windows feature settings, now the issue got resolved but we need to have a permanent solution. So trying to see if there is programmatically we can set this option enabled in win 10 OS ? using the WIX has setup implementation.


    Srinivasan Baskaran, Technology Architect, Infosys Technology Limited, India

    Thursday, June 18, 2015 10:26 AM
  • The application works fine with same s/w configuration with other Users and certain Users are facing the issue.

    Meanwhile we found one of the workaround to enable the .NET Framework 3.5 under the turn on or off windows feature settings, now the issue got resolved but we need to have a permanent solution. So trying to see if there is programmatically we can set this option enabled in win 10 OS ? using the WIX has setup implementation.


    Srinivasan Baskaran, Technology Architect, Infosys Technology Limited, India

    Here is the steps we try to do

    1. Start Program -> Run Prompt -> Type "Control Panel" -> Hit OK to go to Control panel page
    2. Traverse to Programs -> Programs and Features
    3. Select the option “Turn off Windows feature On or Off” from the left hand side pane
    4. Ensure the .NET framework 3.5 (includes .NET 2.0 and 3.0) has filled box

    Any pointers to implement this in WIX / C# ??


    Srinivasan Baskaran, Technology Architect, Infosys Technology Limited, India

    Friday, June 19, 2015 8:23 AM
  • Hi Srinivasan,

    >>Any pointers to implement this in WIX / C# ?? <<

    If the application we have developed that depend on the sepcific version of .Net Framework, we need to config the dependent components as prerequisites correctly.

    I suggest that you get support from Offical support from WIX if you want to achieve the goal using WIX.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by L.HlModerator Friday, July 10, 2015 9:00 AM
    Tuesday, June 23, 2015 5:20 AM
    Moderator