none
NetAdapterBinding not working in Windows Container (0x800106d9) RRS feed

  • Question

  • Hi,

    I want to list (and also enable and disable) Bindings of my Network. But if i try to run Get-NetAdapterBindings within a powershell in my Container it returns following error:

    get-netadapterbinding : A general error occurred that is not covered by a more specific error code. At line:1 char:1 + get-netadapterbinding + ~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (MSFT_NetAdapterBindingSettingData:ROOT/StandardCi...dingSettingData) [ Get-NetAdapterBinding], CimException + FullyQualifiedErrorId : HRESULT 0x800106d9,Get-NetAdapterBinding 

    Same HResult if I try to enable or disable NetAdapterBindings.

    I run 10.0.14393.693_de-de Container of Microsoft/windowsservercore on Win Srv 2k16. The WMI Class is available and also the repository seems to be OK. I already tried to reset the repository via winmgmt /resetrepository.

    PS C:\> gwmi -namespace root\standardcimv2 -List

    NameSpace: ROOT\standardcimv2 Name Methods Properties ---- ------- ----------

    MSFT_NetAdapterBindingElementSet... {} {IsCurrent, IsDefault, IsNext, ManagedElement...} MSFT_NetAdapterBindingSettingData {Enable, Disable} {BindName, Caption, Characteristics, ComponentClassGuid...} ...

    Additional Info:

    • Server Version: 1.12.2-cs2-ws-beta
    • Storage Driver: windowsfilter
    • Swarm: inactive
    • Default Isolation: process
    • Kernel Version: 10.0 14393
    • Operating System: Windows Server 2016 Standard

    Thanks

    Wednesday, February 8, 2017 12:54 PM