none
App Error Sorry, but we can't start this app because it isn't set up properly RRS feed

  • Question

  • I am working with the office app created from the Visual Studio wizard. It works fine when deployed to the local host. But when I publish it to my Azure web server I get this error. I can view the page directly at the web site so I know it is not a connection issue. I checked the manifest and it looks fine. Is there anyway to debug this so I can tell what is happening?
    Tuesday, July 22, 2014 3:31 PM

Answers

All replies

  • Hi Jeffki123,

    Firstly I would like you to check if the office app is deployed properly, follow the steps in this documentation to check it out:

    http://msdn.microsoft.com/en-us/library/office/fp179811(v=office.15).aspx

    To debug an app deployed on a remote web server, you need to attach the remote process which hosts this app. This document will help you on how to attach to a running process with Visual Studio Debugger:

    http://msdn.microsoft.com/en-us/library/3s68z0b3.aspx


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, July 23, 2014 7:03 AM
    Moderator
  • I have reviewed the documentation you listed and related docs. I have setup debugging on Azure and I can debug the app running in the browser, but I need to debug the app as it is loaded in OWA. I think the publishing is working fine as I can see all the files in the server explorer in VS. Here is the manifest posted to my Office 365 Exchange server. I have removed the xmlns:xsi link so I could post this reply.

    <?xml version="1.0" encoding="utf-8"?>
    <!--Published:70EDFC97-B41D-43C5-B751-7C00AD999804-->
    <!--Created:cb85b80c-f585-40ff-8bfc-12ff4d0e34a9-->
    OfficeApp xmlns="http://schemas.microsoft.com/office/appforoffice/1.0" xmlns:xsi="" xsi:type="MailApp">
      <Id>0554d40d-bc8b-434f-a6bc-7391fe9029b7</Id>
      <Version>1.0.0.0</Version>
      <ProviderName>jeffk</ProviderName>
      <DefaultLocale>en-US</DefaultLocale>
      <DisplayName DefaultValue="OfficeApp1" />
      <Description DefaultValue="OfficeApp1" />
      <Capabilities>
        <Capability Name="Mailbox" />
      </Capabilities>
      <DesktopSettings>
        <SourceLocation DefaultValue="https:\\MyExample8277.azurewebsites.net/App/Home/Home.html" />
        <RequestedHeight>250</RequestedHeight>
      </DesktopSettings>
      <Permissions>ReadItem</Permissions>
        <Rule xsi:type="RuleCollection" Mode="Or">
          <Rule xsi:type="ItemIs" ItemType="Message" />
        </Rule>
    </OfficeApp><officeapp xmlns="http://schemas.microsoft.com/office/appforoffice/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="MailApp"><displayname defaultvalue="OfficeApp1"><description defaultvalue="OfficeApp1"><capabilities><desktopsettings>  <rule mode="Or" xsi:type="RuleCollection"><rule itemtype="Message" xsi:type="ItemIs"></rule> </rule> </desktopsettings></capabilities></description></displayname></officeapp>

    Wednesday, July 23, 2014 6:02 PM
  • I tried this on Outlook an the app navigates to the Navigation to the webpage was canceled page. So I believe there is something wrong with loading mail apps from an azure server.
    Wednesday, July 23, 2014 10:54 PM
  • Hi Jeffki123,

    I found the URL format you provided is incorrect.

    It should be “https://MyExample8277.azurewebsites.net/App/Home/Home.html

    And I’m also not able to access it after changing it to the format above, so please ensure the web site is deployed successfully on Azure.

    Regards,

    Jeffrey


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, July 24, 2014 3:20 AM
    Moderator
  • Jeffrey,

    Thanks for the response. The VS publish wizard created that path and I did not catch it. Fixing it gets me a little further. Now when I run it I get the app error with the option to retry then start. When I click start I get "Content was blocked because it was not signed by a valid security certificate." How do I resolve this?

    Thursday, July 24, 2014 3:46 PM
  • Jeffki,

    Are you using the certificates provided by Microsoft on Azure or the self-signed certificates?

    Enable HTTPS for an Azure web site

    If you used the certificates provide by Microsoft, it should have already been in the trust location. Else, I suggest you to try the methods Mahesh mentioned in his answer on the thread below

    http://answers.microsoft.com/en-us/ie/forum/ie9-windows_other/error-content-was-blocked-because-it-was-not/7528770d-0031-49ea-a61f-201b1958eb15

    Regards,

    Jeffrey


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, July 25, 2014 3:00 AM
    Moderator