locked
pages asp.net 2.0 in french RRS feed

  • Question

  • User748783080 posted

    Hi,

     

    On my local machine, all my pages are in french. But when i post my website on the server, the same pages appear in english.

     

    How can I obtain my pages in french??

     

    Thanks

    Sunday, July 30, 2006 8:52 AM

All replies

  • User2032526919 posted

    Hi,

    essentially putting <globalization culture="fr-FR" uiCulture="fr" /> into web.config should accomplish that.

    Here is resources about it:

    How to: Set the Culture and UI Culture for ASP.NET Web Page Globalization 
    http://msdn.microsoft.com/en-us/library/bz9tc508.aspx

    Sunday, July 30, 2006 9:09 AM
  • User748783080 posted

    Thanks

    But it doesn't work!!!

    What can I do?

     

     

    Sunday, July 30, 2006 12:49 PM
  • User-1936818034 posted

    Which part of your pages is turn into english? Some auto generated texts in controls?(e.g Calender)

    If the setting in <globalization /> doesn't work, I recommend you try overriding InitializeCulture() of the Page or setting the thread culture in Begin_Request() in global.asax

    Generally we can set culture info like this: http://msdn.microsoft.com/en-us/library/bz9tc508.aspx
    Further more, if you are using masterpage, look into here: http://forums.asp.net/1219973/ShowPost.aspx

    Sunday, July 30, 2006 10:10 PM
  • User748783080 posted

    Hi,

    In fact, it's working in a single page. But in a masterpager, it doesn't work.

    And I try to understand the forum about it, but I didn't understand anything.

    Can you give me a good and simple solution?

     

    Thanks

    Monday, July 31, 2006 4:02 PM
  • User2032526919 posted
    It's because master page is not actually a page but a user control derived class, so it needs bir extra measures. Have a look at this thread and especially on what rmprimo says and links to.
    Monday, July 31, 2006 4:18 PM