none
Building a Tabular model to access Azure Log Analytics RRS feed

  • Question

  • Hi

    I want to connect to Azure Log Analytics via Tabular models in Analysis Services.

    I exported the M Query from Log analytics which I want to build tabular model on,so creating the power query works when I create the expression as I can get the data.

    Now I convert the expression to a table it cannot extract the data as it gives an error :

    “Failed to save modifications to the server. Error returned: 'An M partition uses a data function which results in access to a data source different from those defined in the model.

    '.”

    Any ideas on how to get this working ?

    Thanks

    Wednesday, November 6, 2019 1:09 PM

All replies

  • Hi

    I want to connect to Azure Log Analytics via Tabular models in Analysis Services.

    I exported the M Query from Log analytics which I want to build tabular model on,so creating the power query works when I create the expression as I can get the data.

    Now I convert the expression to a table it cannot extract the data as it gives an error :

    “Failed to save modifications to the server. Error returned: 'An M partition uses a data function which results in access to a data source different from those defined in the model.

    '.”

    since the M Query uses Json.Document(Web.Contents()), for Log Analytics,

    It seems that Analysis Services does not support Json.Document(Web.Contents()) as a data source and

    only supports  Json.Document(File.Contents()) ?

    Any ideas on how to get this working ?

    Thanks



    Wednesday, November 6, 2019 1:06 PM
  • Hi Armand Morne Theron

    Thank you for your query. I see you have posted the same question in Log Analytics forum (see below)

    https://social.msdn.microsoft.com/Forums/en-US/175580be-7dee-4c5d-a389-707126ec6152/building-a-tabular-model-to-access-azure-log-analytics-error-in-connection?forum=opinsights

    And also found another thread with same question in Log Analytics forum and later deleted (see below) with comment "found solution, not worth wasting peoples time on this". Could you please confirm if you are still looking for assistance on this query or if you have already found a solution? If so, please consider sharing it here as it will be beneficial for other community members who reads this thread. 

    https://social.msdn.microsoft.com/Forums/en-US/5b324b4f-3d10-47b0-8593-42576318a76e/building-a-tabular-model-to-access-azure-log-analytics?forum=opinsights 



    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, November 7, 2019 2:34 AM
    Moderator
  • Hi there,

    Just checking to see if you are still looking for assistance on this query? In case if you have found a solution, please consider sharing it here.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Friday, November 8, 2019 1:18 AM
    Moderator
  • Hi there,

    Following up to see if you still need assistance on your query. 


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Friday, November 8, 2019 10:07 PM
    Moderator