locked
Server Error in '/' Application. RRS feed

  • Question

  • User1628677626 posted

    I am new to asp.net and I found someone else with something like my problem. I don't think its a connection problem but I am going to include my connection strings in my .config. If anyone could help that would be awesome.  I was getting errors on <roleManager enabled="true"/> until I moded my connection string then I just get runtime errors. I need to check which .net framework my godaddy site is using and I will post that once I find out.

     

     

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

     
    <connectionStrings>
         <remove name="LocalSqlServer">
      <add name="SiteSqlServer" connectionString="Server=whsql-v24.prod.mesa1.secureserver.net;Database=SASSQL1;UID=SASSQL1;Password=*********" providerName="System.Data.SqlClient"/>
      <add key="SiteSqlServer" value="Server=whsql-v24.prod.mesa1.secureserver.net;Database=SASSQL1;UID=SASSQL1;Password=**********">
      
     </connectionStrings>
     <system.web>
        <xhtmlConformance mode="Strict"/>
      <roleManager enabled="true"/>
      <authentication mode="Forms"/>
      <compilation debug="true">
       <assemblies>
        <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
       </assemblies>
      </compilation>
      <membership defaultProvider="AspNetSqlMembershipProvider"/>
      <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">
       <providers>
        <remove name="AspNetXmlSiteMapProvider"/>
        <add name="AspNetXmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>
       </providers>
      </siteMap>
        <!--<customErrors mode="RemoteOnly" defaultRedirect="ErrorPage.htm"/>-->
        <customErrors mode="Off"/>
      <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
     </system.web>
    </configuration>
     
    Wednesday, March 12, 2008 8:28 PM

All replies

  • User1628677626 posted

    I also tried each connection string in the configuration drop down on GoDaddy. I've confirmed that the folder has read/write access and that the tables are in the database with all permissions .... I've been reading that GoDaddy has alot of issues with these starter kit pages?

     

     

    Also the error has changed to Server Error in '/SAS' Application

     

    Wednesday, March 12, 2008 8:56 PM
  • User75903138 posted

    I'm assuming you are trying to get the ClubStarter Kit to work with GoDaddy? If so you need to change your connection string to something like this:

    <connectionStrings>

    <add name="ClubSiteDB" providerName="System.Data.SqlClient" connectionString="DataBaseAddressHere; database=DataBaseName; uid=UserNameHere; pwd=YourPasswordHere"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" providerName="System.Data.SqlClient" connectionString="DataBaseAddressHere; database=DataBaseName; uid=UserNameHere; pwd=YourPasswordHere"/>

    </connectionStrings>

    Thursday, March 13, 2008 2:08 PM
  • User1628677626 posted

    Thanks for the reply phamster, I am trying to get it to work with GoDaddy. I tried changing the script but still get the same error. I am not so positive that the error is with my connection. I think it might be making the connection but it won't allow it to run properly. I keep getting the following:

     

    Server Error in '/SAS' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
     

     

    I've tried doing the above to revel the error but nothing happens. It still pumps out the same message .... any ideas?
     

    Thursday, March 13, 2008 4:54 PM
  • User75903138 posted
    Here are instructions to how to setup the clubstarter kit from beginning to end onto GoDaddy. Hope this helps.
    1. Create your site locally.  Include AT LEAST 1 local admin account.
    2. Run site using CTRL-F5.
    3. Log into your GoDaddy hosting account and open the control panel.
    4. Click on ASP.Net runtime and select 2.0
    5. Click Databases > SQL Server > Create New Database.
    6. Select
      1. Check DSN (optional?)
      2. Enter UserName (this will become the database name NOT your hosting login)
      3. Enter Password (again, database password NOT hosting password)
      4. Check "Install Schema Features"
    7. Click Continue > Create Database (it WILL take some time for the database to create itself, you can refresh by clicking the SQL button in the left menu)
    8. Once setup finishes, Click Pencil icon under actions > print this page.
    9. Click Computer icon under actions > record the SQL Connection (.NET) strings
    10. Click Open Manager
    11. Click Connection > Enter the Username and Password from 6 above.
    12. Once connected, expand Tools menu > Click Query Analyzer
    13. Cut & Paste all text from club-add.sql into the Query Analyzer window
    14. Click Submit (you should see many "command(s) completed successfully" below)
    15. Go back to VWD and edit default.aspx
    16. Go to Edit > Find & Replace > Quick Replace
      1. Find dbo. (NOT Dbo. big difference)
      2. Replace with <blank> (nothing, nada, zip, zero)
      3. Look in: Current Document
    17. Click Replace All (should be 12 or more) > Save default.aspx
    18. Repeat steps 16 & 17 for:
      1. Events_Edit.aspx
      2. Events_View.aspx
    19. Open web.config
      1. Replace original text
        1. <add name="ClubSiteDB" connectionString="Data Source=.\SQLExpress;

                Integrated Security=true;

                AttachDBFileName=|DataDirectory|Club.mdf;

                User Instance=True" providerName="System.Data.SqlClient"/>

      2. With new text

        1. <add name="ClubSiteDB" providerName="System.Data.SqlClient"

                connectionString="ConnectionStringGoesHere;

                database=YourDataBaseNameHere;

                uid=YourUserNameHere;

                pwd=YourPasswordHere"/>

          <remove name="LocalSqlServer"/>

          <add name="LocalSqlServer" providerName="System.Data.SqlClient"

                connectionString="ConnectionStringGoesHere;

                database=YourDataBaseNameHere;

                uid=YourUsernameHere;

                pwd=YourPasswordHere"/>

    20. Change <customErrors mode="Off" /> (optional)

    21. Save!!!

    22. Run CTRL-F5 again.  (it will bring up a window with a server error, what you want is to look in the lower left corner of the VWD window for "Build Successful")

    23. Click Website > Copy Web Site > Connect

    24. Input your hosting username and password (NOT you database uid and pwd)

    25. Highlight all files from the left side and click right arrow to transfer.

    26. Go to your public website and create an account for each admin you created on your local database.  (make sure the usernames and passwords are the same!!!)

    27. Log back into Query Analyzer

    28. Input

      1. SELECT RoleId FROM aspnet_Roles WHERE RoleName="Administrators"

    29. Copy bracketed response into a text document and include the brackets

    30. Reset QA and Input

      1. SELECT UserId FROM aspnet_Users WHERE UserName="username"

      2. Copy each bracketed response to your text document.

      3. Reset QA again and Input

        1. INSERT INTO aspnet_UsersInRoles (RoleId, UserID) VALUES ('copied text from 29', 'copied text from 31')

      4. Repeat 28-32 for each admin account.

    Thursday, March 13, 2008 5:00 PM
  • User-704192888 posted

    Hi phamster,

     I am also getting same error massage. Mine application is small...it about uploading a file to the server.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>i have already set <o:p></o:p><customErrors mode="Off" /><o:p></o:p>Please help. <o:p></o:p>

     

    Friday, July 25, 2008 3:01 AM
  • User1323253724 posted

    Any chance a tutorial like this can be done with 1and1.com . I'm haveing a hell of a time figuring this out. I'm just trying to get the sample club website up and running. Thanks 

    Sunday, July 27, 2008 2:45 PM
  • User-1705717250 posted

    For 1and1 take a read of http://forums.asp.net/t/1110595.aspx

    Hope it helps

    Monday, July 28, 2008 10:42 AM
  • User-1705717250 posted

    Aswell as the steps above you should define the membership provider in your web.config and set the applicationname, take a read of
    http://weblogs.asp.net/scottgu/archive/2006/04/22/Always-set-the-_2200_applicationName_2200_-property-when-configuring-ASP.NET-2.0-Membership-and-other-Providers.aspx
    for more info.

    Hope it helps

    Monday, July 28, 2008 11:20 AM
  • User75903138 posted

    Change the <customeErrors mode="Off" /> to <customeErrors mode="On" /> 

    Then post what it says then.

    Thursday, August 7, 2008 4:12 PM
  • User-704192888 posted

    Hi Phamster

    Even after changing CustomError mode to ON..it is still giving below error..Please advise..

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    Regards

    Bhupesh

    Friday, September 19, 2008 12:57 AM