none
Windows container docker pull fails. RRS feed

  • Question

  • Hi,

    I am unable to pull docker image for windowsservercore.

    Below is the dump. Did anybody face the same problem?

    Thanks in anticipation.

    _________________________________________________________________________________

    PS C:\Users\administrator> docker pull microsoft/windowsservercore

    Using default tag: latest
    latest: Pulling from microsoft/windowsservercore

    1239394e5a8a: Extracting [==================================================>] 3.461 GB/3.461 GB
    failed to register layer: re-exec error: exit status 1: output: ProcessBaseLayer C:\ProgramData\docker\windowsfilter\fd1f2b11b1f82a4e02cc5b59508ea656a7e73096f7c4ee772a3379b4801e83a3: The parameter is incorrect.

    ________________________________________________________________________________________________

    PS C:\Users\administrator> docker info
    Containers: 0
     Running: 0
     Paused: 0
     Stopped: 0
    Images: 0
    Server Version: 1.13.0-dev
    Storage Driver: windowsfilter
     Windows:
    Logging Driver: json-file
    Plugins:
     Volume: local
     Network: nat null overlay
    Swarm: inactive
    Security Options:
    Kernel Version: 10.0 14300 (14300.1000.amd64fre.rs1_release_svc.160324-1723)
    Operating System: Windows Server 2016 Datacenter Technical Preview 5
    OSType: windows
    Architecture: x86_64
    CPUs: 2
    Total Memory: 8 GiB
    Name: win-containerA
    ID: BGOB:YVCS:HL22:MLWU:JAIU:UVPF:7NY6:NINI:GW5V:JBCX:HNAW:7UWY
    Docker Root Dir: C:\ProgramData\docker
    Debug Mode (client): false
    Debug Mode (server): false
    Registry: https://index.docker.io/v1/
    Insecure Registries:
     127.0.0.0/8
    Live Restore Enabled: false

    Thursday, September 8, 2016 1:53 PM

All replies

  • Do you have enough disk space?
    Thursday, September 8, 2016 2:52 PM
  • Yes, I do have abundant disk space available.
    Monday, September 12, 2016 9:09 AM
  • Is this a fresh new TP5? Have you ever able to run any container on it?

    The only thing I can see is that your kernel is a bit old, maybe you can try to update it and clean up everything and try again.

    My kernel: Kernel Version: 10.0 14300 (14300.1052.amd64fre.rs1_release_svc.160721-1818)

    Yours: Kernel Version: 10.0 14300 (14300.1000.amd64fre.rs1_release_svc.160324-1723)

    Monday, September 12, 2016 11:42 AM