none
Windows Server 2019Standard版,安装完.net 3.5后,.net 4就是关闭状态了,怎么解决 RRS feed

  • Question

  • 因为需要软件只能匹配低版本的.net ,安装完3.5后,开机就提示.net 4错误,服务管理器,事件查看,查看windows功能都无法使用了;怎么办
    Friday, November 8, 2019 9:17 AM

All replies

  • Hi friend,

    Welcome to MSDN forum.

    According to your description, you have installed .net 3.5, could you share me how you installed .net 3.5? For .net 3.5, it can be installed by Control Panel >> Turn Windows Features on or off >> select .NET Framework 3.5(include .NET 2.0 and 3.0) check box.

    In addition, for the error of .net 4 you talked about, you could check the status of your Windows Update.  I suppose it is caused by your windows system files. You could try to type the command sfc /scannow to fix Windows system files.

    BTW, if possible, we hope to receive more screenshots or logs about the error so that we can better solve the issue.

    Hope all above could help you and any feedback will be expected. 

    Best Regards,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, November 11, 2019 6:32 AM
  • Hi friend,

    Sorry to disturb you, did you have any update?

    As Anna said above, .net 3.5 has been included in Windows system currently, you just need to go to control panel -> Uninstall or change a program -> on the left column find Turn Windows features on or off -> check checkbox of “.NET Framework 3.5(include .NET 2.0 and 3.0)” -> Ok to start using .NET Framework 3.5.

    Not sure where do you download and install .NET Framework 3.5 if you really need to download it you could download and install it form this official website: Microsoft .NET Framework 3.5 and select the language you use.

    In addition, I notice that you said you could not use Windows Feature, does it mean you could not open Windows Features Window?

    If you could open Windows Features Window follow the steps I said above, you might could try to restart to use .net 4 by checking the box of .net 4.X.

    If not, I consider there might be something wrong with your windows system, you could try Anna's suggestions or maybe restart your computer and check if this issue could be solved.

    Hope all above could help you and any feedback will be expected.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 15, 2019 9:27 AM
  • 3.5安装是在添加角色 里面安装的,一直下一步就可以安装成功了; 没有做过多操作,就是重启以后出现弹窗.net 4.0有错误
    Tuesday, November 26, 2019 1:29 AM
  • windows程序和功能,打不开了;添加角色也已经找不开了,4.X版本安装 的时候都提示是已经安装,但是已经关闭的
    Tuesday, November 26, 2019 1:31 AM