none
EWS getting a 401 Unauthorized error RRS feed

  • Question

  • We have implemented a EWS application to synchronize calendar items using push notifications in Java.

    It is working fine on Exchange 2007 with domain controller 2003. We can connect to EWS with an account that has full access rights on some mailboxes.

    When we setup another environment using Exchange 2010 on windows 2008 server. 

     

    The account cannot login to EWS. The account can login using OWA. When connecting to EWS we get a 401 Unauthorized error.

     

    Any ideas?

    Tuesday, September 13, 2011 10:13 AM

Answers

  • This has been solved.

     

    Go to Internet Information Services Manager -> Sites -> Default Web Site -> EWS -> Authentication -> Basic Authentication: Set to enabled

     

    It was originaly set to disabled

     

    Hope this helps someone else!

    • Marked as answer by Sean Moloney Friday, September 16, 2011 1:01 PM
    Friday, September 16, 2011 1:01 PM

All replies

  • A 401 indicates a lot lower down type of authentication error for example if it was just that the user didn't have access to a particular mailbox they would get "'The specified object was not found in the store" type error. Can the user your using access their own mailbox ? you might want to check the authentication type your using in your code eg are you trying to use basic authentication where the default in EWS would be NTLM etc.

    Cheers
    Glen

    Wednesday, September 14, 2011 3:20 AM
  • Hi Glen

     

    From looking at logs it shows that NTLMUsed="false"

     

    Looking at a working enviorment it shows:

    INFO: NTLM authentication scheme selected

     

    I wonder could this be the problem?

     

    Thanks!

    Friday, September 16, 2011 10:04 AM
  • This has been solved.

     

    Go to Internet Information Services Manager -> Sites -> Default Web Site -> EWS -> Authentication -> Basic Authentication: Set to enabled

     

    It was originaly set to disabled

     

    Hope this helps someone else!

    • Marked as answer by Sean Moloney Friday, September 16, 2011 1:01 PM
    Friday, September 16, 2011 1:01 PM