locked
Error when trying to import entire web server RRS feed

  • Question

  • User553537030 posted

    Hello all.

    So, we recently upgraded a server and successfully migrated from IIS6 to IIS7.5. Now, I want to move to Server 2012 with IIS8.5.

    On the old server, I tried exporting the server in IIS Manager, but was told the package exceeds 2GB, so I used msdeploy commands to create an archiveDir instead. I've moved the archiveDir over to the new server, on the C:\ root.

    Using msdeploy again, I run:

    msdeploy -verb:sync -source:archiveDir=c:\backup,encryptPassword=mypassword -dest:webServer -whatif

    Prompt returns with an error "cannot create a file when that file already exists." I've tried just installing Web Deploy and running it again, but it still does not work. I've wiped the drive, reinstalled Server 2012, installed my server roles and tried again, but I still receive this error. I want to move the entire server over to save myself some headaches, but this is turning into one itself! What can I do?



    Monday, July 24, 2017 3:58 PM

All replies

  • User-460007017 posted

    Hi R4L,

    The error message  "cannot create a file when that file already exists." could be related to the binding host header already existed on the target server. So just ensure there are no duplicated website with same binding host header. Maybe you could just try to remove the default website and try to run the sync command.

    In addition, to migrate a IIS server from IIS6 to IIS7:

    msdeploy -verb:sync -source:webserver60,computerName=Server1 -dest:webserver60 > msdeploy_test.log 

    Here is the instruction to sync IIS server from 6 to 7:

    https://technet.microsoft.com/en-us/library/ff633422(v=ws.10).aspx

    Best Regards,

    Yuk ding

    Tuesday, July 25, 2017 3:04 AM
  • User553537030 posted

    Okay, I ended up just loading up the old server, and migrating from IIS6 instead so I could import using the Web Deploy GUI. It worked, but my site will not start due to port 80 being in use already? I've ran a netstat command to check what is listening on that port, but the only reply is from a PID of 4, which is the System process... what can I do now?

    Friday, July 28, 2017 2:24 PM
  • User-460007017 posted

    Hi R4L,

    So what error message did you get when you were trying to start the website? The PID of 4 just means that IIS or SSRS was using the 80 port. If you could not start the website with 80 port. Just ensure all the 80 port sites have the host header in binding otherwise the port could not be shared. Besides, If you were using SSRS, try to disable it. In addition, just ensure the website has selected the correct application pool. You could try to change the application pool to another one, if the application pool doesn't exist or created incorrectly, the website will never start.

    Best Regards,

    Yuk Ding

    Monday, July 31, 2017 2:27 AM
  • User553537030 posted
    The error message was that the site could not start because the same port was already in use, but I just re-assigned new ports and all is good. Thanks for the help!
    Monday, July 31, 2017 2:31 AM