none
My SAP.COM has stopped working in Biztalk RRS feed

  • Question

  • Hi all,

    I am try to run command in Biztalk server (-t -a abbsgecd01.DESADV01 –g abbsgecd01 –x sapgw00) to register the program ID , But here showing error like

    My SAP.COM has stopped.

    Now i am doing to connect  SAP--> TO ---->Biztalk server

    1.what is the prablem in Biztalk side i instaled all 32 bit

    My SAP Bussiness suits RFC SDK files,

    Biztalk adapter pack X86 ,

    WCF LOB Adapter SDK 32 Bit

    and LOB files still i am getting this error.

    I nedd any additional instalation  ?

    Any bady help me it's very urgent.

    Thanks and Regards,

    Ram.

    Wednesday, September 15, 2010 9:19 AM

Answers

  • Hi Ram,

     

    are you sure the receive location is running on a 32bit host and that all you connection information and credentials are correct?

     

    If yes, contact your SAP team for RFC logging (ST01 or SM01) and SysLog Information (SM21).

     


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    Friday, September 17, 2010 1:20 PM

All replies

  • Can you post the complete error details from the event log?
    Friday, September 17, 2010 9:55 AM
  • Thanks. manas see i am getting this errors

    The receive location "Rcv_IDOCRequest_SAP" with URL "sap://CLIENT=134;LANG=EN;@d/ZBIZTALK?GWHOST=asmsgecd01.sg.asm.com&GWSERV=sapgw00&ListenerDest=ZBIZTALK&ListenerGwServ=sapgw00&ListenerGwHost=asmsgecd01.sg.asm.com&ListenerProgramId=DESADV01&RfcSdkTrace=True&AbapDebug=False" is shutting down. Details:"The Messaging Engine failed while notifying an adapter of its configuration. ".

    2.

    The Messaging Engine failed to add a receive location "Rcv_IDOCRequest_SAP" with URL "sap://CLIENT=134;LANG=EN;@d/ZBIZTALK?GWHOST=asmsgecd01.sg.asm.com&GWSERV=sapgw00&ListenerDest=ZBIZTALK&ListenerGwServ=sapgw00&ListenerGwHost=asmsgecd01.sg.asm.com&ListenerProgramId=DESADV01&RfcSdkTrace=True&AbapDebug=False" to the adapter "WCF-SAP". Reason: "Microsoft.ServiceModel.Channels.Common.ConnectionException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_BUSY. SapErrorMessage=CMALLC : rc=2 > Connect from SAP gateway to RFC server failed

    Connect_PM DEST=ZBIZTALK, GWHOST=ASMSGECD01, GWSERV=sapgw00, TPNAME=DESADV01

    LOCATION SAP-Gateway on host ASMSGECD01 / sapgw00

    ERROR program DESADV01 not registered

    TIME Fri Sep 17 16:04:44 2010

    RELEASE 700

    COMPONENT SAP-Gateway

    VERSION 2

    RC 679

    MODULE gwr3cpic.c

    LINE 1835

    DETAIL TP DESADV01 not registered

    COUNTER 2. AdapterErrorMessage=. ---> Microsoft.Adapters.SAP.RFCException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_BUSY. SapErrorMessage=CMALLC : rc=2 > Connect from SAP gateway to RFC server failed

    Connect_PM DEST=ZBIZTALK, GWHOST=ASMSGECD01, GWSERV=sapgw00, TPNAME=DESADV01

    Thanks.

    Ram.

    Friday, September 17, 2010 11:03 AM
  • Hi Ram,

     

    are you sure the receive location is running on a 32bit host and that all you connection information and credentials are correct?

     

    If yes, contact your SAP team for RFC logging (ST01 or SM01) and SysLog Information (SM21).

     


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    Friday, September 17, 2010 1:20 PM