Biometric Authentification Service is not functioning properly


  • Good Morning

    Logging into my HP ProBook 6540b laptop (windows7) using biometric authentification allows me to scan my fingerprint, start windows, do ctrl alt delete to login etc  but now i get the 'user' and 'swipe your finger to log on' icons appearing. The only one i can use is the 'user' icon to which i now have ot retype my password and next the HP ProtectTools Security Manager comes up with the hour glass.....waiting waiting waiting....and then i get the GUI  "The biometric authentication service is not functioning properly" and i am left with 2 options 1. "Log on without biometric functioality" or 2. "Wait 30 seconds, then try again". I did notice in the Biometric Authentication Service was not started in services but when i tried to start it i get this error "Windows could not start the BMS on local computer Error193:0xc1" Any one got any ideas on what i can try to fix this.....i was thinking of doing a complete restore but not if there is an y easy fix??





    • Moved by Sean LimingMVP Friday, February 17, 2017 3:42 PM Windows 7 Security Question
    Wednesday, August 18, 2010 11:35 PM

All replies

  • Hi, this does not seem to be related to embedded but I'll try to help anyway. The biometric behavior you mention is specific to the software used which is not part of the OS. My previous laptop was Toshiba and the behavior is different than that of HP I am using now. I would recommend to try to reinstall the "HP ProtectTools".

    Hope this helps


    • Proposed as answer by MattP - MS Saturday, October 02, 2010 12:04 AM
    Saturday, October 02, 2010 12:04 AM
  • I have this same issue - ProBook 4320s. Rick, were you ever able to solve this problem? I tried reinstalling Protect Tools and got an error with that too.
    Thursday, November 18, 2010 1:14 AM
  • Hi. I am encountering the same problem. Has anybody solved it?
    Tuesday, May 17, 2011 2:56 AM
  • same problem on HP 8540p
    Thursday, June 23, 2011 6:32 AM
  • same problem on HP 8540p

    The reason of this annoying problem is buggy software from HP – HP Protect Tools Security Manager.

    When you look at the System Event Log, there is Error from Service Control Manager: „The Biometric Authentication Service service terminated unexpectedly.  It has done this 1 time(s).“

    In application event log is also application error Faulting application name: DpHostW.exe, version: Faulting module name: vcsAPIShared.dll_unloaded Faulting application path: C:\Program Files\Hewlett-Packard\HP ProtectTools Security Manager\Bin\DpHostW.exe Faulting module path: vcsAPIShared.dll

    HP is notified about this error by Windows Error Reporting, but still there is no update for this.

    Temporary solution for this is to run faulted service: Start > Control Panel > Administrative Tools > Services > Biometric Authentication Service > Start

    • Proposed as answer by Halim Setiawan Thursday, January 05, 2012 3:01 AM
    Thursday, June 23, 2011 7:00 AM
  • From HP support;

    You amy also disable the 'Biometric Authentication' using group policy if you are not using the finger print authentication.

    1. Logon to the computer with administrator account.
    2. Click on Start button.
    3. At the bottom of start menu in search box type gpedit.msc and press enter key.
    4. On Local Group Policy Editor snap-in under Computer Configuration expand Administrative Templates and expand Windows Components.
    5. From the expanded list click on Biometrics and from the right pane double click on Allow users to log on using biometrics.
    6. On the opened window select Disabled radio button and click on Ok button to accept and confirm your configuration.
    7. Deny Biometric Authentication
    8. Close Local Group Policy Editor snap-in and open Command Prompt.
    9. In command window type gpupdate /force and press enter key to update your computer configuration with latest settings.
    10. Close Command Prompt.

    Monday, October 10, 2011 6:04 PM
  • I know this is an old topic, but I found a fix. 


    For those who have HP ProtectTools Security Manager, go to control panel then programs, and repair the program. It worked after I rebooted.

    Tuesday, October 18, 2011 5:36 PM
  • Hello

        same problem in My laptop hp pavilion dv2519tu .Because When I am using the Windows Vista on that Biometrices Finger print sensor is properly working but this time I am using Windows7 and I am installing driver properly but no detection of hardware is there.I generate question on standards that is used in hp product of hp laptops.



    maria sara

    • Edited by maria sara Monday, October 31, 2011 4:24 AM
    Monday, October 31, 2011 4:23 AM
  • I'm also having this issue, but two things happen for me:

    1.  This happens only when resuming from sleep mode

    2.  It is intermittent.

    3.  The crashing of the application does something to the RPC server, which in turn means I can no longer login to the system.  Any work I had open previously before the sleep may be lost as a result.

    I know this is probably not the best place as it's a MS forum but Jcdrummr, I thought I'd stop by to see if your repair solution had fixed your problem?  

    I have done it but awaiting the results (will take a week or two before the problem rears its ugly head again).





    Consultant | Nerd | Visionary. |
    Thursday, November 03, 2011 11:45 AM
  • Jason Kelton, I think I am having the same problem as you--the 'RPC server is unavailable' error pops up randomly when I try to authenticate after going into sleep mode. I'm running Windows 7 on a new HP ProBook 4530s. I will also try Jcdrummer's suggestion. In the meantime, I found that if I 'Switch user' whenever this happens, then log back into my user, I am able to log in without losing any work. Still, it's an annoying bug. Did the problem disappear for you after repairing HP ProtectTools?
    Saturday, November 26, 2011 4:20 AM
  • Hi Newtonics et. al.,


    OK I think my problem is fixed.  Well for the most part anyway.  Shortly after this post, HP released a new update for the Protect Tools software.  This seems to have fixed the RPC server is unavailable error.  Sometimes I do get the Biometric facility is unavailable not but I'm still able to get in to the system without using the fingerprint reader so no more problems.

    So I would recommend updating to the latest version of software which was released sometime within the last 2-3 weeks.

    What I have noticed though is the credential manager update sucks and is not as good as picking up credentials for other apps as well as it used to, so there is a tradeoff here.



    Consultant | Nerd | Visionary. |
    Saturday, November 26, 2011 4:25 AM
  • This solution works for me...

    i donot re install the application...

    i just start  the service "Biometric Authentication Service" and the fingerscan device works again :)


    thx lot

    Thursday, January 05, 2012 3:02 AM
  • Look like you take this article from HP support.

    It doesn't change anything, the error will still continue.

    Monday, October 05, 2015 7:29 PM
  • Doesn't fix... same error
    Monday, October 05, 2015 7:31 PM
  • I have Precision Tower 5810 and it did not solve my problem. 
    Friday, February 17, 2017 12:51 PM