locked
How to change the text on the first tab? RRS feed

  • Question

  • Hi,

    Thanks for reading my question. The problem is site name is appearing on the first tab of my SharePoint site. My site name consist of 5 words. Because of that my first tab is becoming very wider. I want to change it to something else. How can I do this? I found some piece of code to do that and I tried but it is not working. Is there any simple way to do that?

    FYI: I have only one tab and I am using "IT Team Workspace" template under Application Templates category. I am using SharePoint Server 2007.

    Any help will be appreciated. Thanks in advance.

     

     Moderator Note: later posts in this thread will not be understood if you aren't aware that the I am using SharePoint Server 2007" text was edited after later posts here!





    • Edited by SPTechie Monday, March 28, 2011 6:57 PM
    • Edited by Mike Walsh FIN Monday, March 28, 2011 7:46 PM Moderator Note amended to be 100% accurate - WSS 3.0 was mentioned in a later post. Here no product was mentioned at the beginning
    Friday, March 25, 2011 3:44 PM

Answers

  • Hi SPTechie,

    If you want to remove Home tab and active Publishing feature at the same time, please check out Kalik’s reply in this similar thread.

    Best regards,
    Emir

    • Marked as answer by David HM Friday, April 1, 2011 1:16 AM
    Tuesday, March 29, 2011 11:17 AM
  • Hi SPTechie,

    Thanks for your reply.

    Please try to add the control in the master page.

    Best regards,
    Emir

    • Marked as answer by David HM Friday, April 1, 2011 1:16 AM
    Wednesday, March 30, 2011 1:15 PM

All replies

  • You can cjhange the display name of the site under site settings --> Title, Description & Image on the left hand of the site administration screen under the look & feel heading.

    I'm curious as to this code you've found though, can you please share a link with us?


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Friday, March 25, 2011 4:02 PM
    Answerer
  • Steven: Thanks for your reply. I understand what you are saying. But my question is little bit different. I don't want to change my site name or title(even though it is long - its a division name). The problem is - whatever is the title of the site, it is appearing on the first tab. I want to change the text on the first tab.

    FYI: I have only one tab and I am using "IT Team Workspace" template under Application Templates category. I am using SharePoint services 3.0.

    Thanks.

     

    Friday, March 25, 2011 7:10 PM
  • > I am using "IT Team Workspace" template under Application Templates

    This was key information.

    Without it everyone assumes that you are using a SP 2007 product out-of-the-box.

    WSS 3.0 was also important information because the look of it is different to that of MOSS 2007 - but the use of an Application Template was *much* more important.

    Please put this kind of thing in your first posts in future.

    Moderator


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Friday, March 25, 2011 7:25 PM
  • Steven:

    If you notice in the following sites, the title of these sites are WSSV4FAQ and WSSV3FAQ and it has a home tab. I want to rename the home tab. That's it.

    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx

    Any suggestions please.

    Thanks.

     

    Friday, March 25, 2011 8:19 PM
  • Sure Mike. Will do from next time.

    Friday, March 25, 2011 8:22 PM
  • > ...WSSV4FAQ and WSSV3FAQ and it has a home tab. I want to rename the home tab.

    Site Actions / Site Settings / Top Link bar (second col; fourth item)

    Click on the Edit Box next to Home and you can change the text Home to something else.

    Mike


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Saturday, March 26, 2011 5:50 AM
  • Hi Mike,

    Thanks for your reply. I didn't find "Top Link bar" option in my SharePoint site settings even though I have full blown admin rights. Below is my second column items:

    Look and Feel

      Title, description, and icon
      Master page
      Navigation
      Tree view
      Site theme
      Reset to site definition
      Searchable columns
    Monday, March 28, 2011 2:20 PM
  • I can't answer this.

    I checked this on my own v3 site (see sig) and also have just checked that I was right that it was being hosted by a Windows SharePoint Services 3.0 system (by clicking the ? at the top-right of the default page).

    The version number of WSS 3.0 used there is 12.0.0.6421 and the order in that column is

    Title, description and icon

    Tree View

    Site Theme

    Top link bar

    Quick Launch

    Save site as template

    Reset to site definition

    when I access as an Administrator.


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Monday, March 28, 2011 3:26 PM
  • The link goes to (in my case)

    http://wssv3faq.mindsharp.com/_layouts/topnav.aspx

    you could try that address (i.e. add the _layouts etc. to your site's URL) and see if it goes to the correct page.

     


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters

    Monday, March 28, 2011 3:48 PM
  • Hi Mike,

    I appreciate your help.

    I really apologize for this. I thought I am using WSS 3.0 but when I clicked on ? at the top-right of the default page - it says "SharePoint Server 2007 Help".

    I read somewhere that - If the publishing feature is enabled then it shows  "Navigation" otherwise "Top Link Bar". I checked my site settings - publishing feature is disabled. I dont know why it is not showing "Top Link Bar".

    The link is going to the right place but it is showing all the subsites links not the first tab.

    http://wssv3faq.mindsharp.com/_layouts/topnav.aspx

    I tried this - Site Settings -> Navigation -> Navigation Editing and Sorting section. In the "Global Navigation" I added a link say "Home". By doing this it is creating a new tab just beside the first tab. 

    Any more ideas?

     

    Monday, March 28, 2011 6:56 PM
  • @Mike, your link challenges for authentication, which I can´t pass.  Is this supposed to be a public link?

    @SPtechie: Its a bit of a longshot but in your site collection features, can you see a site publishing feature?  If so, try activating this and seeing if the link Mike refers too appears.  Since Mike is on WSS, I don´t think that this is the answer, but we can at least check.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Monday, March 28, 2011 7:23 PM
    Answerer
  • >@Mike, your link challenges for authentication, which I can´t pass. 

    It would wouldn't it.

    I thought everyone would get the fact that they needed to replace my URL with their own URL before the _layouts !

    (and just in case they didn't I even added this  "(i.e. add the _layouts etc. to your site's URL) " and had before the link "in my case".)

    Could I have done more ?

    Mike (smiling - I'm sure I've made the same kind of mistake many times in the past)

     


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Monday, March 28, 2011 7:43 PM
  • Cheese almighty..yeah...my bad...
    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Monday, March 28, 2011 7:50 PM
    Answerer
  • Steven:

    I replaced Mike's URL with my SharePoint's URL before "_layouts...".

    I tried activating/deactivating publishing feature - it just add more options in "Site Actions" not the "Top Link Bar". In a publishing site, users create pages by working in the browser.

    Thanks.

     

     

    Monday, March 28, 2011 8:24 PM
  • Hi SPTechie,

    If you want to remove Home tab and active Publishing feature at the same time, please check out Kalik’s reply in this similar thread.

    Best regards,
    Emir

    • Marked as answer by David HM Friday, April 1, 2011 1:16 AM
    Tuesday, March 29, 2011 11:17 AM
  • Thanks Emir. That thread really helps. Its kind of same what I am trying to do. But I think my sharepoint is not a publishing site because I didn't find any "Publishing" tag in the code.

    What I am trying to do now is - changing the DataSoureID of the <SharePoint:aspmenu> control. It is working.

    It is raising another issue - When I click "View All Site Content", it is again displaying the site name on the first tab instead of my own text.

     

    Tuesday, March 29, 2011 5:18 PM
  • Hi SPTechie,

    Thanks for your reply.

    Please try to add the control in the master page.

    Best regards,
    Emir

    • Marked as answer by David HM Friday, April 1, 2011 1:16 AM
    Wednesday, March 30, 2011 1:15 PM
  • I found this

    http://weblogs.asp.net/bsimser/archive/2009/10/12/changing-the-home-tab-in-mutipage-meeting-workspaces-with-jquery.aspx

     

    Check if you can applay it in your site


    Destin -MCPD: SharePoint Developer 2010, MCTS:SharePoint 2007 Application Development
    Wednesday, March 30, 2011 3:35 PM
  • Hi Emir,

    I added in the master page but still if I click on "View All Site Content" it is showing up the site title name on the first tab.

    Thanks.

     

    Tuesday, April 5, 2011 6:05 PM
  • Destin: Thanks for your reply. I didn't find "Manage Pages" option in my SharePoint. May be because I don't have publishing feature enabled.
    Tuesday, April 5, 2011 6:08 PM
  • Yes You have to enable publishing feature then go to navigation under global links you can change the name.This is another option i hopes
    Destin -MCPD: SharePoint Developer 2010, MCTS:SharePoint 2007 Application Development
    Thursday, April 7, 2011 8:43 AM