locked
url scan suddenly blocking sites with permalinks RRS feed

  • Question

  • User-813868943 posted

    This is a windows 2003 server, which has been running fine for years.

    but all of a sudden, sites which have been working fine for years, are suddenly being blocked by url scan, with error sin the log like

    /rss.cfm/NewsID/293/ Rejected URL+contains+dot+in+path URL - -

    so any URL which has
    index.php/somehting also breaks, so all wordpress sites are breaking.

    URL SCAN HAS NOT BEEN UPDATED
    It is running version 3.1 and has been for a years
    urlscan.dll has not been modified since 2008

    url scan settings have not been changed.
    I have done a file compare against backup copies of the ini file to confirm this, and the only setting which has been changed is

    RemoveServerHeader=1 

    Which has no affect on this issue, changing it back to 0 makes no difference.

    In order to solve this issue I have had to change

    AllowDotInPath=1 

    But the questionis why ?
    This setting has always been set to 0 until now, and has worked fine, so I feel this is not the cause, and I have just found a workaround. So What has caused URL scan to suddenly start blocking all these url's

    Monday, June 2, 2014 11:11 AM

All replies

  • User-2064283741 posted
    Not used urlscan for years but that seems normal behaviour as the url does contain a dot.
    Tuesday, June 3, 2014 5:17 AM
  • User-813868943 posted

    No, something that has worked for years suddenly being blocked is not normal behaviour. But I suspect you didn't read the post properly before replying.

    Anyway no matter, I have solved it myself now.

    Tuesday, June 3, 2014 5:26 AM
  • User-2064283741 posted
    No I did read it properly I would expect that a dot in the url to be rejected.
    normal behaviour looks resumed.
    Tuesday, June 3, 2014 5:34 AM
  • User-813868943 posted

    no your still not getting it, but nevermind, it has been resolved.

    Tuesday, June 3, 2014 5:54 AM
  • User1183424175 posted

    Hi,

    I think the url /index.php/without something should work, so I think we should set AllowDotInPath=1 to allow "." in the path.

    For more configuration, you can refer here

    http://support.microsoft.com/kb/326444

    Tuesday, June 3, 2014 6:05 AM
  • User-813868943 posted

    Pengzhen, please read my previous replies.

    Tuesday, June 3, 2014 1:43 PM