none
VSTO Installer Error RRS feed

  • Question

  • Copied from my post in the Office 2013 forums. Hope this is OK -- they suggested I ask here as well.

    I developed a VSTO using the Visual Studio Tools for Office 2010 x64, targetting .NET 3.5. It's published as both an installer from disk and ClickOnce. It seems to install correctly for every combination of Windows and Office we want to support except for one: Server 2008 R2 and Office 2013 Professional. In either case of using the setup or ClickOnce installer, it errors out with a message box saying:

    The following Microsoft Office solution cannot be installed due to a general installer error: <name of vsto>

    0x80070057

    Checking the event log an error occurs during installation:

    Product: Microsoft Office Professional Plus 2013 -- Error 1304. Error writing to file: Policy.14.0.Microsoft.BusinessData.dll.  Verify that you have access to that directory.

    I am logged in with the local administrator account. I have tried turning off UAC, which doesn't help. In a somewhat related topic I cleared the application event log and that did not help either.

    Any suggestions?

    Friday, April 5, 2013 11:40 PM

Answers

  • Fixed itself after installing Visual Studio 2010 and 2008 Server R2 SP1.
    • Marked as answer by Jon W2 Saturday, April 6, 2013 6:55 PM
    Saturday, April 6, 2013 6:55 PM

All replies

  • Fixed itself after installing Visual Studio 2010 and 2008 Server R2 SP1.
    • Marked as answer by Jon W2 Saturday, April 6, 2013 6:55 PM
    Saturday, April 6, 2013 6:55 PM
  • Hi Jon,

    I'm glad to hear you've solve your issue.

    Thank you for sharing your solution which might also be helpful to other community members.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 8, 2013 2:36 AM
    Moderator
  • I think I still need to investigate why the add-in requires Visual Studio to be installed. I didn't even install the VSTO components -- only C#.
    Monday, April 8, 2013 4:09 PM
  • Did you ever find a solution besides installing Visual Studio? I need my VSTO powerpoint add-in to be able to install on computers that do not have Visual Studio installed.
    Tuesday, March 18, 2014 2:55 PM