none
Transit Option on Isochrone API RRS feed

  • Question

  • I just wanted to check if the ISOChrone API is working for Transit travel mode.

    I've tried the  NYC and Sydney. Giving either the long/lat or address waypoint I get 

    errorDetails":"Can't find transit connections.", they work fine for driving transit mode.

    Example queries, one for Grand Central, 1 for a Central Sydney station.

    https://dev.virtualearth.net/REST/v1/Routes/Isochrones?waypoint=89%20E%2042nd%20St%20New%20York%20NY&maxTime=30&travelMode=transit&key=myKey

    https://dev.virtualearth.net/REST/v1/Routes/Isochrones?waypoint=Martin%20Place%20Station%20Castlereagh%20St%20Sydney%20NSW&maxTime=30&travelMode=transit&key=myKey

    Anyone got any insights?

    Thursday, June 21, 2018 11:22 AM

All replies

  • Hi Sam,

    Based on the Docs, this should be working for transit.  See https://msdn.microsoft.com/en-us/library/mt814921.aspx

    I'll give your samples a try and see if I can get the same results.

    Sincerely,

    IoTGirl

    Friday, July 27, 2018 11:03 PM
    Owner
  • Does not work for me too. Anyone has a solution?
    Monday, December 17, 2018 12:21 AM
  • Hi Kasper,

    Can you provide a sample that fails?  This is an older thread and had confirmed that transit Isochrones are working for Sydney. Without providing your key, can you give the call and failure message?

    Sincerely,

    IoTGirl

    Monday, December 17, 2018 5:24 AM
    Owner
  • I tried the Get and the Post.

    For Post (https://dev.virtualearth.net/REST/v1/Routes/Isochrones?key=) the body was:

    { waypoint: "37.776883,-122.416759", maxTime: 50, timeUnit: "Minute", travelMode: "transit", dateTime: "2018-02-26T18:00:00-08:00" }

    For the Get the URI was:

    https://dev.virtualearth.net/REST/v1/Routes/Isochrones?waypoint=cheshunt&maxDistance=50&distanceUnit=mile&travelMode=transit&MaxTime=50&key={key}

    in both cases I get the following error:

    {
        "authenticationResultCode": "ValidCredentials",
        "brandLogoUri": "http://dev.virtualearth.net/Branding/logo_powered_by.png",
        "copyright": "Copyright © 2019 Microsoft and its suppliers. All rights reserved. This API cannot be accessed and the content and any results may not be used, reproduced or transmitted in any manner without express written permission from Microsoft Corporation.",
        "errors": [
            {
                "errorCode": "",
                "errorDetails": [
                    "Can't find transit connections."
                ]
            }
        ],
        "resourceSets": [],
        "statusCode": 200,
        "statusDescription": "Can't find transit connections.",
        "traceId": "6da5fd6353a5435588a75a65e278f434|DB40231537|7.7.0.0"
    }

    Does this work for transit?

    Friday, January 25, 2019 3:11 PM
  • Hi David,

    It seems like the 50 might be your issue.  Can you try assuming that this is seconds rather than minutes? The suspicion is that the timeUnit is not actually being set to minute in your call.

    Sincerely,

    IoTGirl

    Thursday, January 31, 2019 6:51 PM
    Owner