none
Framework not detected by any program and is installed RRS feed

  • Question

  • My problem is that programs won't find .NET Framework even though it's a part of the OS (Win 8)

    I have tried to reinstall several times but the installer says it's already installed.

    Help please!

    Sunday, June 9, 2013 10:00 AM

All replies

  • Hi Henrikx,

    Are you attempting to work with an older version of the .NET Framework on Win 8? (You're correct Framework is installed however a newer version) If you require an older version, you may need enable it?

    Here is a link - http://support.microsoft.com/kb/2785188?wa=wsignin1.0  Let me know if this is helpful.

    thanks,

    Norm

    Sunday, June 9, 2013 10:28 AM
  • Can you identify the .NET Framework version(s) these programs need?

    Windows 8 comes with .NET Frameworks 4.0 and 4.5 by default. Earlier versions must be installed.

    Try Norm"s helpful suggestion to install .NET Framework 2.0/3.0/3.5 on Windows 8 and let us know how it goes.


    • Edited by pvdg42 Sunday, June 9, 2013 5:19 PM
    Sunday, June 9, 2013 5:16 PM
  • Yes. All the stuff that is about NET framework is enabled
    Tuesday, June 11, 2013 11:55 AM
  • The programs need NET Framework v4.0

    Tuesday, June 11, 2013 11:56 AM
  • You can verify your .NET Framework 4.0 installation with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 4.0 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Tuesday, June 11, 2013 1:47 PM
  • ======================================================================
    [06/11/13,17:20:06] Beginning of new SetupVerifier activity logging session
    [06/11/13,17:20:06] Activity log file location: C:\Users\Henrikx\AppData\Local\Temp\setupverifier_main_06-11-13_17.20.06.txt
    [06/11/13,17:20:06] Error log file location: C:\Users\Henrikx\AppData\Local\Temp\setupverifier_errors_06-11-13_17.20.06.txt
    [06/11/13,17:20:06] Build created on September 10, 2012
    [06/11/13,17:20:06] Detected operating system: Windows 8 (x64)
    [06/11/13,17:20:06] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [06/11/13,17:20:06] Install state for .NET Framework 1.0: not installed.
    [06/11/13,17:20:06] Install state for .NET Framework 1.1: not installed.
    [06/11/13,17:20:06] Install state for .NET Framework 2.0: installed with service pack 2.
    [06/11/13,17:20:06] Install state for .NET Framework 3.0: installed with service pack 2.
    [06/11/13,17:20:06] Install state for .NET Framework 3.5: installed with service pack 1.
    [06/11/13,17:20:06] Install state for .NET Framework 4 Client: installed with no service packs.
    [06/11/13,17:20:06] Install state for .NET Framework 4 Full: installed with no service packs.
    [06/11/13,17:20:06] Install state for .NET Framework 4.5: installed with no service packs.

    AND

    [06/11/13,17:20:38] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
        Value: Version
        Actual Data:    REGISTRY VALUE FOUND
    [06/11/13,17:20:38] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries
    [06/11/13,17:20:38] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [06/11/13,17:20:38] ExecutablePath = 'Netfx40TestApplication.exe'
    [06/11/13,17:20:38] FriendlyName = '.NET Framework 4 test application'
    [06/11/13,17:20:38] TimeoutSeconds = '300'
    [06/11/13,17:20:38] WaitOnExit = 'true'
    [06/11/13,17:20:38] Silent = 'true'
    [06/11/13,17:20:38] Launching process 'Netfx40TestApplication.exe' now
    [06/11/13,17:20:38] Process successfully launched. Waiting 300 seconds for it to complete.
    [06/11/13,17:20:42] Process 'Netfx40TestApplication.exe' exited with return code 0
    [06/11/13,17:20:42] Verification succeeded for product .NET Framework 4 Full

    • Edited by henrikx Tuesday, June 11, 2013 3:25 PM
    Tuesday, June 11, 2013 3:22 PM
  • Your .NET Framework 4.0 verifies as correct.

    What is the application that cannot find it, and is the version you have certified Win 8 compatible by the publisher?

    Tuesday, June 11, 2013 4:05 PM
  • Any application can't find it "My problem is that programs won't find .NET Framework"

    Wednesday, June 19, 2013 2:32 PM