locked
Extended Club Starter Kit and SQL 2005 RRS feed

  • Question

  • User49523753 posted

    I have converted the Extended kit I think off of SQL express to SQL 2005.  I have both the membership db and the site db in SQL 2005, I also have updated the web config to point the provider to the new database but when I pull up the page after the solution is built I get this error...below the web.config connection strings. Any thoughts on why its pointing to a config in the framework directory?

    <connectionStrings>
      <remove name="LocalSqlServer" />
      <add name="ClubSiteDB" connectionString="Server=(local);Database=ClubSite;uid=clubsite;pwd=;"
       providerName="System.Data.SqlClient" />
      <add name="ASPNETDB" connectionString="Server=(local);Database=aspnetdb;uid=clubsite;pwd=;"
       providerName="System.Data.SqlClient" />
    </connectionStrings>

    ERROR
     

    Server Error in '/ClubSite' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: The specified connectionStringName, 'LocalSqlServer', was not registered.

    Source Error:

    Line 345:                <providers>
    Line 346:                    <add connectionStringName="LocalSqlServer"
    Line 347:                        name="AspNetSqlPersonalizationProvider" type="System.Web.UI.WebControls.WebParts.SqlPersonalizationProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    Line 348:                </providers>
    Line 349:

    Source File: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\web.config    Line: 347


    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

    Friday, February 16, 2007 12:44 PM

Answers

  • User49523753 posted

    If anyone wants it....

     <?xml version="1.0"?>
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
     <location path="events_edit.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
      <location path="admin">
        <system.web>
          <authorization>
            <allow roles="Administrators"/>
            <deny users="*"/>
          </authorization>
        </system.web>
      </location> 
     <location path="locations_edit.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
     <location path="news_edit.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
     <location path="photoalbum_new.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
     <location path="member_list.aspx">
      <system.web>
       <authorization>
        <deny users="?"/>
       </authorization>
      </system.web>
     </location>
     <location path="member_details.aspx">
      <system.web>
       <authorization>
        <deny users="?"/>
       </authorization>
      </system.web>
     </location>
     <connectionStrings>
      
      <remove name="LocalSqlServer" />
      <add name="ClubSiteDB" connectionString="Server=(local);Database=ClubSite;uid=clubsite;pwd=xxxxxx;"
         providerName="System.Data.SqlClient" />
      <add name="ASPNETDB" connectionString="Server=(local);Database=aspnetdb;uid=clubsite;pwd=xxxxxx;"
         providerName="System.Data.SqlClient" />
     </connectionStrings>
     <system.web>
      <xhtmlConformance mode="Strict"/>
      <roleManager enabled="true" defaultProvider="SqlRoleManager">
       <providers>
        <remove name="AspNetSqlRoleProvider" />
        <remove name="AspNetWindowsTokenRoleProvider" />
        <remove name="AspNetSqlPersonalizationProvider" />
        <add name="SqlRoleManager"
         type="System.Web.Security.SqlRoleProvider"
         connectionStringName="ASPNETDB"
         applicationName="Clubsite" />
       </providers>
      </roleManager>
      <authentication mode="Forms"/>
      <compilation debug="true">
       <assemblies>
        <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
       </assemblies>
      </compilation>
      <membership defaultProvider="CustomizedProvider">
       <providers>
        <remove name="AspNetSqlMembershipProvider" />
        <add name="CustomizedProvider"
          type="System.Web.Security.SqlMembershipProvider" 
          connectionStringName="ASPNETDB"
          applicationName="Clubsite"
          minRequiredPasswordLength="5"
          minRequiredNonalphanumericCharacters="0" />
       </providers>
      </membership>

      <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">
       <providers>
        <remove name="AspNetXmlSiteMapProvider"/>
        <add name="AspNetXmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>
       </providers>
      </siteMap>
      <!--<customErrors mode="RemoteOnly" defaultRedirect="ErrorPage.htm"/>-->
      <customErrors mode="Off"/>
      <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
      <webParts>
       <personalization defaultProvider="AspNetSqlPersonalizationProvider">
        <providers>
         <remove name="AspNetSqlPersonalizationProvider" />
         <add name="AspNetSqlPersonalizationProvider"
            type="System.Web.UI.WebControls.WebParts.SqlPersonalizationProvider"
            connectionStringName="ASPNETDB"
            applicationName="Clubsite" />
        </providers>
       </personalization>
      </webParts>
     </system.web>
    </configuration>

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 20, 2007 12:56 PM

All replies

  • User49523753 posted

    Membership line

    <roleManager enabled="true" defaultProvider="SqlRoleManager">

    <providers>

    <add name="SqlRoleManager"

    type="System.Web.Security.SqlRoleProvider"

    connectionStringName="ASPNETDB"

    applicationName="Clubsite" />

    </providers>

    </roleManager>

    <authentication mode="Forms"/>

    <compilation debug="true">

    <assemblies>

    <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    </assemblies>

    </compilation>

    <membership defaultProvider="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ASPNETDB" applicationName="ClubSite"/>

     

    Friday, February 16, 2007 2:08 PM
  • User49523753 posted
    Well I have successfully moved the Extended Club Starter Kit to SQL 2005, it was a pain staking task but I got it, with a hefty web config.  If anyone wants my web config and how I did it, let me know.
    Friday, February 16, 2007 4:14 PM
  • User-57859606 posted
    I'd be interested in the details -- I'm having trouble getting the same setup running here on my end.  Thanks in advance for any help.
    Monday, February 19, 2007 2:23 PM
  • User49523753 posted

    I have the working webconfig file on my laptop, I will post tomorrow when I get back to work.  I am not thrilled with the site though.  You will need to install a membership database on your sql server.  Usually you can do this by running reg_sql.exe from the framework dir. 

    Monday, February 19, 2007 7:23 PM
  • User-57859606 posted

    Actually, I was working with this late into the evening yesterday, and I finally gave up on the extended club site.  I've switched to the CodePlex version (http://www.codeplex.com/ClubStarterKit) and this works with no problem.  I just had endless difficulty with the extended kit, and the features it adds aren't that big of a deal to me.  I'd rather be spending my time developing new features than fighting with an install.

     Thanks very much for the offer of assistance.  I appreciate it.

    Tuesday, February 20, 2007 11:11 AM
  • User49523753 posted

    If anyone wants it....

     <?xml version="1.0"?>
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
     <location path="events_edit.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
      <location path="admin">
        <system.web>
          <authorization>
            <allow roles="Administrators"/>
            <deny users="*"/>
          </authorization>
        </system.web>
      </location> 
     <location path="locations_edit.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
     <location path="news_edit.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
     <location path="photoalbum_new.aspx">
      <system.web>
       <authorization>
        <allow roles="Administrators"/>
        <deny users="*"/>
       </authorization>
      </system.web>
     </location>
     <location path="member_list.aspx">
      <system.web>
       <authorization>
        <deny users="?"/>
       </authorization>
      </system.web>
     </location>
     <location path="member_details.aspx">
      <system.web>
       <authorization>
        <deny users="?"/>
       </authorization>
      </system.web>
     </location>
     <connectionStrings>
      
      <remove name="LocalSqlServer" />
      <add name="ClubSiteDB" connectionString="Server=(local);Database=ClubSite;uid=clubsite;pwd=xxxxxx;"
         providerName="System.Data.SqlClient" />
      <add name="ASPNETDB" connectionString="Server=(local);Database=aspnetdb;uid=clubsite;pwd=xxxxxx;"
         providerName="System.Data.SqlClient" />
     </connectionStrings>
     <system.web>
      <xhtmlConformance mode="Strict"/>
      <roleManager enabled="true" defaultProvider="SqlRoleManager">
       <providers>
        <remove name="AspNetSqlRoleProvider" />
        <remove name="AspNetWindowsTokenRoleProvider" />
        <remove name="AspNetSqlPersonalizationProvider" />
        <add name="SqlRoleManager"
         type="System.Web.Security.SqlRoleProvider"
         connectionStringName="ASPNETDB"
         applicationName="Clubsite" />
       </providers>
      </roleManager>
      <authentication mode="Forms"/>
      <compilation debug="true">
       <assemblies>
        <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
       </assemblies>
      </compilation>
      <membership defaultProvider="CustomizedProvider">
       <providers>
        <remove name="AspNetSqlMembershipProvider" />
        <add name="CustomizedProvider"
          type="System.Web.Security.SqlMembershipProvider" 
          connectionStringName="ASPNETDB"
          applicationName="Clubsite"
          minRequiredPasswordLength="5"
          minRequiredNonalphanumericCharacters="0" />
       </providers>
      </membership>

      <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">
       <providers>
        <remove name="AspNetXmlSiteMapProvider"/>
        <add name="AspNetXmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>
       </providers>
      </siteMap>
      <!--<customErrors mode="RemoteOnly" defaultRedirect="ErrorPage.htm"/>-->
      <customErrors mode="Off"/>
      <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
      <webParts>
       <personalization defaultProvider="AspNetSqlPersonalizationProvider">
        <providers>
         <remove name="AspNetSqlPersonalizationProvider" />
         <add name="AspNetSqlPersonalizationProvider"
            type="System.Web.UI.WebControls.WebParts.SqlPersonalizationProvider"
            connectionStringName="ASPNETDB"
            applicationName="Clubsite" />
        </providers>
       </personalization>
      </webParts>
     </system.web>
    </configuration>

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 20, 2007 12:56 PM
  • User-57859606 posted

    For the record, this did fix the last problem I was having.  I combined the two SQL Express databases into one SQL 2005 database, but I had neglected to include a web.config entry for the ASPNETDB database (which simply points at the same database as ClubSiteDB).

    I think I'm still going to keep using the CodePlex version, since that seems to be undergoing active development, but this will be useful for reference.

    Thanks again.

    Tuesday, February 20, 2007 6:15 PM
  • User-57859606 posted

    Actually, forget what I just said.  There was more wrong with my web.config than that.  I had followed the guidelines at http://www.edream.org/BlogArticle.aspx?RecordID=115 , but they just didn't cover everything.

    Your config is the way to go.  Congrats on figuring it out!

    Tuesday, February 20, 2007 6:20 PM
  • User49523753 posted

    Thanks, ya lots of trial and error.  I split my membership into a seperate db thats called aspnetdb....it was an old name used in like one of the first express kits (personal starter kit) but anyway you could have it all in one db and have just one connection string.  I glad I can help around here cause so many have helped me. 

     Anyway I was not digging the extended version either after I got it working, I am going to look into the codeplex one too, the extended seemed too much over the top.

    Tuesday, February 20, 2007 11:38 PM
  • User1084043625 posted

    Brilliant! Thank you so VERY much. I have been battling with this off and on for weeks. Thanks to you, this is the first time I have ever seen this starter kit. 

    Wednesday, November 17, 2010 1:51 PM