locked
Visual studio deployment error RRS feed

  • Question

  • While trying to deploy a share point project containing a web part into visual studio, This error keeps popping up "Error below"

    Error occurred in deployment step 'Recycle IIS Application Pool': Cannot connect to the SharePoint site: http://192.168.11.200:39171/. Make sure that this is a valid URL and the SharePoint site is running on the local computer. If you moved this project to a new computer or if the URL of the SharePoint site has changed since you created the project, update the Site URL property of the project.


    Heads up is much appreciated.
    Wednesday, October 31, 2012 1:28 PM

Answers

  • Hi,

     This may help you to fix this issue. First right click on the project and click "Clean" option. select your project by single mouse click and press "F4". And change from Default to No Activation and try to deploy. After that go to particular site collection and activate feature. Please refer the following screen shot


    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Proposed as answer by SekThang Friday, November 2, 2012 5:49 PM
    • Marked as answer by Jack-Gao Thursday, November 8, 2012 10:02 AM
    Friday, November 2, 2012 5:48 PM
  • Hi,

    1.Make sure the account you are trying to deploy the solution have sufficient access to the sharepoint farm.

    2. Make sure you deploy from the same machine (192.168.11.200), remote deployment is not possible.

    3.Make sure you run the VS as ADMIN.

    Thanks,

    Sudan

    • Marked as answer by Jack-Gao Thursday, November 8, 2012 10:02 AM
    Friday, November 2, 2012 5:53 PM

All replies

  • I've encoutered this error a few times.  For me one of three things fixed it (listed in order severity):

    1. Perform IISReset via command line
    2. Restart Visual Studio
    3. Reboot the server

    Brandon Atkinson
    Blog: http://brandonatkinson.blogspot.com

    Wednesday, October 31, 2012 2:30 PM
  • Thanks , Will check and get back to you if the problem stays.

    Thanks

    Wednesday, October 31, 2012 2:35 PM
  • If Brandons sugestion doesn't work it can be that you lack permission to the database. The easiest and best way to fix this is to use PowerShell and use the following command. Just change the domain\username to whatever you are using.

    You might need to do this with a user that has more rights than you have.

    Add-PSSnapin microsoft.sharepoint.powershell
    $contentdb = Get-SPContentDatabase -Site http://192.168.11.200:39171
    Add-SPShellAdmin -UserName DOMAIN\UserName -database $contentdb
    Also just starting visual studio with "run as administrator" can solve it aswell.
    Wednesday, October 31, 2012 2:43 PM
  • All, Non of the mentioned above worked. Anyone has any idea what the problem is ? Please if your answers are guesses , do not post them here.

    Thanks

    Friday, November 2, 2012 1:58 PM
  • Hi,

     This may help you to fix this issue. First right click on the project and click "Clean" option. select your project by single mouse click and press "F4". And change from Default to No Activation and try to deploy. After that go to particular site collection and activate feature. Please refer the following screen shot


    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Proposed as answer by SekThang Friday, November 2, 2012 5:49 PM
    • Marked as answer by Jack-Gao Thursday, November 8, 2012 10:02 AM
    Friday, November 2, 2012 5:48 PM
  • Hi,

    1.Make sure the account you are trying to deploy the solution have sufficient access to the sharepoint farm.

    2. Make sure you deploy from the same machine (192.168.11.200), remote deployment is not possible.

    3.Make sure you run the VS as ADMIN.

    Thanks,

    Sudan

    • Marked as answer by Jack-Gao Thursday, November 8, 2012 10:02 AM
    Friday, November 2, 2012 5:53 PM
  • If you changed the port in IIS for your SharePoint site it may differ from the registered application in your SharePoint farm.

    Look in the Central Administration and make sure that your Application matches the port in IIS. In your case, port 39171. You should be connecting by using the registered SharePoint application name. (I see you are using the IP.) 

    e.g. If the SharePoint application is MyPCName:39171, then use that in Visual Studio (http://MyPCName:39171/)

    Tuesday, November 6, 2012 5:57 PM
  • Thanks Jack-Gao

    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Thursday, November 8, 2012 12:15 PM