locked
IIS 5.1 for XP Pro with VWD2005 RRS feed

  • Question

  • User120353699 posted

    thanks for the assistance and forums!  There are 2 issues here, but one seems to be related to the other, so here goes...

     

    Environment:

    IIS 5.1 for xp pro using vwd2005.  (I cannot use the default localhost dev server due to central corporate authentication which uses cookies.)

     

    1st issue:

    IIS 5.1 is installed first and ASP.Net v2.0.50727 is registered using aspnet_regiis.exe -i, then install vwd2005.  Everything works fine at this point: i can debug (normally, see 2nd issue below) and edit.  Until I reboot.  After reboot, IIS hangs no matter how I try to access it: the management console or IIS admin and when I try to open the site with vwd2005, I get the nasty 'environment is waiting for an external operation to complete' message.  The workaround is to uninstall vwd, kick IIS a couple times, re-install vwd.  As you might guess, this is no way to make use of morning coffee.  What would cause IIS to hang only with vwd 2005 installed after a reboot?  The property page's 'start options' is set to use custom server with my 'http://<machine dns name>/' set as the base URL.

    2nd issue:

    The above scenario has worked out ok for several months, but after the latest workaround effort, I am suddenly getting 'unable to start debugging on the web server.  remote debugging is not supported' error.  1st, this isn't 'remote' debugging; second, this has worked well in the past.  My web.config has the debug option set to true and the IIS properties of the web site under 'Home Directory' application settings configuration, both the debugging flags are checked as enabled.  The start page's star options is set to use ASP.Net debuggers.  Any idea why this suddenly has stopped working?

     

    Thanks for any help that can be offered!

    ejowens

    Thursday, November 12, 2009 9:50 AM

All replies

  • User120353699 posted

    FYI:  Issue 2 is resolved...I had forgotten to install the service pack update... 

    Tuesday, November 24, 2009 11:27 AM