locked
Can't create a Silverlight 5 app in Visual Studio 2013 on 64 bit Windows 8 RRS feed

  • Question

  • I think I was able to create Silverlight apps on this box in the past, but having trouble now. So I uninstalled everything Silverlight. Downloaded SL 5 SDK and installed it. When I try to make a new SL C# project (or Oxygene for that matter), VS says "You need to install the latest Silverlight Developer runtime before creating a Silverlight project.

    SDK version 9.0.61118.0.

    What am I missing?

    Friday, June 19, 2015 7:28 PM

Answers

All replies

  • SL5 developer tools come with visual studio 2012/13.

    You might have to do a refresh (& pick components including Silverlight) on vs to add them back now.


    Hope that helps.

    Technet articles: WPF: Change Tracking; All my Technet Articles

    Monday, June 22, 2015 8:52 AM
    Moderator
  • I just had to find the right ones. Got it all going now. Although the service code generated by slSvcUtil won't compile. Looking into that now.

    This generated line:

       

    GuardianEditObservationServiceClientChannel nested in GuardianEditObservationServiceClient  = class(ChannelBase<IGuardianEditObservationService>, IGuardianEditObservationService)

    Caused this error:

    Error 63 (E380) Type "System.ServiceModel.ClientBase.ChannelBase<IGuardianEditObservationService,IGuardianEditObservationService>" cannot be used as ancestor for type "GuardianEditObservationServiceClient.GuardianEditObservationServiceClientChannel", because it does not have the right visibility C:\Users\Mark\Documents\Visual Studio 2013\Projects\SW\GuardianEditObservation\EOServerServiceInterface\GuardianEditObservationService.pas 716 5 EOServerServiceInterface

    Monday, June 22, 2015 1:04 PM
  • Hi mltiede,

    Can you create Silverlight app now? How do you do it? The problem was that the link that Visual Studio was giving was for the 32 bit version, and you are running 64 bit.

    Here is the link for the 64-bit version of Silverlight 5 developer tools:
    http://go.microsoft.com/fwlink/?LinkID=229324

    Tuesday, June 23, 2015 5:47 AM
  • I create them and I can run them ok now. But I still get the error above when trying to compile to use a service.
    • Edited by Mark Tiede Tuesday, June 23, 2015 12:09 PM
    Tuesday, June 23, 2015 12:09 PM
  • Hi Mark,

    I have seen that you have solved this issue at "RemObjects Talk", I will quote the thread here:

    http://talk.remobjects.com/t/cant-compile-slsvcutil-generated-class/6407

    It will be very beneficial for other communities who have similar problem. At currently, I will close this thread, if you have any difficulty in future, welcome to our forum.

    Best Regards,
    Weiwei

    Monday, June 29, 2015 2:56 AM
    Moderator