locked
The wait operation timed out. (Exception from HRESULT: 0x80070102) when requesting for pushNotification channel

    Question

  • Hi, I have been trying for push Notification Services in Windows 8 Store Apps. I am requesting For notification channel in the following manner

     

    publicasyncvoidregisterChannelForNotification( )

            {

               

    try


                {

                   

    TileUpdateManager.CreateTileUpdaterForApplication().Clear();

                   

    BadgeUpdateManager.CreateBadgeUpdaterForApplication().Clear();

                   

    varvProfile = NetworkInformation.GetInternetConnectionProfile();

                   

    if(vProfile.GetNetworkConnectivityLevel() == NetworkConnectivityLevel.InternetAccess)

                    {

                       

    varvChannel = awaitPushNotificationChannelManager.CreatePushNotificationChannelForApplicationAsync();

                       

    varvBuffer = CryptographicBuffer.ConvertStringToBinary(vChannel.Uri, BinaryStringEncoding.Utf8);

                       

    varvUri = CryptographicBuffer.EncodeToBase64String(vBuffer);

                       

    varvClient = newHttpClient();

                       

    try


                        {

                           

    varvResponse = awaitvClient.GetAsync(newUri(Constants.SERVER_URL));

                           

    if(vResponse.IsSuccessStatusCode)

                            {

                                sendDeviceTokenRequest(vChannel.Uri);

                            }

                        }

                       

    catch(HttpRequestException)

                        {

                        }

                    }

                }

               

    catch(Exceptionex)

                {

    }

                }

    This gives me the exception,The wait operation timed out. (Exception from HRESULT: 0x80070102) when requesting for pushNotification channel. What could be the possible reason and how to solve this issue


    Nikhil Sharma10

    Tuesday, August 19, 2014 9:17 AM

Answers

All replies

  • As per the documentation: http://msdn.microsoft.com/en-us/library/windows/apps/windows.networking.pushnotifications.pushnotificationchannelmanager.createpushnotificationchannelforapplicationasync.aspx the error means:

    0x80070102 The earlier channel request async operation has timed out. Apps should retry the channel request later using an exponential back-off strategy.

    The documentation explains the resolution steps as well.


    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog

    Tuesday, August 19, 2014 11:30 PM
    Moderator
  • Hi,

    I have currently the same problem with requesting a push channel.

    But iam not sure if it is a problem with my phone, or my application.

    I cant get rid of this error. The solution says: "retry the channel request later". But it doesn matter if I retry the channel request later (triggerd by pressing a button) the same day or the next day.

    I resetted my windows phone, installed the newest dev preview, but it is still not working. But the same code worked a few months ago. On the same phone.

    Thats why Iam not sure what I changed (accidentally) in my app code which causes now the 0x80070102 error.

    Any ideas why the same code is not working any more?

    Thanks

    Greetings from Germany

    Simon

    Thursday, January 15, 2015 1:29 PM
  • Are you sure you have a data connection - either Wi-Fi or cellular?

    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog

    Friday, January 16, 2015 12:32 AM
    Moderator
  • Yes, I always check 

    NetworkInformation.GetInternetConnectionProfile()

    before requesting a new channel.

    I installed today the new dev update and suprisingly no 0x8... error any more! I really dont know why, but now it is possible again to request a new push channel.

    Friday, January 16, 2015 9:57 AM
  • Ok, it is not really getting better.

    I can request a new channel. I can push notifications to my phone. WPN says everything went right:

    [StatusCode: 200, NotificationStatus: received, WNSStatus: received, DeviceStatus: connected]

    But neither my BackgroundTask, nor my notification listener get triggered. I cant receive the push notification.

    The same code worked a couple of months/weeks ago just fine. Iam really confused...


    Friday, January 16, 2015 8:47 PM
  • Hi,

    I'm getting the exact same issue. Have you found a solution to this?

    This code have been working for me in the past months, but now I needed to test again my app and I get a timeout exception:

    Channel = await PushNotificationChannelManager.CreatePushNotificationChannelForApplicationAsync();

    The wait operation timed out. (Exception from HRESULT: 0x80070102)

    Please help!

    Thursday, February 26, 2015 4:41 PM
  • I really dont know why, but it is working again.

    I dont have a solution, and I dont know what Ive changed in my code, but currently it is working without any problems

    Friday, February 27, 2015 8:13 AM