App only runs intermittently in Android Emulator RRS feed

  • Question

  • User369248 posted

    I create an AVD using Android Studio and try to run my Xamarin Android app from VS 2017. But most of the times, the app builds, deploys, but it does not run in the emulator. The emulator error says "app.Android has stopped working" and the console says "Android application is debugging".

    I have to always go and create a new AVD and clean the project, re build and run again. This will get it working sometimes but i do not understand this intermittent behaviour, plus it is very time consuming. Is it because of the AVD, Xamarin, or Android Properties ? Can anyone please suggest me a permanent solution to avoid this ?Thank you.

    Friday, September 14, 2018 7:39 PM

All replies

  • User371688 posted

    @Mayur534 You may try the following methods:

    1.right-click on the Android project > Properties > Android Option > Deselect "Use Fast Deployment" from the Packaging tab > Save 2.if not work, .Go to the Project Properties -> Build; Verify if you have a Platform Target and Platform .If not, customize one Platform Target for the entire solution: x86 or x64; 3.If it is still not work, try to access regedit.exe, navigating to HKEYLOCALMACHINE\SOFTWARE\Wow6432Node\Android, and changing the SDK path to my Xamarin Mono Android SDK folder. Example: The path originally is C:\Users[User]\AppData\Local\Android\android-sdk then change to C:\Users[User]\AppData\Local\Xamarin\MonoForAndroid\AndroidSDK For more details : https://forums.xamarin.com/discussion/64088/android-emulator-opens-but-project-does-not-deploy-and-start


    If you don't get it to work at the end, please collect the detail logs of your Emulator and post us,that would be really appreciated!

    Monday, September 17, 2018 5:12 AM
  • User369248 posted

    Thank you for your answer. I tried all the things you mentioned, and it works sometimes but still it does not work most of the times. This is the error that i get all the time: -

    10-03 14:52:18.298: E/AndroidRuntime(22048): Caused by: java.lang.ClassNotFoundException: Didn't find class "mono.MonoRuntimeProvider" on path: DexPathList[[zip file "/data/app/com.companyname.AppName-1/base.apk"],nativeLibraryDirectories=[/data/app/com.companyname.AppName-1/lib/arm, /data/app/com.companyname.AppName-1/base.apk!/lib/armeabi-v7a, /vendor/lib, /system/lib]]
    10-03 14:52:18.298: E/AndroidRuntime(22048):
    Wednesday, October 3, 2018 7:58 PM