Infopath Drop Down List not showing all items in a list RRS feed

  • Question

  • I have an Infopath form where I have a vendor drop down and then I filter the product list based on the vendor. The problem is the drop down list is only filtering through the first 100 records. I added a second drop down with the model#'s and no filter and there is only 100 values showing. I checked the All Items view and it is set to display all records. Does anyone know how to fix this?
    Wednesday, June 13, 2007 3:24 PM

All replies

  • Something about posting to a forum helps you find the problem on your own. I was using a list someone else created, I recreated the list as a custom list with 2 columns Vendor and Model and set it to show 1000 items, there are only about 550 in the list. All is working now. The first list had an option to display all records or to limit the records to a defined#. Not sure what list template the person used but it must have caused a problem. Hopefully this helps someone else who might come across this.
    Wednesday, June 13, 2007 3:48 PM
  • Thank you!  Strangely, the view option for my list was set to "show all" but the non-selected limit option was at 100.  I had assumed that was not the problem (the dropdowns within SP were not limited, just in Forms), but after reading your post I reset to 9999 and picked that instead.  Problem solved!


    Thursday, August 16, 2007 11:02 PM
  • Sorry but i don't find in Infopath 2003 the options to set "show all" or something. My Dropdowns are limited to 100.
    Can anyone give me a detailed summary how i can fix this problem ?

    In easy englisch please. I am from Germany Wink

    Tuesday, August 21, 2007 10:37 AM
  • The number of items to return is set within the default view for the SharePoint form library. This value is set to 100 by default.


    Tuesday, August 21, 2007 11:48 AM
  • The changes you need to make are in SharePoint; not in InfoPath. InfoPath uses the settings that have been defined for the item limit on the default view of a SharePoint list. You need to go to the SharePoint list, modify its settings, and change the item limit on the default view for the list to something greater than 100.


    Wednesday, August 22, 2007 1:56 AM
  • Hi,


    I'm having this problem with getting a user information list out of sharepoint. I'm using this list to populate a drop down field in infopath so users can choose from a list of all sharepoint users.


    This 100 default thing has applied itself to my user info list but I can't find where I would to change this. I understand your instructions about to do this with any normaly list in sharepoint but do you know where I would find the user info list and the settings to make this change?


    Also, when published into sharepoint, this list goes crazy and pulls through like NT/AUTHORITY info as well. I only want users listed and no one else. How do you set filters on infopath fields?



    Friday, August 31, 2007 2:51 AM

    I have a similar problem. I have a drop down list that populated "item numbers' and another filed that is "populated" depending on which item was selected from the drop down list. It took some struggling but I finally got this to work (or so i thought). It seems that if i choose one of the first 100 items in the drop down list, the "item description will populate accordingly. But if i choose the 101st item in the list, no results are returned to the "description" field. I am not using "sharepoint" this is a local access database on a network share. Does anyone have any ideas?
    Tuesday, December 11, 2007 5:24 PM
  • The User information List can be viewed in SP2007 by viewing 'All People'.  Update the detail view to show up to 9999 items......This resolved the problem for me.

    Saturday, December 15, 2007 9:35 PM
  • Hi all,

    If I want a drop down list in InfoPath (data coming from a SharePoint list) to be in a particular order I query the SharePoint list via this method

    You can create a data connection to a particular view in SharePoint - make sure that view is sorted how you want it to be and the item limit is set to 9999.

    You do not need code for this method and it works in browser enabled forms.

    The people picker (which also works in browser enabled forms) can help with those of you trying to get a list of users.

    Monday, February 16, 2009 10:02 PM
  • Change the default view limit of the list from 100 to 200 or more. It should display more than 100.


    Wednesday, January 28, 2015 6:45 PM